Re: JRE 1.6 .002 install: JVM does not find libs under /opt/OV/lib and throws Unsatisfied link error (306 Views)
Reply
Occasional Visitor
Akhil Khandelwal
Posts: 3
Registered: ‎04-27-2009
Message 1 of 5 (306 Views)

JRE 1.6 .002 install: JVM does not find libs under /opt/OV/lib and throws Unsatisfied link error

After i install jre1.6.002 depot jvm some how is not able to locate the libraries under /opt/OV/lib and subsequent calls to JNI layes fail. Every thing looks perfect with JRE1.5 version.
And once i set the SHLIB_PATH to /opt/OV/lib,every thing looks great.
This happens only in HP-UX PA.

Any idea.

Regards,
Akhil
Acclaimed Contributor
Dennis Handly
Posts: 25,190
Registered: ‎03-06-2006
Message 2 of 5 (306 Views)

Re: JRE 1.6 .002 install: JVM does not find libs under /opt/OV/lib and throws Unsatisfied link error

>And once I set the SHLIB_PATH to /opt/OV/lib,every thing looks great.

I'm not sure why you think a generic JVM would know anything at all about /opt/OV/lib, unless you used SHLIB_PATH?
Occasional Visitor
Akhil Khandelwal
Posts: 3
Registered: ‎04-27-2009
Message 3 of 5 (306 Views)

Re: JRE 1.6 .002 install: JVM does not find libs under /opt/OV/lib and throws Unsatisfied link error

Hi Dennis,
Seems we have rpath entries in our Imakefile to /opt/OV/lib. I assume jvm looks into this path while looking out for libraries.
These all works with JRE1.5. But after installation of JRE 1.6.002, some how jvm lost this info.

Regards,
Akhil
Acclaimed Contributor
Dennis Handly
Posts: 25,190
Registered: ‎03-06-2006
Message 4 of 5 (306 Views)

Re: JRE 1.6 .002 install: JVM does not find libs under /opt/OV/lib and throws Unsatisfied link error

>Seems we have rpath entries in our Imakefile to /opt/OV/lib.

What were you making? A JNI shlib that uses /opt/OV/lib? (Is this 64 bit?)

>some how jvm lost this info.

This probably has nothing to do with JVM, most likely dld. Do you have the latest patches?
Occasional Visitor
Akhil Khandelwal
Posts: 3
Registered: ‎04-27-2009
Message 5 of 5 (306 Views)

Re: JRE 1.6 .002 install: JVM does not find libs under /opt/OV/lib and throws Unsatisfied link error

I have installed patch mentioned here -

http://docs.hp.com/en/HPUXJAVAPATCHES/g-11.23-6.0-1123.0712.html

Do i need to install any other patch?
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.