Installing Sun-Oracle´s JDK 1.6 Java SE 6 Update 25 in HP-UX 11i v1 PARISC (783 Views)
Reply
Occasional Visitor
aogsg2000
Posts: 2
Registered: ‎05-09-2011
Message 1 of 4 (783 Views)

Installing Sun-Oracle´s JDK 1.6 Java SE 6 Update 25 in HP-UX 11i v1 PARISC

[ Edited ]

Hello,

I have a doubt:

Can I install Oracle/Sun´s JDK 1.6 Java SE 6 in someone HP-UX 11i v1 PARISC server?

Thanks a lot.

Antonio



P.S.This thread has been moved from  HP-UX > System Administration to HP-UX > languages -HP Forums Moderator

Honored Contributor
Matti_Kurkela
Posts: 6,271
Registered: ‎12-02-2001
Message 2 of 4 (783 Views)

Re: Installing Sun-Oracle´s JDK 1.6 Java SE 6 Update 25 in HP-UX 11i v1 PARISC

Oracle/Sun does not provide JDK for HP-UX: neither for PA-RISC nor for Itanium. Anything you might download from Oracle/Sun won't work in HP-UX.

But HP gets the JDK source code from Oracle/Sun, ports it for HP-UX and packages it into familiar HP-UX software depots.

You can download the ported versions at:
http://www.hp.com/go/java

Note: JDK 1.6 has several OS patch requirements, especially for an old HP-UX version like 11i v1. The required patch levels for each JDK version are listed here:

http://ftp.hp.com/pub/softlib/hpuxjava-patchinfo/index.html

Make sure your system is patched to the required level before attempting to run any Java applications with your new JDK.

MK
MK
Occasional Visitor
aogsg2000
Posts: 2
Registered: ‎05-09-2011
Message 3 of 4 (783 Views)

Re: Installing Sun-Oracle´s JDK 1.6 Java SE 6 Update 25 in HP-UX 11i v1 PARISC

Hello Matti,

Firstly, thank you. Other question:

- Then, if JBOSS Applicattion Server 5.1.0GA is certificated for SUN JDK 1.6 then, Could I think that JBOSS Applicattion Server 5.1.0GA is certificated and compliant for HP-JDK 1.6?


Thanks a lot!

Honored Contributor
Matti_Kurkela
Posts: 6,271
Registered: ‎12-02-2001
Message 4 of 4 (783 Views)

Re: Installing Sun-Oracle´s JDK 1.6 Java SE 6 Update 25 in HP-UX 11i v1 PARISC

Each HP JDK should be functionally identical to the respective Oracle/Sun JDK version. If there are any exceptions, they should be clearly documented in the release notes. (I would expect those exceptions, if any exist, to be minor and mostly related to the properties of HP-UX.)

So yes, it should work. But "certificated"? That would usually mean that someone responsible for that certification has tested JBoss on a specific JDK version on a specific hardware platform, i.e. HP-UX/PA-RISC or HP-UX/Itanium. Open-source projects may not have resources to test all possible hardware/JDK combinations with their software.

MK
MK
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.