Re: Getting error while install Apache 2.2.24 on HPUX 11.31 (449 Views)
Reply
Advisor
Tushar_hiwase
Posts: 29
Registered: ‎08-20-2012
Message 1 of 3 (480 Views)

Getting error while install Apache 2.2.24 on HPUX 11.31

[ Edited ]

Hi,

 

I am trying to install Apache 2.2.24 on HPUX 11iv3 server. When trying to "make" getting below error.

 

(Bundled) cc: warning 922: "-b" is unsupported in the bundled compiler, ignored.
ld: Unknown input file type: "/opt/hpws22/httpd-2.2.24/srclib/apr-util/xml/expat/.libs/libexpat.so"
Fatal error.
*** Error exit code 1

Stop.
*** Error exit code 1

Stop.
*** Error exit code 1

Stop.
*** Error exit code 1

Stop.
#

 

seems like missing cc compiler as per the above mentioned errors. But see the below output.

 

# which cc
/usr/bin/cc
#

 

I have checked the README.platforms from the apache bundle. its saying that "cpprt0_stub.s" need to install.

 

Is it the problem with C++ compiler. Do i need to install this package ? From where can i get this package ?

I have checked the link as per mentioned in README.platforms, but no luck, didn't get package there.

 

http://h21007.www2.hp.com/hpux-devtools/CXX/hpux-devtools.0107/0083.html

 

 

 

thanks in advance

 

 

P.S. This thread has been moved from HP-UX > System Administration to HP-UX > languages

 

Acclaimed Contributor
Dennis Handly
Posts: 25,274
Registered: ‎03-06-2006
Message 2 of 3 (467 Views)

Re: Getting error while install Apache 2.2.24 on HP-UX 11.31

>I am trying to install Apache 2.2.24 on HP-UX 11.31 server.

 

There are no prebuilt versions?

 

>(Bundled) cc: warning 922: "-b" is unsupported in the bundled compiler, ignored.
ld: Unknown input file type: "/opt/hpws22/httpd-2.2.24/srclib/apr-util/xml/expat/.libs/libexpat.so"

>seems like missing cc compiler as per the above mentioned errors.

 

You'll need to purchase the aC++ compiler to build the application.  You can't develop using the bundled C compiler.

What does "file /opt/hpws22/httpd-2.2.24/srclib/apr-util/xml/expat/.libs/libexpat.so" show?

 

>I have checked the README.platforms from the apache bundle. it's saying that "cpprt0_stub.s" need to install.

 

That would only be for PA-RISC.

 

>I have checked the link as per mentioned in README.platforms

http://h21007.www2.hp.com/hpux-devtools/CXX/hpux-devtools.0107/0083.html

 

This link is also dead.  What started you here?

Frequent Advisor
SoumitraC
Posts: 26
Registered: ‎03-21-2012
Message 3 of 3 (449 Views)

Re: Getting error while install Apache 2.2.24 on HPUX 11.31

Unless you have a very specific version requirement, you can install the binary package directly:

http://hpux.connect.org.uk/hppd/hpux/Networking/WWW/apache-2.4.4/

 

For building from source, you'll need to purchase the aC++ developer's bundle (see http://hp.com/go/acc). You'll also need to first build all of the pre-requisites from source using the same.

 

Another alternative would be to use the free GNU compilers (see http://hp.com/go/gcc).

 

Note that typically, building FSF packages would also require you to have the GNU build tools (gmake, m4, autoconf, etc) installed on your system.

 

Soumitra C
HP-UX Compilers
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.