Compiling on HPUX 11.31 Itanium with ldap library (273 Views)
Reply
Highlighted
Occasional Advisor
Posts: 8
Registered: ‎05-30-2010
Message 1 of 4 (273 Views)
Accepted Solution

Compiling on HPUX 11.31 Itanium with ldap library

I am compiling 32-bit program with ldap libray and error occur "ld: Mismatched ABI (not an ELF file) for -lldap50, found /iseprod/ivrshrt/.lib/libldap50.sl".

I have checked the library libldap50.sl is 32-bit.
$ file /iseprod/ivrshrt/.lib/libldap50.sl
/iseprod/ivrshrt/.lib/libldap50.sl: PA-RISC1.1 shared library -not stripped

Is there any other reason cause the error?
Acclaimed Contributor
Posts: 25,902
Registered: ‎03-06-2006
Message 2 of 4 (273 Views)

Re: Compiling on HPUX 11.31 Itanium with ldap library

Besides having to match on bitness, you have to match on architecture.
Your shlib is PA, you need an Integrity version.
Occasional Advisor
Posts: 8
Registered: ‎05-30-2010
Message 3 of 4 (273 Views)

Re: Compiling on HPUX 11.31 Itanium with ldap library

Thanks.
Cause the library was copied from old machine. Problem solved by using a IA64 version library.
Occasional Advisor
Posts: 8
Registered: ‎05-30-2010
Message 4 of 4 (273 Views)

Re: Compiling on HPUX 11.31 Itanium with ldap library

Thanks.
Cause the library was copied from old machine. Problem solved by using a IA64 version library.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.