HP 2915 VLAN Routing (265 Views)
Reply
Visitor
All8up
Posts: 2
Registered: ‎09-09-2013
Message 1 of 2 (265 Views)

HP 2915 VLAN Routing

I am trying to get VLAN routing setup on this 8 port switch. Putting in a whole new infrastructure for a school and implementing several VLANs and now trying to incorporate thier old network/server/subnet into the new infrastructure. Essentially I am wanting to hang the old server off of this switch and move all the clients to the new infrastructure while still maintaining connectivity to the old server. The main subnet for the infrastructure is on the 192.168.10.x subnet and the old subnet is 192.168.1.x. I can ping the 192.168.1.254 IP that I gave that port from the device itself but not from any other device on that subnet. If I run a traceroute from any other device on the subnet I get a loop type response from 192.168.10.9, the IP of the primary VLAN. I also can't ping a device I have plugged into this port just for testing purposes. I am a total novice when it comes to VLANs and have everything else functioning I believe, just not this piece of the puzzle. Any/all guidance is appreciated!

 

Here is the device's current configuration. The 192.168.10.20 device is another routing switch that services all the the other VLANs in the network.

 

 

; J9562A Configuration Editor; Created on release #A.15.09.0015
; Ver #03:01.15.05:12
hostname "Server Rack 2915"
timesync sntp
sntp unicast
sntp server priority 1 192.168.10.5
time timezone -6
ip dns server-address priority 1 192.168.10.5
ip dns server-address priority 2 192.168.10.6
ip route 0.0.0.0 0.0.0.0 192.168.10.20
snmp-server community "public" unrestricted
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-10
   ip address 192.168.10.9 255.255.255.0
   exit
vlan 15
   name "OldZone"
   tagged 7
   ip address 192.168.1.254 255.255.255.0
   ip helper-address 192.168.10.5
   exit

 

Please use plain text.
Visitor
All8up
Posts: 2
Registered: ‎09-09-2013
Message 2 of 2 (244 Views)

Re: HP 2915 VLAN Routing

I was able to figure this out by reading several different of the threads in here and a bit of trial/error and can now ping/access to the VLAN 15 from VLAN 1. Going to go out to th client and do some more testing as far as the DHCP relay functionality and access from VLAN 15 to the other VLANs, there are 8 more that use an Adtran L3 switch to route. Next up will be getting the HP MSM760 Wireless Controller configuration hammered out.

 

Anyway, here is the config that got traffic flowing proper as I can tell at this point:

; J9562A Configuration Editor; Created on release #A.15.09.0015
; Ver #03:01.15.05:12
hostname "Server Rack 2915"
timesync sntp
sntp unicast
sntp server priority 1 192.168.10.5
time timezone -6
ip dns server-address priority 1 192.168.10.5
ip dns server-address priority 2 192.168.10.6
ip route 0.0.0.0 0.0.0.0 192.168.10.20
ip routing
snmp-server community "public" unrestricted
vlan 1
   name "DEFAULT_VLAN"
   no untagged 7
   untagged 1-6,8-10
   ip address 192.168.10.9 255.255.255.0
   exit
vlan 15
   name "OldZone"
   untagged 7
   ip address 192.168.1.254 255.255.255.0
   ip helper-address 192.168.10.5
   exit

 

 

The changes I made were to add the "ip routing" statement even though the manual says it is enabled by default, removed port 7 from the VLAN 1 list, and switch VLAN 15 port 7 to untagged.

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation