Re: make_tape_recovery completed unsuccessfully (1473 Views)
Reply
Regular Advisor
EU-Admins-UNIX
Posts: 196
Registered: ‎09-23-2011
Message 1 of 17 (1,510 Views)
Accepted Solution

make_tape_recovery completed unsuccessfully

HI


I have installed Ignite C.7.13.259 on an 11.31 RP8420.

 

I am trying to:

 

/opt/ignite/bin/make_tape_recovery -I -a /dev/rmt/4mn -x inc_entire=vg00 -v 2>&1 | tee /tmp/recovery_tape.txt

 

But I am getting:

 

** 0 - The Volume Group or Filesystem is Not included in the
               System Recovery Archive
        ** 1 - The Volume Group or Filesystem is Partially included in the
               System Recovery Archive
        ** 2 - The Volume Group or Filesystem is Fully included in the
               System Recovery Archive

       * Scanning system for IO devices...
       * Boot device is: 0/0/0/2/0.0x6.0x0
ERROR:   System Error, /opt/ignite/bin/make_medialif failed creating boot LIF file.
ERROR:   Failed to generate LIF on tape.

       * Creating local directories for configuration files and archive.

=======  01/31/12 10:25:33 GMT  Started /opt/ignite/bin/make_tape_recovery. (Tue Jan 31 10:25:33 GMT 2012)
         @(#)Ignite-UX Revision C.7.13.259
         @(#)ignite/net_recovery (opt) Revision: /branches/IUX_RA1109/ignite/src@83994 Last Modified: 2011-08-22 13:38:37 +0530 (Mon, 22 Aug 2011)

       * Recovery Archive Description = Recovery Archive

       * Recovery Archive Location    = /dev/rmt/4mn

       * Number of Archives to Save   = 2

       * Pax type  = tar


        In?     dsk/vg  name                    minor#  Associated disks/mountpoints
        2       v       /dev/vg00               0x00    /dev/disk/disk2
                                                /dev/vg00/lvol1 /stand  2
                                                /dev/vg00/lvol2
                                                /dev/vg00/lvol3 /       2
                                                /dev/vg00/lvol4 /opt    2
                                                /dev/vg00/lvol5 /tmp    2
                                                /dev/vg00/lvol6 /usr    2
                                                /dev/vg00/lvol7 /home   2
                                                /dev/vg00/lvol8 /var    2
       * Checking Versions of Ignite-UX filesets
       * Creating System Configuration.
       * /opt/ignite/bin/save_config -f /var/opt/ignite/recovery/2012-01-31,10:25/system_cfg vg00
       * Backing Up Volume Group /dev/vg00
       * /usr/sbin/vgcfgbackup /dev/vg00
       * Creating Map Files for Volume Group /dev/vg00
       * /usr/sbin/vgexport -s -p -m /etc/lvmconf/vg00.mapfile /dev/vg00

       * Creating Control Configuration.
       * Creating Archive File List
       * Creating Archive Configuration

       * /opt/ignite/lbin/make_arch_config -c /var/opt/ignite/recovery/2012-01-31,10:25/archive_cfg -g /var/opt/ignite/recovery/2012-01-31,10:25/flist -n
         2012-01-31,10:25 -r pa -b 64 -d Recovery\ Archive -t 1 -i 1 -m t
       * Saving the information about archive to /var/opt/ignite/recovery/previews
       * Creating The Tape Archive
       * Checking configuration file for Syntax
make_medialif: ERROR: Cannot lifcp -r -K2 file "/opt/ignite/data/Rel_B.11.31/SYSCMDSIA" to "/var/tmp/uxinstlf.recovery:SYSCMDSIA":
        lifcp: Cannot create SYSCMDSIA ; no space on the LIF volume

=======  01/31/12 10:26:16 GMT  make_tape_recovery completed unsuccessfully

 

I have tried installing PHSS_27407, but I am facing the swinstall message:

 

 Currently, there are no products on this source which are compatible │   │
│┌──│ with the target.  Therefore, no products are shown.   

 

I'm confused.

 

Can you help please?

 

Regards

 

Tariq

Please use plain text.
Acclaimed Contributor
Torsten.
Posts: 23,200
Registered: ‎10-02-2001
Message 2 of 17 (1,508 Views)

Re: make_tape_recovery completed unsuccessfully

The patch is for 11.00, this cannot work at all.


>> make_medialif: ERROR: Cannot lifcp -r -K2 file "/opt/ignite/data/Rel_B.11.31/SYSCMDSIA" to "/var/tmp/uxinstlf.recovery:SYSCMDSIA":
lifcp: Cannot create SYSCMDSIA ; no space on the LIF volume


Still enough space in /var/tmp ??

Hope this helps!
Regards
Torsten.

__________________________________________________

There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________

No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! star in the left column!   
Please use plain text.
Regular Advisor
EU-Admins-UNIX
Posts: 196
Registered: ‎09-23-2011
Message 3 of 17 (1,507 Views)

Re: make_tape_recovery completed unsuccessfully

Torsten

 

I have 16GB available.

 

# bdf
Filesystem          kbytes    used   avail %used Mounted on
/dev/vg00/lvol3    2097152  333312 1750072   16% /
/dev/vg00/lvol1    1776056   40800 1557648    3% /stand
/dev/vg00/lvol8    16777216  426384 16223216    3% /var
/dev/vg00/lvol6    6291456 2105376 4153472   34% /usr
/dev/vg00/lvol5    4194304  466728 3698456   11% /tmp
/dev/vg00/lvol4    8388608 3555040 4795864   43% /opt
/dev/vg00/lvol7     131072    5792  124312    4% /home

 

 

Please use plain text.
Acclaimed Contributor
Torsten.
Posts: 23,200
Registered: ‎10-02-2001
Message 4 of 17 (1,504 Views)

Re: make_tape_recovery completed unsuccessfully

I assume google delivers you some pages with this old patch mentioned. As you can see, this should be solved since years.

The strange thing is, it complaines about "SYSCMDSIA" - this is for itanium.

But you say you have a RISC based system (model?).

# model

In a very first step I would eject and re-insert the tape into the drive and run



# /opt/ignite/bin/make_tape_recovery -x inc_entire=vg00 -I -v -a /dev/rmt/4mn

Hope this helps!
Regards
Torsten.

__________________________________________________

There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________

No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! star in the left column!   
Please use plain text.
Regular Advisor
EU-Admins-UNIX
Posts: 196
Registered: ‎09-23-2011
Message 5 of 17 (1,502 Views)

Re: make_tape_recovery completed unsuccessfully

Torsten

 

I have arranged for our onsite to re-insert the tape.

 

Meanwhile:

 

# model
9000/800/rp8420
# uname -a
HP-UX lordrapo B.11.31 U 9000/800 3502276056 unlimited-user license
# swlist | grep -i ignite
  IGNITE                C.7.13.259     HP-UX Installation Utilities (Ignite-UX)
  Ignite-UX-11-31       C.7.13.259     HP-UX Installation Utilities for Installing 11.31 Systems

 

Regards

 

Tariq

Please use plain text.
Acclaimed Contributor
Torsten.
Posts: 23,200
Registered: ‎10-02-2001
Message 6 of 17 (1,498 Views)

Re: make_tape_recovery completed unsuccessfully

Meanwhile you could try to rewind the tape first

# mt -f /dev/rmt/4mn rew

and then run

# /opt/ignite/bin/make_tape_recovery -x inc_entire=vg00 -I -v -a /dev/rmt/4mn

What kind of tape drive is it?

# ioscan -fn

Hope this helps!
Regards
Torsten.

__________________________________________________

There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________

No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! star in the left column!   
Please use plain text.
Regular Advisor
EU-Admins-UNIX
Posts: 196
Registered: ‎09-23-2011
Message 7 of 17 (1,496 Views)

Re: make_tape_recovery completed unsuccessfully

# ioscan -fnCtape
Class     I  H/W Path        Driver S/W State   H/W Type     Description
========================================================================
tape      4  0/0/12/1/1.1.0  stape   CLAIMED     DEVICE       HP      Ultrium 4-SCSI
                            /dev/rmt/4m            /dev/rmt/4mn           /dev/rmt/c5t1d0BEST    /dev/rmt/c5t1d0BESTn
                            /dev/rmt/4mb           /dev/rmt/4mnb          /dev/rmt/c5t1d0BESTb   /dev/rmt/c5t1d0BESTnb
tape      5  0/0/14/1/1.2.0  stape   CLAIMED     DEVICE       HP      Ultrium 4-SCSI
                            /dev/rmt/5m            /dev/rmt/5mn           /dev/rmt/c7t2d0BEST    /dev/rmt/c7t2d0BESTn
                            /dev/rmt/5mb           /dev/rmt/5mnb          /dev/rmt/c7t2d0BESTb   /dev/rmt/c7t2d0BESTnb

 

I have also tried rewinding, makes no differnce!

Please use plain text.
Regular Advisor
EU-Admins-UNIX
Posts: 196
Registered: ‎09-23-2011
Message 8 of 17 (1,493 Views)

Re: make_tape_recovery completed unsuccessfully

Torsten

 

Re-inserting the drive made no difference.

 

make_medialif: ERROR: Cannot lifcp -r -K2 file "/opt/ignite/data/Rel_B.11.31/SYSCMDSIA" to "/var/tmp/uxinstlf.recovery:SYSCMDSIA":
        lifcp: Cannot create SYSCMDSIA ; no space on the LIF volume
ERROR:   System Error, /opt/ignite/bin/make_medialif failed creating boot LIF file.
ERROR:   Failed to generate LIF on tape.


=======  01/31/12 12:16:19 GMT  make_tape_recovery completed unsuccessfully

 

# ll /opt/ignite/data/Rel_B.11.31/
total 376080
-r--r--r--   1 bin        bin        21445113 Aug 28 20:33 INSTCMDS
-r--r--r--   1 bin        bin        42518018 Aug 28 21:32 INSTCMDSIA
-r--r--r--   1 bin        bin         297609 Aug 28 20:33 RECCMDS
-r--r--r--   1 bin        bin         576410 Aug 28 21:32 RECCMDSIA
-r--r--r--   1 bin        bin        48631242 Aug 28 20:34 SYSCMDS
-r--r--r--   1 bin        bin        79022478 Aug 28 21:33 SYSCMDSIA
-r--r--r--   1 bin        bin          22999 Aug 28 18:30 config
-r--r--r--   1 bin        bin            927 Aug 28 20:47 hw_patches_cfg

 

 

Please use plain text.
Acclaimed Contributor
Torsten.
Posts: 23,200
Registered: ‎10-02-2001
Message 9 of 17 (1,491 Views)

Re: make_tape_recovery completed unsuccessfully

Hmmm, could you compare the file size

/var/tmp/uxinstlf.recovery

with a known to work system and also

lifls -v /var/tmp/uxinstlf.recovery

Hope this helps!
Regards
Torsten.

__________________________________________________

There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________

No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! star in the left column!   
Please use plain text.
Regular Advisor
EU-Admins-UNIX
Posts: 196
Registered: ‎09-23-2011
Message 10 of 17 (1,489 Views)

Re: make_tape_recovery completed unsuccessfully

This is a fresh out of the box build.

 

Other than installing Ignite, do I need to install anything else?

Please use plain text.
Acclaimed Contributor
Torsten.
Posts: 23,200
Registered: ‎10-02-2001
Message 11 of 17 (1,487 Views)

Re: make_tape_recovery completed unsuccessfully

After some google around I found this:

In /opt/ignite/bin/make_medialif

change LIFVolSize='500000000' to LIFVolSize='750000000'.

there is obviously not enough space in the defined LIF area to hold all the files.


Hope this helps!
Regards
Torsten.

__________________________________________________

There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________

No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! star in the left column!   
Please use plain text.
Regular Advisor
EU-Admins-UNIX
Posts: 196
Registered: ‎09-23-2011
Message 12 of 17 (1,483 Views)

Re: make_tape_recovery completed unsuccessfully

I will try this, but I have checked other working systems, and the parameter is 500000000.  I'll let you know how it goes.

 

Regards

 

Tariq

Please use plain text.
Regular Advisor
EU-Admins-UNIX
Posts: 196
Registered: ‎09-23-2011
Message 13 of 17 (1,481 Views)

Re: make_tape_recovery completed unsuccessfully

It's got past the problem stage, and is still running.  I'll let you know the outcome.

 

I'll be sure to add points!

 

Thanks

 

Tariq

Please use plain text.
Regular Advisor
EU-Admins-UNIX
Posts: 196
Registered: ‎09-23-2011
Message 14 of 17 (1,476 Views)

Re: make_tape_recovery completed unsuccessfully

Great, it worked!

 

But I still have a query. 

 

When validating the archive with tar tvf

 

I do the ...... fsf 1 etc

 

But can only read the archive with

 

tar tvf /dev/rmt/4mn, it doesn;t work with tar tvf /dev/rmt/4m

 

See below:

 

# mt -f /dev/rmt/4m rew
# mt -f /dev/rmt/4m fsf 1
# tar tvf /dev/rmt/4m
Tar: blocksize = 4
directory checksum error

 

And:

 

#  mt -f /dev/rmt/4m rew
# mt -f /dev/rmt/4mn fsf 1
# tar tvf /dev/rmt/4mn
r-xr-xr-x   2/2      0 Jan 31 08:24 2012 stand/
rwxr-xr-x   0/0      0 Jan 19 10:10 2012 stand/lost+found/
rw-r--r--   0/3   5260 Jan 31 11:52 2012 stand/ioconfig
rw-r--r--   0/3  11008 Jan 31 11:52 2012 stand/ext_ioconfig
rw-r--r--   0/3     19 Jan 19 10:11 2012 stand/bootconf
rwxr-xr-x   0/0      0 Jan 31 08:23 2012 stand/system symbolic link to nextboot/system
rw-r--r--   0/3      0 Jan 19 10:21 2012 stand/.kc.lock
rwxr-xr-x   0/3      0 Jan 31 08:25 2012 stand/krs/
rw-r--r--   0/0   4584 Jan 31 08:25 2012 stand/krs/system.krs
rw-r--r--   0/0   4584 Jan 30 12:45 2012 stand/krs/system.krs.lkg
rwxr-xr-x   0/0      0 Jan 31 08:24 2012 stand/nextboot symbolic link to current
rwxr-xr-x   0/0      0 Jan 31 08:23 2012 stand/bootfs symbolic link to current/bootfs
rwxr-xr-x   0/3      0 Jan 19 11:26 2012 stand/current/

 

Regards

 

Tariq

Please use plain text.
Honored Contributor
Patrick Wallek
Posts: 13,733
Registered: ‎06-21-2000
Message 15 of 17 (1,473 Views)

Re: make_tape_recovery completed unsuccessfully

When you used the device file /dev/rmt/4m you used the device that WILL rewind the drive after it finishes its action. So when you did 'mt -f /dev/rmt/4m fsf 1' it moved the tape forward 1 file as you asked, but since you used 4m it rewound the tape when it finished.

 

This is why you must use the 4mn device file.  The 'n' at the end means no-rewind.  So when you do 'mt -f /dev/rmt/4mn fsf 1' it will move the tape forward 1 file and stop at that point.  That is where the 'tar' portion of the tape starts.

Please use plain text.
Acclaimed Contributor
Torsten.
Posts: 23,200
Registered: ‎10-02-2001
Message 16 of 17 (1,467 Views)

Re: make_tape_recovery completed unsuccessfully

Not working:

# mt -f /dev/rmt/4m fsf 1

working:

# mt -f /dev/rmt/4mn fsf 1

You need to use the no-rewind device file ("n").

Hope this helps!
Regards
Torsten.

__________________________________________________

There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________

No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! star in the left column!   
Please use plain text.
Regular Advisor
EU-Admins-UNIX
Posts: 196
Registered: ‎09-23-2011
Message 17 of 17 (1,467 Views)

Re: make_tape_recovery completed unsuccessfully

Thanks Patrick

 

Makes sense!

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation