Re: error in flist, make_net_recovery (205 Views)
Reply
Frequent Advisor
Gerald Taylor
Posts: 95
Registered: ‎03-29-2001
Message 1 of 8 (205 Views)
Accepted Solution

error in flist, make_net_recovery

Hello Experts,

I am attempting to make a make_net_recovery of a 11.00 system. The command I use is:

/opt/ignite/bin/make_net_recovery -Av -d "localserver Recovery archive 20031203" -a igniteserver:/u01/ignite/localserver -s igniteserver -n 2

I am using ignite B.4.4.30 on both servers. The problem is that I recieve an error when running the command:
WARNING: There was a problem with the list of files/directories to archive.
Input: /var/opt/ignite/recovery/client_mnt/0x00306E0990F7/recovery/2003-12-03,13:49/flist
The following line(s) had too few/incorrect entries in each of them.
Problem lines:
line: 14 opt/perl5/bin
line: 100755 1038344152 1032192 1008

I can log into the ignite server and vi the flist file to find that there is an inadvertant line break after "opt/perl5/bin" that is causing the error. I would like to know if I can supply an flist file to the make_net_recovery or if there is another fix? I have tried the command several times and it is consistent in creating the same line break. Thanks in advance for any help.

Gerald
Honored Contributor
Armin Feller
Posts: 460
Registered: ‎04-23-2002
Message 2 of 8 (205 Views)

Re: error in flist, make_net_recovery

I think that the message occur because the list_expander calculates the wrong value of characters in the path.

line: 14 opt/perl5/bin

The path in line 14 has only has 13 characters, not 14!

/opt/ignite/lbin/list_expander -S -l file
Frequent Advisor
Gerald Taylor
Posts: 95
Registered: ‎03-29-2001
Message 3 of 8 (205 Views)

Re: error in flist, make_net_recovery

Thanks I agree with you but can you think of a way to fix this problem? Do you think it's a bug in list_expander that should be taken up with HP?

Gerald
Honored Contributor
Jean-Louis Phelix
Posts: 724
Registered: ‎10-07-2002
Message 4 of 8 (205 Views)

Re: error in flist, make_net_recovery

Or perhaps the opt/perl5/bin contains extra chars. Try a ls -lb /opt/perl

Regards.
It works for me (© Bill McNAMARA ...)
Honored Contributor
Armin Feller
Posts: 460
Registered: ‎04-23-2002
Message 5 of 8 (205 Views)

Re: error in flist, make_net_recovery

I'm not sure, I think that the list_expander is ok. I think there was a problem with opt/perl5/bin during creating the image. For deeper analyse I would recommend to open a support case at your local HP support.
Frequent Advisor
Gerald Taylor
Posts: 95
Registered: ‎03-29-2001
Message 6 of 8 (205 Views)

Re: error in flist, make_net_recovery

Thanks Jean,

I did a ls -lb and found something very wierd in the directory. This is another mystery. As for now I cleaned the directory and the make_net_recovery worked properly.

Gerald

# ls -lb /opt/perl5
total 2020
drwxr-xr-x 2 root sys 1024 Nov 27 2002 bin
-rwxr-xr-x 1 root sys 1032192 Nov 26 2002 bin\012
drwxr-xr-x 2 root sys 1024 Nov 27 2002 doc
drwxr-xr-x 5 root sys 96 Nov 27 2002 lib
drwxr-xr-x 4 root sys 96 Apr 26 2001 man
Occasional Contributor
Antonio_56
Posts: 3
Registered: ‎05-01-2002
Message 7 of 8 (205 Views)

Re: error in flist, make_net_recovery

Hi Gerald,

I have the same trouble with Ignite-UX Server. I try cleaning the filesystem but the error has ocurried in other directory. A line is wroten break in "flist" file and the process stop. I can kill the process "list_expander" and continue with ignite but then I haven't an ignite archive from all vg00. That's the problem, Do you know the solution now?

Advanced thanks,

Anthon.
Frequent Advisor
Gerald Taylor
Posts: 95
Registered: ‎03-29-2001
Message 8 of 8 (205 Views)

Re: error in flist, make_net_recovery

ls -lb found extra chars in the directory
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.