Problems cloning a server (370 Views)
Reply
Occasional Advisor
PetraHora
Posts: 8
Registered: ‎07-08-2008
Message 1 of 3 (370 Views)

Problems cloning a server

I have a rx2660 with HPUX B.11.31 and want to clone this server to another rx2660 (which should be the same hardware).

On the first rx2660 I created a tape with this command:

/opt/ignite/bin/make_tape_recovery -a /dev/rmt/0mn -t "Archive `date +%d%m%Y`" -x inc_entire=vg00 -x inc_entire=vg01 -I

On the second rx2660 I tried to recover (with "Cloning on different Hardware=True") and I get these messages:
=========================================

* Running the ioinit command ("/sbin/ioinit -c")
* Creating device files via the insf command.
insf: Installing special files for sdisk instance 3 address 0/1/1/0.0.0.0.0
insf: Installing special files for sdisk instance 11 address 0/1/1/0.0.0.1.0
insf: Installing special files for sdisk instance 2 address 0/1/1/0.0.0.2.0
insf: Installing special files for sdisk instance 12 address 0/1/1/0.0.0.3.0
insf: Installing special files for esdisk instance 9 address 64000/0xfa00/0x1
insf: Installing special files for esdisk instance 5 address 64000/0xfa00/0x2
insf: Installing special files for esdisk instance 7 address 64000/0xfa00/0x3
insf: Installing special files for esdisk instance 4 address 64000/0xfa00/0x4
insf: Installing special files for stape instance 0 address 0/5/1/0.3.0
insf: Installing special files for estape instance 1 address 64000/0xfa00/0x0
insf: Installing special files for pseudo driver dlpi
insf: Installing special files for pseudo driver kepd
insf: Installing special files for pseudo driver framebuf
insf: Installing special files for pseudo driver sad
* Creating the system file.
Creating your system file in the file /tmp/ign_configure/tstand.system
* Constructing the bootconf file.
* Setting primary boot path to "0/1/1/0.0x5000c50008202c45.0x0".
Primary boot path set to 0/1/1/0.0x5000c50008202c45.0x0 (/dev/rdisk/disk4)
ioinit: libIO error - Entry not found in ioconfig file.
Input line 1: 0/0/2/0.0 OO 2
WARNING: Command: "/sbin/ioinit -f /tmp/ioinit.in" failed. Instance number
assignments for devices of class "OO" may not be assigned correctly.
* Executing: "/var/adm/sw/products/OS-Core/CORE-SHLIBS/iux_postload".
* Running: /var/adm/sw/products/OS-Core/CORE-SHLIBS/postinstall
* Executing: "/var/adm/sw/products/OS-Core/CORE2-KRN/iux_postload".
* Executing: "/var/adm/sw/products/OS-Core/CORE-KRN/iux_postload".
* Loading_software: Warning
* Build_Kernel: Begin
* Building a new kernel using the command: "/usr/sbin/mk_kernel -f -o
/stand/vmunix".
WARNING: The configuration is supposed to include a module
'UsbScsiAdaptor' that is not installed on the system. The
system will attempt to proceed without it, but the resulting
kernel may fail to boot or function properly.
WARNING: The configuration is supposed to include a module 'sasd_vbus'
that is not installed on the system. The system will attempt
to proceed without it, but the resulting kernel may fail to
boot or function properly.
* The currently running configuration has been imported from
'/stand/system'.
* Build_Kernel: Complete
* Boot_From_Client_Disk: Begin
* Rebooting machine as expected.
NOTE: Rebooting system.

After the reboot:
========================================
System Console is on the Built-In Serial Interface
igelan0: INITIALIZING HP PCI-X 1000Base-T Dual-port Built-in at hardware path 0/1/2/0
igelan1: INITIALIZING HP PCI-X 1000Base-T Dual-port Built-in at hardware path 0/1/2/1
AF_INET socket/streams output daemon running, pid 34
afinet_prelink: module installed
Starting the STREAMS daemons-phase 1
LVM: Root VG activated
Swap device table: (start & size given in 512-byte blocks)
entry 0 - major is 64, minor is 0x2; start = 0, size = 16777216
The device file /dev/rroot does not exist or is not correct.
Automatic checks of the root file system not performed.
Create STCP device files
Starting the STREAMS daemons-phase 2
$Revision: vmunix: B.11.31_LR FLAVOR=perf
Memory Information:
physical page size = 4096 bytes, logical page size = 4096 bytes
Physical: 4173276 Kbytes, lockable: 2863684 Kbytes, available: 3012796 Kbytes

insf: Unable to load the driver: cfsmdr
insf: Unable to load the driver: cfsm
insf: Unable to load the driver: cifs
NOTICE: mod_openpath: Cannot open module cfsmdr on path /stand/current/mod

WARNING: mod_deletestr: string cfsmdr not found in dump string table

NOTICE: mod_openpath: Cannot open module cfsm on path /stand/current/mod

WARNING: mod_deletestr: string cfsm not found in dump string table

NOTICE: mod_openpath: Cannot open module cifs on path /stand/current/mod

WARNING: mod_deletestr: string cifs not found in dump string table

PCI_CDIO: pci_cdio_scan() errors: 0x100
insf: Installing special files for sdisk instance 3 address 0/1/1/0.0.0.0.0
insf: Installing special files for sdisk instance 11 address 0/1/1/0.0.0.1.0
insf: Installing special files for sdisk instance 2 address 0/1/1/0.0.0.2.0
insf: Installing special files for sdisk instance 12 address 0/1/1/0.0.0.3.0
insf: Installing special files for esdisk instance 9 address 64000/0xfa00/0x1
insf: Installing special files for esdisk instance 5 address 64000/0xfa00/0x2
insf: Installing special files for esdisk instance 7 address 64000/0xfa00/0x3
insf: Installing special files for esdisk instance 4 address 64000/0xfa00/0x4
insf: Unable to load the driver: cfsmdr
insf: Unable to load the driver: cfsm
insf: Unable to load the driver: cifs
NOTICE: mod_openpath: Cannot open module cfsmdr on path /stand/current/mod

WARNING: mod_deletestr: string cfsmdr not found in dump string table

NOTICE: mod_openpath: Cannot open module cfsm on path /stand/current/mod

WARNING: mod_deletestr: string cfsm not found in dump string table

NOTICE: mod_openpath: Cannot open module cifs on path /stand/current/mod

WARNING: mod_deletestr: string cifs not found in dump string table

insf: Installing special files for stape instance 0 address 0/5/1/0.3.0
insf: Installing special files for estape instance 1 address 64000/0xfa00/0x0
Volume group "/dev/vg00" is already active on this system.
Activated volume group
Volume group "/dev/vg01" has been successfully changed.
Resynchronized volume group /dev/vg00
Resynchronized volume group /dev/vg01
.
. (some more lines ...)
.
Memory Information:
physical page size = 4096 bytes, logical page size = 4096 bytes
Physical: 4173276 Kbytes, lockable: 2863684 Kbytes, available: 3012796 Kbytes

NOTICE: mod_openpath: Cannot open module cfsmdr on path /stand/current/mod

WARNING: mod_deletestr: string cfsmdr not found in dump string table

MOD: mod_load_helper: error loading cfsmdr
NOTICE: mod_openpath: Cannot open module cfsm on path /stand/current/mod

WARNING: mod_deletestr: string cfsm not found in dump string table

MOD: mod_load_helper: error loading cfsm
NOTICE: mod_openpath: Cannot open module cifs on path /stand/current/mod

WARNING: mod_deletestr: string cifs not found in dump string table

MOD: mod_load_helper: error loading cifs
Line 4095 in /ux/core/kern/em/plat/psm/acpi_hotplug_psm.c: acpi_hotplug_pci_slot - acpi_hotplug_slot_get failed
Line 4095 in /ux/core/kern/em/plat/psm/acpi_hotplug_psm.c: acpi_hotplug_pci_slot - acpi_hotplug_slot_get failed
Line 4095 in /ux/core/kern/em/plat/psm/acpi_hotplug_psm.c: acpi_hotplug_pci_slot - acpi_hotplug_slot_get failed
Line 1074 in /ux/core/kern/em/plat/psm/eh_ipf_psm.c: eh_ipf_get_lba_status: Cannot find the h2p 0x0 in Global list
Line 4095 in /ux/core/kern/em/plat/psm/acpi_hotplug_psm.c: acpi_hotplug_pci_slot - acpi_hotplug_slot_get failed
Line 4095 in /ux/core/kern/em/plat/psm/acpi_hotplug_psm.c: acpi_hotplug_pci_slot - acpi_hotplug_slot_get failed
Line 4095 in /ux/core/kern/em/plat/psm/acpi_hotplug_psm.c: acpi_hotplug_pci_slot - acpi_hotplug_slot_get failed
Line 1074 in /ux/core/kern/em/plat/psm/eh_ipf_psm.c: eh_ipf_get_lba_status: Cannot find the h2p 0x0 in Global list
Line 4095 in /ux/core/kern/em/plat/psm/acpi_hotplug_psm.c: acpi_hotplug_pci_slot - acpi_hotplug_slot_get failed
PCI_CDIO: pci_cdio_scan() errors: 0x100
NOTICE: mod_openpath: Cannot open module cfsmdr on path /stand/current/mod

WARNING: mod_deletestr: string cfsmdr not found in dump string table

MOD: mod_load_helper: error loading cfsmdr
NOTICE: mod_openpath: Cannot open module cfsm on path /stand/current/mod

WARNING: mod_deletestr: string cfsm not found in dump string table

MOD: mod_load_helper: error loading cfsm
NOTICE: mod_openpath: Cannot open module cifs on path /stand/current/mod

WARNING: mod_deletestr: string cifs not found in dump string table

MOD: mod_load_helper: error loading cifs
Line 4095 in /ux/core/kern/em/plat/psm/acpi_hotplug_psm.c: acpi_hotplug_pci_slot - acpi_hotplug_slot_get failed
Line 4095 in /ux/core/kern/em/plat/psm/acpi_hotplug_psm.c: acpi_hotplug_pci_slot - acpi_hotplug_slot_get failed
Line 4095 in /ux/core/kern/em/plat/psm/acpi_hotplug_psm.c: acpi_hotplug_pci_slot - acpi_hotplug_slot_get failed
Line 1074 in /ux/core/kern/em/plat/psm/eh_ipf_psm.c: eh_ipf_get_lba_status: Cannot find the h2p 0x0 in Global list
Line 4095 in /ux/core/kern/em/plat/psm/acpi_hotplug_psm.c: acpi_hotplug_pci_slot - acpi_hotplug_slot_get failed
Line 4095 in /ux/core/kern/em/plat/psm/acpi_hotplug_psm.c: acpi_hotplug_pci_slot - acpi_hotplug_slot_get failed
Line 4095 in /ux/core/kern/em/plat/psm/acpi_hotplug_psm.c: acpi_hotplug_pci_slot - acpi_hotplug_slot_get failed
Line 1074 in /ux/core/kern/em/plat/psm/eh_ipf_psm.c: eh_ipf_get_lba_status: Cannot find the h2p 0x0 in Global list
Line 4095 in /ux/core/kern/em/plat/psm/acpi_hotplug_psm.c: acpi_hotplug_pci_slot - acpi_hotplug_slot_get failed
bad_kern_reference: 0xdead31.0xe00000013a970018, fault = 0x8

Message buffer contents after system crash:

panic: Fault when executing in kernel mode
Stack Trace:
IP Function Name
0xe000000002367240 bad_kern_reference+0xa0
0xe0000000008f9790 vfault+0x14c0
0xe0000000008f3600 vm_hndlr+0x480
0xe000000001eaf780 bubbledown+0x0
0xe000000001316170 $cold_vx_dnlc_enter+0x110
0xe00000000098ecd0 vx_cbdnlc_enter+0x470
0xe0000000008c73d0 vx_lookup+0x15a0
0xe00000000092da50 lookupname+0x3b0
0xe000000000989520 stat+0x60
0xe00000000089c490 syscall+0xd30
End of Stack Trace

linkstamp: Mon Aug 18 16:18:49 METDST 2008
_release_version: @(#) $Revision: vmunix: B.11.31_LR FLAVOR=perf
Calling function e0000000018f0f20 for Shutdown State 1 type 0x2
================

What can be the reason for this? Please help!





Honored Contributor
Tim Nelson
Posts: 3,727
Registered: ‎06-01-2000
Message 2 of 3 (370 Views)

Re: Problems cloning a server

Forget the clone on diff hardware option.

Just do an interactive recovery, advanced install, change the network and hostname info ....

Should work right out of the gate unless your new server has piles of difference HW that the source does not.

Occasional Advisor
PetraHora
Posts: 8
Registered: ‎07-08-2008
Message 3 of 3 (370 Views)

Re: Problems cloning a server

I did an interactive recovery, but I didn't change the ip and hostname (they ought to be the same - its OK!).

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.