Re: SNMP outbound broken after 7.2 upgrade (169 Views)
Reply
Trusted Contributor
LGentile
Posts: 295
Registered: ‎09-04-2012
Message 1 of 9 (201 Views)

SNMP outbound broken after 7.2 upgrade

I finally upgraded to SIM 7.2.2 (latest version I can run due to IRSA) and shortly after, I noticed that discoveries and identify tasks fail with systems running SNMP.  I also tried using the sytem types tool to pull OIDs from systems and it fails as well.

 

I stumbled across a blog where someone found that a new parameter existed in the globalsettings file - "JavaSnmpStack", and setting it to 'false' fixed the issue for me - for about 15 minutes!  Without doing anything else, the same issue came back.

 

It's very strange.. yes the clients have valid SNMP community names and yes the SIM credentials are correct - i have thousands of devices so they all could not be wrong.

 

Thanks

 

Please use plain text.
Frequent Visitor
BrianKelly
Posts: 4
Registered: ‎12-19-2011
Message 2 of 9 (191 Views)

Re: SNMP outbound broken after 7.2 upgrade

I have the same issue except not as bad.  It happens to me about every 2 weeks.  I reboot the SIM server and all is good again.  It's a bit frustrating though because I made a collection of servers in alarm and they don't show up there when the issue arises.  After the reboot they show up.  Data collection and system identifies don't pull down data until after the reboot.  Wondering what's changing to do this. 

Please use plain text.
Trusted Contributor
LGentile
Posts: 295
Registered: ‎09-04-2012
Message 3 of 9 (169 Views)

Re: SNMP outbound broken after 7.2 upgrade

Yeah I am in a similar situation. 


Traps seem to work just fine, but it screws up my collections since a lot of systems end up as 'unknown'.  I also use the daily ID task to find broken agents or servers that are no longer responding to polls.. now the ID task takes 15+ hours and doesn't complete properly, so I can't really tell what servers really have issues since ALL the SNMP servers (Windows) come up as major failures..

 

I will open a case with HP on this one and post something if I hear back.  We're not ready to use WBEM with Windows yet since we have a lot of legacy systems, so that really isn't an option right now.  Same goes for agentless, can't do that due to IRSA in case anyone suggests that. 

 

Thanks

 

Please use plain text.
Occasional Visitor
LesleyH
Posts: 1
Registered: ‎04-16-2014
Message 4 of 9 (71 Views)

Re: SNMP outbound broken after 7.2 upgrade

Did HP provide any casue or resolution for this?
Please use plain text.
Frequent Visitor
BrianKelly
Posts: 4
Registered: ‎12-19-2011
Message 5 of 9 (61 Views)

Re: SNMP outbound broken after 7.2 upgrade

I have a case open w/HP for the issue.  I'm working w/tier 3.  I don't believe they have a work around yet because they still haven't nailed down what the issue is with my server.  I'll keep you posted.  As a hack work around I setup a sceduled task to run a batch file with the line  MXSTOP.  Then another one ten minutes later with   MXSTART.  I run it at midnight every night.  Thankfully my server runs ok doing that.  SIM 7.4 is coming out soon (October/November) I'd like to get it fixed before I upgrade. 

 

Brian Kelly

Please use plain text.
Trusted Contributor
Andrew_Haak
Posts: 332
Registered: ‎09-13-2013
Message 6 of 9 (59 Views)

Re: SNMP outbound broken after 7.2 upgrade

If you look in the SIM installation folder under the traps folder, do you see a lot of files?
Kind regards,

Andrew
Please use plain text.
Frequent Visitor
BrianKelly
Posts: 4
Registered: ‎12-19-2011
Message 7 of 9 (58 Views)

Re: SNMP outbound broken after 7.2 upgrade

I don't have a lot of traps.  I monitored the folder for a day.  The traps came in and left normally.  I sent a debug file to HP last week.  I'm waiting for a reply. 

 

Please use plain text.
Trusted Contributor
LGentile
Posts: 295
Registered: ‎09-04-2012
Message 8 of 9 (43 Views)

Re: SNMP outbound broken after 7.2 upgrade

[ Edited ]

Brian - interestingly enough, after 4 months, HP finally got back to me (L3 engineer working with the dev team) to acknowledge this issue.

Note that many customers cannot upgrade beyond 7.2.2 right now so HP should be obligated to fix this issue without needing to upgrade to 7.3 or better. I will not be able to upgrade my instance to 7.4 so HP told me they are testing a fix in 7.2 to see if it will work.

Andrew - this isn't about traps, it's SNMP outbound (discoveries, daily ID tasks, etc..) SNMP simply fails to connect (using a commandline SNMPGet utility, everything works just fine) - this something in SIM or the Java SNMP stack that SIM uses..

Please use plain text.
Trusted Contributor
Andrew_Haak
Posts: 332
Registered: ‎09-13-2013
Message 9 of 9 (35 Views)

Re: SNMP outbound broken after 7.2 upgrade

Thanks LGentile for the info, didn't see that..
Kind regards,

Andrew
Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation