Re: HP Smart Update Manager: No install was run, due to failed dependencies (1321 Views)
Reply
Occasional Contributor
Loc_750
Posts: 4
Registered: ‎09-11-2012
Message 1 of 3 (2,179 Views)

HP Smart Update Manager: No install was run, due to failed dependencies

We tried to use SIM's Update to Baseline wizard to update to a server to SPP 2013.09.0B. As seen in the log below, it failed due to dependencies. This is a DL380 G7 server, so we don't know why it thinks the DL980 System Providers is a dependency.

////////////////////////////////////////////////////////////////////////////////
// HP Smart Update Manager for Target localhost Started: Wed Sep 25 2013 18:50:51
////////////////////////////////////////////////////////////////////////////////

Target localhost is up to date, no updates were needed or nothing was installed before exiting.


////////////////////////////////////////////////////////////////////////////////
// Exit Code for Target localhost: -1
// HP Smart Update Manager for Target localhost Finished: Wed Sep 25 2013 18:52:15
////////////////////////////////////////////////////////////////////////////////



Note: The following list of components were not tried for installation cp021280.exe cp020865.exe cp020913.exe cp021108.exe cp021032.exe cp021035.exe cp020435.exe cp020438.exe cp020307.exe cp016819.exe cp017871.exe cp019012.exe cp019017.exe cp013803.exe cp019795.exe cp019213.exe cp010920.exe cp019819.exe cp019271.exe cp018873.exe cp018456.exe cp010978.exe cp020547.exe cp020267.exe cp020353.exe cp020258.exe cp020834.exe cp019294.exe cp019296.exe cp017732.exe cp011349.exe cp021384.exe cp021252.exe
////////////////////////////////////////////////////////////////////////////////
// HP Smart Update Manager for Target localhost Started: Wed Sep 25 2013 18:50:51
////////////////////////////////////////////////////////////////////////////////

Starting Discovery

Discovery completed

No install was run, due to failed dependencies
Installed Components : None.

Component File Name: cp017732.exe
Component Name: HP ProLiant DL980 System Providers for Windows Server x64 Editions
Dependency failed. Its installation requires one or more of the following that is not currently installed or in the install set:
- HP ProLiant DL980 G7



////////////////////////////////////////////////////////////////////////////////
// Exit Code for Target localhost: -1
// HP Smart Update Manager for Target localhost Finished: Wed Sep 25 2013 18:52:15
////////////////////////////////////////////////////////////////////////////////

Visitor
Server Messaging Suppor
Posts: 4
Registered: ‎05-23-2011
Message 2 of 3 (1,607 Views)

Re: HP Smart Update Manager: No install was run, due to failed dependencies

Did you ever find an answer?
I just removed it from the package to avoid anymore issues...

Occasional Contributor
Loc_750
Posts: 4
Registered: ‎09-11-2012
Message 3 of 3 (1,321 Views)

Re: HP Smart Update Manager: No install was run, due to failed dependencies

I gave up on deploying this SPP from HP SIM. We've been updating servers locally using HP Smart Update Manager that is included with the SPP. HP SUM 6.0+ is available as a standalone download on HP's website and it has the ability to deploy SPP baselines to remote servers. So we may "install" HP SUM on the server that runs HP SIM and do deployments from HP SUM instead of HP SIM.

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.