HP SIM Not Receiving The Same Alerts (433 Views)
Reply
Occasional Advisor
zarulzakuan
Posts: 14
Registered: ‎10-05-2012
Message 1 of 4 (433 Views)
Accepted Solution

HP SIM Not Receiving The Same Alerts

Hi guys, Need some help from you experts. We have two HP SIM servers which having exactly the same servers inventory. The version of the HP SIM are difference however. 5.2 with SP1 and 5.3 with SP1. After a while I noticed that events coming to both SIM servers are not the same. Mostly the Accelerator Board events. For example, ServerA keeps sending its Accelerator Board Status Change (3038) events to its SNMP Destination which are SIMserverA and SIMserverB but the event only appear on SIMserverA; not on SIMserverB. SIMserverA based in Australia monitors all the Asiapac servers and SIMserverB based in LA monitors all the US servers. The reason why we have all the Asiapac and US servers on both SIM servers is for them to be the failover server to each other whenever either of them is down. The Events Setting, SNMP Trap Setting, Automatic Event Handling - Manage Tasks, Credentials, Protocol Setting all exactly the same. Is this because of the SIM server and its managed systems to far away? I've increased the SNMP timeout and its still the same. Any of your help would be much appreciated. Thanks in advance! :-)

Honored Contributor
shocko
Posts: 881
Registered: ‎11-13-2008
Message 2 of 4 (386 Views)

Re: HP SIM Not Receiving The Same Alerts

Firstly, verify using a network sniffer on both SIM servers that the traps are indeed hitting the server:

  1. Run sniffer on both SIM servers
  2. Send a test trap from the SMH on the test server
  3. verify it hits the SIM servers at both locations

If the trap is htting then we need ot look at the SIM instances themseleves. Check they following:

 

  1. What MIB bundles are registered on each SIM server?
  2. Are any of the traps disabled on the server not raising an alert?
If my post was helpful please award me Kudos! or Points :)
Occasional Advisor
zarulzakuan
Posts: 14
Registered: ‎10-05-2012
Message 3 of 4 (382 Views)

Re: HP SIM Not Receiving The Same Alerts

Thanks for your reply Shocko!

 

Using network sniffer, I've verified that both servers receive the trap packet.

I checked also the MIB bundles which is the cpqida.mib on the SIM server that doesn't receive the alerts and they are all enabled..

However I tried comparing this SNMP Trap Settings with the other SIM server that do receive the alerts, but everytime I try to load its cpqida.mib, its going back to the first mib in the list, the asmib.mib.

Occasional Advisor
zarulzakuan
Posts: 14
Registered: ‎10-05-2012
Message 4 of 4 (379 Views)

Re: HP SIM Not Receiving The Same Alerts

Finally found what cause this issue!

 

The configuration parameters in snmpd.conf should not percedes the HP MIB’s to net-snmp command which is  dlmod cmaX /usr/lib/libcmaX.so (for 64-bit) dlmod cmaX /usr/lib64/libcmaX64.so

 

For example

 

rwcommunity public 127.0.0.1 rocommunity public 127.0.0.1 
rwcommunity public SIM server IP address (If there is any) 
rocommunity public SIM server IP address (If there is any) 
trapcommunity public trapsink public SIM server IP address (If there is any) 
syscontact Sysadmin (root@localhost) syslocation Server_Room

 

should be written AFTER

 

dlmod cmaX /usr/lib/libcmaX.so 

 or

dlmod cmaX /usr/lib64/libcmaX64.so

 

 

Dont know why, but its per adviced by HP SIM

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&taskId=115&prodSeriesId=...

 

Now both my SIMs are working dandy :-)

 

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.