Re: error in webinstallation for AM9.4 (544 Views)
Reply
Advisor
sreedevireddy
Posts: 31
Registered: ‎11-25-2013
Message 1 of 11 (641 Views)

error in webinstallation for AM9.4

 

After completing the web installation,I am unable to connect the AM 9.4 database(not demodatabase,our prod database) through web.I am getting the following error

 

"

Unable to connect to the database to retrieve the version. Please check the Web service's start-up parameters above and the parameters of the AssetManager connection in the 'amdb.ini' file. Error (12,001): Dll not found, Check connection settings 'AmApiDll'"

 

find the attached error screeshot.

HP Expert
Priya_B
Posts: 534
Registered: ‎10-25-2012
Message 2 of 11 (631 Views)

Re: error in webinstallation for AM9.4

Hello Sreedevi,

 

Could you check if the dll is present in the location specified ? Have you installed AM in the E:\Directory ?

 

ALso, I see this is a 64 bit installation so just to send you the document please verify each step.

 

I hope your OS, DB client System DSN created , JAVA all are 64 bit.

 

Please refer to KM00663678 to verify.

 

 

HP Support - If this post or any post helps you resolve an issue, please be sure to mark it as an acceptable solution.
Like a post, Please click Kudos to show appreciation !
HP Expert
Priya_B
Posts: 534
Registered: ‎10-25-2012
Message 3 of 11 (603 Views)

Re: error in webinstallation for AM9.4

Hello Sreedevi,

 

Is this issue resolved ? Did the document help you ?

HP Support - If this post or any post helps you resolve an issue, please be sure to mark it as an acceptable solution.
Like a post, Please click Kudos to show appreciation !
Advisor
sreedevireddy
Posts: 31
Registered: ‎11-25-2013
Message 4 of 11 (599 Views)

Re: error in webinstallation for AM9.4

Hi Priya,

 

Thanks for providing the document.

 

I followed same steps,still I phased same error.

 

I am attaching the detailed document.Can you please help me...

HP Expert
Priya_B
Posts: 534
Registered: ‎10-25-2012
Message 5 of 11 (590 Views)

Re: error in webinstallation for AM9.4

Hello ,

 

Is the tomcat port mentioned fine ? Are you using 8080 only ? If not that that port needs to be updated.

 

Secondly the connection DSN is

POCHDSA is this the name of the Data Source DSN. You need to create a SYstem DSN and not a USER DSN .

 

ALso create both 32 bit ( for win client) and 64 bit DSN .

 

 

Also check in the <AM install>\x64\folder is there the aamapi94.dll present ? As the error says DLL not found.

 

HP Support - If this post or any post helps you resolve an issue, please be sure to mark it as an acceptable solution.
Like a post, Please click Kudos to show appreciation !
Advisor
sreedevireddy
Posts: 31
Registered: ‎11-25-2013
Message 6 of 11 (574 Views)

Re: error in webinstallation for AM9.4

Hi Priya,
1)Tomcat port using 8080.
2)POCHDSA is creating for System DSN .
3)"aamapi94.dll" present in AM install>\x64\folder and bin folder(both folder)
this all are mentioned like this.
Honored Contributor
Mark Cullen_1
Posts: 1,236
Registered: ‎03-17-2010
Message 7 of 11 (562 Views)

Re: error in webinstallation for AM9.4

Your web service properties file "DB.datasource=POCHDSA" should be the 64bit ODBC System DSN name.

 

You should have a new connection for 64bit in your amdb.ini file.  DO NOT REPLACE THE EXISTING 32BIT CONNECTION.

 

This new connection (duplicated from 32bit connection) will have 64 in the name (to distinguish from 32bit name, "Location" parameter set to your 64bit ODBC System DSN name, and the "AmApiDll" parameter set to the \x64 path.

HP Expert
Priya_B
Posts: 534
Registered: ‎10-25-2012
Message 8 of 11 (544 Views)

Re: error in webinstallation for AM9.4

Sreedevi ,

 

Did you create 64 bit System DSN named POCHDSA ? Did it help ?

 

If not please send us the tomcat logs.

HP Support - If this post or any post helps you resolve an issue, please be sure to mark it as an acceptable solution.
Like a post, Please click Kudos to show appreciation !
Advisor
sreedevireddy
Posts: 31
Registered: ‎11-25-2013
Message 9 of 11 (529 Views)

Re: error in webinstallation for AM9.4

Hi Priya,

Now I am using 32 bit server and installed AM 9.4. I have successfully installed Web client installation.I am able to login in webclient,but after login not able to access screens.I am getting the following error
"defaultScreenSetError "
HP Expert
Priya_B
Posts: 534
Registered: ‎10-25-2012
Message 10 of 11 (516 Views)

Re: error in webinstallation for AM9.4

Hello Sreedevi,

 

Thats a different issue, please raise a new thread for the same.  You will have to send the ADBlog and the tomcat log for the same. Its due to several reasons.

 

Please mark this thread as solved as this is no longer an issue.

HP Support - If this post or any post helps you resolve an issue, please be sure to mark it as an acceptable solution.
Like a post, Please click Kudos to show appreciation !
Visitor
Khaled_FP
Posts: 1
Registered: ‎12-19-2013
Message 11 of 11 (493 Views)

Re: error in webinstallation for AM9.4

i have the same issue and i am already using x32 not x64.

Any help will be appreciated,
Thanks,

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.