Re: Asset Manager 5.2 and 9.3 do not support alphanumeric passwords (498 Views)
Reply
Advisor
Jhon-ETS
Posts: 26
Registered: ‎04-24-2012
Message 1 of 5 (546 Views)
Accepted Solution

Asset Manager 5.2 and 9.3 do not support alphanumeric passwords

Hi all,

I'm migrating from Asset Center 5.3 to Asset Manager 9.3, but I found that when wanting to make the connection to the database, the "Manage Connections" Asset Manager 9.3 don't save alphanumeric passwords (such as eg 1234abcd) and the message sent to try to save the connection is: "The database connection password is empty, Are you sure you want to save the connection?", however alphabetic passwords save ok (eg abcdefg).

This test also perform on a separate installation in a test environment of Asset Manager 5.2 and the result is the same.

This to me is a problem as database passwords regularly we try to be as safe as possible and Asset Manager not helping me in this.

Anyone knows any way to fix this problem?

Any idea with which you could support me?

Thanks for your time.

Best regards.

Honored Contributor
Mark Cullen_1
Posts: 1,241
Registered: ‎03-17-2010
Message 2 of 5 (527 Views)

Re: Asset Manager 5.2 and 9.3 do not support alphanumeric passwords

First check with the DBMS DBA then check with HP support as I am currently also using special characters with alphanumeric password at the database level.

Advisor
Jhon-ETS
Posts: 26
Registered: ‎04-24-2012
Message 3 of 5 (525 Views)

Re: Asset Manager 5.2 and 9.3 do not support alphanumeric passwords

I thank in advance for your reply soon.

 

However my point of view things this has nothing to do with the DBMS DBA, because if I made ​​a connection test using the "Manager ODBC data sources" the connection test is successful, another important point is that I have connected an Asset Center 5.03 client to the same database with the alphanumerical password and it does not have connection problems the only problem is to make the Asset Manager 9.3 client connect to the data base, that is where the same software does not recognize the password and returns me the error "the database connection password is empty, Are you sure you want to save the connection?".

 

In order to give solution to this particular problem, Is it possible to store this password in connection amdb.ini file and the Asset Manager 9.3 recognize the password?

 

From already thank you for your time and support.

 

Best Regards

Honored Contributor
Mark Cullen_1
Posts: 1,241
Registered: ‎03-17-2010
Message 4 of 5 (523 Views)

Re: Asset Manager 5.2 and 9.3 do not support alphanumeric passwords

Not sure if this will work however from the 5.03 sucess take the encrypted password from amdb.ini and place in 9.3 amdb.ini.

Advisor
Jhon-ETS
Posts: 26
Registered: ‎04-24-2012
Message 5 of 5 (498 Views)

Re: Asset Manager 5.2 and 9.3 do not support alphanumeric passwords

Hi all,

This issue was resolved on the second day it is released, I offer an apology for not write down the solution to this problem as soon as possible, but I continue with the upgrade of AM9 and other problems have arisen that have required my time and attention to solve .


Well sharing my solution and that no one could answer was that for a standard password only writes: abcdefg (just an example), and an alphanumeric password a quotation marks are added at the beginning and end: "abcd1234" (example) is a pity that details like this are not clarified in any way.

 

Thanks to those who were around and I hope to assist in the resolution of any case.

 

Greetings to all.

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.