AM9.32 - Web client LDAP integration not working (203 Views)
Reply
Regular Advisor
kooshi
Posts: 124
Registered: ‎10-29-2010
Message 1 of 3 (203 Views)

AM9.32 - Web client LDAP integration not working

Hello all,

 

I am running into an issue where the LDAP integration seems to be not working properly.

I have deployed the proper war files into the Tomcat directories.

I deleted the el-api.jar file from the web services.

 

The adblog message I see when trying to log in is:

2014/01/28 14:18:44.761 0 256 [Thrd#:1548]Error loggued 331989648 - -52 Unable to load LDAP-specific dynamic library ('old
2014/01/28 14:18:44.761 0 1 [Thrd#:1548](-52) Unable to load LDAP-specific dynamic library ('oldap.dll').
2014/01/28 14:18:44.761 0 256 [Thrd#:1548]Error loggued 331989648 - -52 Unable to load LDAP-specific dynamic library ('nsl
2014/01/28 14:18:44.761 0 1 [Thrd#:1548](-52) Unable to load LDAP-specific dynamic library ('nsldap32v50.dll').

 

Logging in as the Admin works perfectly fine.

Users are able to log into AM with their LDAP credentials fine when using the Windows client.

 

Any advice is appreciated.

Thank you!

Please use plain text.
Regular Advisor
matthewpmattson
Posts: 130
Registered: ‎10-08-2012
Message 2 of 3 (184 Views)

Re: AM9.32 - Web client LDAP integration not working

Hi kooshi,

 

I have configured LDAP for AM 9.30 and 9.32 and have never run into those error messages in the adblog.

 

It seems to be complaining about an ldap dll so you may want to make sure you have all of the necesarry LDAP files (dll's) and they are not corrupt. When you installed Asset Manager, did you do a full install? If so, my understanding is that all necesarry LDAP files are included, however if you choose custom installation you must ensure the LDAP component is to be installed. What is interesting is that you say LDAP works fine with the Windows client. It seems like that type of error would prevent LDAP from working at all.

 

The only cases I've had where Windows client worked and Web client failed were issues with my LDAP certificate and trust store. Make sure there is no issue with these things as well.

 

Matt

Please use plain text.
Regular Advisor
matthewpmattson
Posts: 130
Registered: ‎10-08-2012
Message 3 of 3 (156 Views)

Re: AM9.32 - Web client LDAP integration not working

[ Edited ]

Hi kooshi,

 

I also found this Support Tip that looks like a workaround to this issue:

http://h30499.www3.hp.com/t5/IT-Asset-Manager-Connect-IT/lt-Support-Tip-gt-lt-AM-gt-Unable-to-load-L...

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation