Re: [IMC 7.0] JAVA: circle of death (573 Views)
Reply
Valued Contributor
MichaelM55
Posts: 203
Registered: ‎06-08-2011
Message 1 of 3 (661 Views)

[IMC 7.0] JAVA: circle of death

[ Edited ]

After upgrading from IMC 5.2 to 7.0 I have JAVA´s circle of death within device view, i.e. I have to wait for 2,3,4,5 minutes till the rest of the homepage appears (And yes, SNMP is working correctly on all devices...). Sometimes the whole browser freezes (on different machines with different JREs installed), asking myself what is actually going wrong? Btw, which JRE is recommended at all? Maybe a problem on serverside?

 

 

Please use plain text.
Honored Contributor
LindsayHill
Posts: 693
Registered: ‎11-16-2011
Message 2 of 3 (652 Views)

Re: [IMC 7.0] JAVA: circle of death

That's not Java. Java has never been used on that page. 

 

What seems to happen with IMC is that when you go to a Device Details page, it goes and does some extra polling of that device, and it will try and login to it. If you have incorrect SNMP credentials, it will take a while to time out. If the devices are on the far end of a high-latency link, then it can take a while, and you'll see it sitting there spinning for a bit. Once it's got whatever info it is after, it loads the rest of that page

 

But if the device has all the right SNMP + Telnet/SSH credentials, and latency is low, it should not take long at all for that page to load. Double-check all credentials. Click Synchronise, the Refresh, and ensure the System Uptime value is updated. Run a backup, and check credentials are working.

 

You don't _have_ to use a JRE any more, with the introduction of HTML5. But it's still there on some pages, such as Resource -> Network Topology. Don't know why, since if you view the Topology via Resource -> Custom View, it uses HTML5.

 

If you do have a JRE installed on your client systems, you should use the latest available, and patch it frequently, as there are so many security issues with it. You shouldn't touch the JRE used by IMC on the server side.

CCIE 36708 | @northlandboy | lkhill.com
Please use plain text.
Valued Contributor
MichaelM55
Posts: 203
Registered: ‎06-08-2011
Message 3 of 3 (573 Views)

Re: [IMC 7.0] JAVA: circle of death

[ Edited ]

I finally found the problem:  imcvlandm.exe does not start any longer, It´s same problem mentioned within

http://h30499.www3.hp.com/t5/IMC/IMC-standard-Edition-Trail-version/td-p/2378939#.Uoy1duIgdGM

 

So I undeployed the IMC VLAN management part. After that the GUI is running without any problems, but I lost VLAN information.

After deploying the VLAN management part again, imcvlandm.exe starts without failing. GUI speed stays normal.

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation