Installing OpenVMS V8.4 on RX2620 with SA 6400 (250 Views)
Reply
Regular Advisor
Stephen C. Jackson
Posts: 84
Registered: ‎03-11-2007
Message 1 of 4 (250 Views)
Accepted Solution

Installing OpenVMS V8.4 on RX2620 with SA 6400

I acquired a RX2620, 2 1.6GHz CPUs, 16GB memory, & 2 36GB drives.  It also has a HP Smart Array 6400-128.  As usual these Smart Arrays are always complaining about needing a new battery.  I arranged the 2 disks as a 69.5GB raid 0, DKC0:.  I installed VMS V8.4 with no problems and had it set up the boot.  When I try to boot it,  it fails with a PKC0: not found.  It looks like it sets up the option as just –fl 0,0.   I can boot it from the EFI SHELL,  using fs0:\efi\vms\vms_loader.efi.  When I try to set up the Boot Option, using @SYS$MANAGER:BOOT_OPTIONS.COM, it always sets it up as  PKC0: too and that fails even in validation.

 

Any suggestions?  Can I edit the boot option, from the Boot Configuration,  differently than –fl 0,0?  Should I remove the raid board and go with the onboard SCSI?

 

I have never had this problem with Smart Arrays before.

Stephen C. Jackson
SCJ Consulting
Please use plain text.
Trusted Contributor
Jeremy Begg
Posts: 380
Registered: ‎01-20-2005
Message 2 of 4 (191 Views)

Re: Installing OpenVMS V8.4 on RX2620 with SA 6400

Have you tried configuring the boot option using the iLO Boot Options Maintenance menu?  It might do a better job.

 

My understanding is that when booting on Integrity the VMS system disk will be the disk which holds the EFI script being run to boot the system.  In other words VMS_LOADER.EFI boots the VMS image which is on the disk that VMS_LOADER.EFI itself is on; you can't specify an alternative device name.


Regards,

Jeremy Begg

Please use plain text.
Regular Advisor
Stephen C. Jackson
Posts: 84
Registered: ‎03-11-2007
Message 3 of 4 (184 Views)

Re: Installing OpenVMS V8.4 on RX2620 with SA 6400

I'm not sure what really will work. 

 

I ended up putting in a SA 5300 instead and that worked fine.

 

I'm closing this incident.

 

Stephen C. Jackson
SCJ Consulting
Please use plain text.
Regular Advisor
Stephen C. Jackson
Posts: 84
Registered: ‎03-11-2007
Message 4 of 4 (174 Views)

Re: Installing OpenVMS V8.4 on RX2620 with SA 6400

[ Edited ]

 

I got a reply from John Egolf, of HP, who gave me this work around:

 

Go into the EFI Shell and do

Shell> bcfg boot add 1 fs0:\efi\vms\vms_loader.efi “OpenVMS I64 via bcfg menu”

Shell>exit

 

What this does is add an EFIU menu called “OpenVMS I64 via bcfg menu” at position 1 in the menu order.

There will be no menu options.

 

It does work.

 

 

Stephen C. Jackson
SCJ Consulting
Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation