P4300 Hyper-V Snapshot - Wrong Server gets permission (150 Views)
Reply
Advisor
Frankiboy
Posts: 18
Registered: ‎01-04-2013
Message 1 of 1 (150 Views)

P4300 Hyper-V Snapshot - Wrong Server gets permission

I have a small 2 node hyper-v 2012 cluster with Lefthand P4300 Saniq 10.

i'm using DPM 2012 Sp1 to backup my cluster.

I have laso installed lefthand vss writer on both host and it works fine on one of the host.

On the other host this weird thing happen;

When i run a backup from dpm on a virtual machine hosted on this particular host, i can see in CMC that the snapshot is made. But my scsiinitiator will not make a connection to the snapshotlun, and it times out.

I have actually found why this happens and to resolve it manually, but it has to be done each time i run a backup..... NOT an option.

So... the problem is actually that the snapshot that is made have no read/write for my host, but just for my secondhost. my second host does not have that particular virtual machine online.

To resolve this I right click the snapshot and assign the correct server read right and the snapshot automatically mounts and backup work 100%.

The question is;

1. Why does the snapshow get wrong owner? Even when the name Vss---servername of the snapshot refer to the right hyper-v server?

2. Is there a way i can force the lefthand to give all my hyper-v servers read right to all the snapshot?

 

Looking forward to hear from you if anyone have a solution for this issue.

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation