Re: Signal 11 error while making a SOAP call using Java script in SM9.21 (5728 Views)
Reply
Occasional Contributor
Roopakm
Posts: 2
Registered: ‎08-08-2011
Message 1 of 7 (5,821 Views)

Signal 11 error while making a SOAP call using Java script in SM9.21

Hello,

 

We have integrated SM9.21 with a third party tool using webservices. The custom javascript making a webservice call to the third party application is being run in a schedule record. A custom background process schedules the record to run every min.  The script runs fine for few minutes and then SM application hangs , giving the signal 11 error. the log shows that the call for doSoaprequest method is failing ..This would also result in the background process to hang. Can anyone please suggest how to fix this...

 

The sm.log is as below 

08/08/2011 16:21:25  RTE D (0x08830F90)      DBACCESS - Cache Find   against file ScriptLibrary found 1 record, query: name="SOAP"
 10008( 25461) 08/08/2011 16:21:25  RTE I got doSoapRequest ID
 10008( 25461) 08/08/2011 16:21:25  RTE I Received signal: 11 -- calling log_print_stack_with_info()
 10008( 25461) 08/08/2011 16:21:25  RTE W ==== received signal 11, errno was 0, code was 1, when accessing address 0x000000C0 ====
 10008( 25461) 08/08/2011 16:21:25  RTE I [Curr.Frame][Next Frame][ProgCountr]
 10008( 25461) 08/08/2011 16:21:26  RTE I [0xDB4491E8][0xDB449208][0xF7D3F6D1] libsm.so::log_print_stack_with_info(+0x0021)(0x0000000B,0xDB44960C,0xDB44968C)
 10008( 25461) 08/08/2011 16:21:26  RTE I             [0xDB4499A8][0xF64CE5AC] libjvm.so::_ZN6Thread10muxAcquireEPViPKc(+0x008C)
 10008( 25461) 08/08/2011 16:21:26  RTE I [0xDB4499A8][0xDB4499C8][0xF6411916] libjvm.so::_ZN2os28block_on_serialize_page_trapEv(+0x0026)(0x00000000,0x00000000,0x00000000)
 10008( 25461) 08/08/2011 16:21:26  RTE I [0xDB4499C8][0xDB449B98][0xF641AAB5] libjvm.so::JVM_handle_linux_signal(+0x03A5)(0x0000000B,0xDB449C8C,0xDB449D0C)
 10008( 25461) 08/08/2011 16:21:26  RTE I [0xDB449B98][0xDB449BB8][0xF6416B54] libjvm.so::_Z13signalHandleriP7siginfoPv(+0x0024)(0x0000000B,0xDB449C8C,0xDB449D0C)
 10008( 25461) 08/08/2011 16:21:26  RTE I [0xDB449BB8][0xDB449C78][0xF7E05C33] libsm.so::sytermCatchWithInfoBeforeJVM(+0x00A3)(0x0000000B,0xDB449C8C,0xDB449D0C)
 10008( 25461) 08/08/2011 16:21:26  RTE I [0xDB449C78][0xDAABDD78][0xFFFFE600] <not found>::<not found>(+0x0000)(0x0813B510,0xDAABDDAC,0xDAABDDB0)
 10008( 25461) 08/08/2011 16:21:26  RTE I [0xDAABDD78][0xDAABDD98][0xF5EA10B3] libjava.so::Java_java_lang_ClassLoader_findLoadedClass0(+0x0033)(0x0813B510,0xDAABDDAC,0xDAABDDB0)
 10008( 25461) 08/08/2011 16:21:26  RTE I [0xDAABDD98][0xDAABDDC8][0xF307619B] <not found>::<not found>(+0x0000)(0xDFB9C370,0xD8A03CEC,0x0813B400)
 10008( 25461) 08/08/2011 16:21:26  RTE I [0xDAABDDC8][0xDEE7F9D0][0xF30A7E04] <not found>::<not found>(+0x0000)(0xF66036E8,0x00000008,0x00000020)
 10008( 25461) 08/08/2011 16:21:26  RTE W   Address 0x00000001 (length=20) is not readable
 10008( 25461) 08/08/2011 16:21:26  RTE I [0xDEE7F9D0][0x00000001][0xDEDB0150] <not found>::<not found>(+0x0000)
 10008( 25461) 08/08/2011 16:21:26  RTE W   Address 0x00000001 (length=20) is not readable
 10008( 25461) 08/08/2011 16:21:26  RTE I !!! Core Generation is disabled.  Ignoring Generate Core Dump Request.
 10008( 25461) 08/08/2011 16:21:26  RTE E Recursion in signal handler detected (1)

Any inputs will be helpful..

Thanks in advance

Roopa

Honored Contributor
-m-
Posts: 989
Registered: ‎02-22-2011
Message 2 of 7 (5,802 Views)

Re: Signal 11 error while making a SOAP call using Java script in SM9.21

There was (maybe still is) an issue executing JavaScript/Web Services in the background. Try executing the JavaScript manually several times to confirm it works in the foreground.

Advisor
Joana Garcia
Posts: 27
Registered: ‎09-24-2007
Message 3 of 7 (5,767 Views)

Re: Signal 11 error while making a SOAP call using Java script in SM9.21


-m- wrote:

There was (maybe still is) an issue executing JavaScript/Web Services in the background. Try executing the JavaScript manually several times to confirm it works in the foreground.



Hi,

 

Did you resolve this issue? I have the sam problem in OOB system but in a SM9.20.

 

Thanks a lot.

Kind Regards,

Joana.

Regular Advisor
John_Baker
Posts: 88
Registered: ‎07-10-2009
Message 4 of 7 (5,749 Views)

Re: Signal 11 error while making a SOAP call using Java script in SM9.21

This looks like a JVM crash, which isn't really the fault of HP. I'd suggest upgrading the JVM and sending the hs_X.log file to HP. It'll give you more information on why the JVM crashed.

 

 

John

--

SSO Plugin for HP Service Manager

http://www.ssoforservicemanager.com

 

Honored Contributor
-m-
Posts: 989
Registered: ‎02-22-2011
Message 5 of 7 (5,734 Views)

Re: Signal 11 error while making a SOAP call using Java script in SM9.21

The JVM (customized Tomcat) within the SM application should not be modified. If the JavaScript which invokes the Web Service works in the foreground and not in the background, then a ticket should be opened with Customer Support. If the solution also fails in the foreground, then consider trying to get it to work there first.

Regular Advisor
John_Baker
Posts: 88
Registered: ‎07-10-2009
Message 6 of 7 (5,732 Views)

Re: Signal 11 error while making a SOAP call using Java script in SM9.21

It's a JVM crash. The first step is to try a more modern JVM. Suggesting that the JVM shouldn't be checked can result in lots of effort, only to find out it was the JVM.

 

How is the Tomcat customised? A WebTier war/ear are provided and they should work with any Tomcat within the major version on which WebTier was developed. Keeping with the latest minor release ofTomcat is a good thing given they often fix security issues. Suggesting to a security conscious user that they stick with a dated version of Tomcat isn't good practice.

Honored Contributor
-m-
Posts: 989
Registered: ‎02-22-2011
Message 7 of 7 (5,728 Views)

Re: Signal 11 error while making a SOAP call using Java script in SM9.21

Using Windows terminology for a moment, the scenario and log entries in the original post strongly suggest this failure involves the JVM within the sm.exe executable (not the JVM used to deploy the SM WAR/EAR file).

 

When starting a SM servlet container...

 

Excerpts from 7.0 sm.log file:

1234(  5678) 09/15/2011 23:45:39 Starting tomcat server
1234(  5678) 09/15/2011 23:45:39 Starting Servlet Engine: Apache Tomcat/5.5.17

 

Excerpts from 9.30 sm.log file:

9876(  5432) 09/21/2011 12:10:17  RTE I JVM successfully created
9876(  5432) 09/21/2011 12:10:18 JRTE I Java version: 1.6.0_20

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.