Re: Service Manager 9.33 upgrade issue. (486 Views)
Reply
Occasional Contributor
Kimi_Liu
Posts: 5
Registered: ‎05-03-2014
Message 1 of 2 (491 Views)
Accepted Solution

Service Manager 9.33 upgrade issue.

I try to upgrade the Service Manager from 9.30 to 9.33. But the services can't start. I copy and replayce the upgrade file to the server installation file, and delete old jar files, then try to start services. And get blow error message:

 

4964( 2336) 05/04/2014 09:33:33 RTE I Connected to Oracle Version 11.2.0.1.0
4964( 2336) 05/04/2014 09:33:33 RTE I Oracle Client version: 11.2.0.1.0
4964( 2336) 05/04/2014 09:33:33 RTE E Detected an unsupported version of Oracle Server. To override this please enable the parameter [allowunsupporteddbversion] and restart Service Manager to continue.
4964( 2336) 05/04/2014 09:33:33 RTE E Service Manager will be terminated.
4964( 2336) 05/04/2014 09:33:33 RTE E Please check Service Manager compatibility matrix and upgrade your Oracle software.
4964( 2336) 05/04/2014 09:33:33 RTE E Oracle version incompatible between Server and Client, Never try to reconnect Oracle
4964( 2336) 05/04/2014 09:33:33 RTE I sql total 0.031 call#:4 -->sqociDisconnect:OCISessionEnd
4964( 2336) 05/04/2014 09:33:33 RTE I sql total 0.031 call#:5 -->sqociDisconnect:OCIServerDetach
4964( 2336) 05/04/2014 09:33:33 RTE E Failure opening 'dbdict' file, terminating.
4964( 2336) 05/04/2014 09:33:33 RTE E Failed to initialize one or all of the core files( dbdict, code, format and link)
4964( 2336) 05/04/2014 09:33:33 RTE I -Memory : S(243200) O(97452) MAX(357036) - MALLOC's Total(2717)
4964( 2336) 05/04/2014 09:33:33 RTE I Thread termination in progress
4964( 2336) 05/04/2014 09:33:33 RTE I Shutdown of HP Service Manager environment has completed
4964( 2336) 05/04/2014 09:33:33 RTE D Total number of recorded stacks: 0
4964( 2336) 05/04/2014 09:33:33 RTE I Process termination cleanup complete (exit code=0)
3920( 5072) 05/04/2014 09:33:37 RTE I smservice: initialization complete

 

According to the error message, I guess it should be the db version issue. Maybe I need to add the allowunsupporteddbversion parameter to sm.ini file. But I've never seen the parameter. So I'm not sure.

 

BTW, I've reinstall my Service Manager, but not clean the database. I forget delete the old jar files in the run/lib folder when I try to upgrade. At first I don't know it's the root cause, so I try to reinstall the server. And I remeber we need to drop a record in the database after reinstalling server. Anyone can tell me the table name because I forget it, thanks.

Occasional Contributor
Kimi_Liu
Posts: 5
Registered: ‎05-03-2014
Message 2 of 2 (486 Views)

Re: Service Manager 9.33 upgrade issue.

After adding below configuration to sm.ini, the issue has been solved. Just try. The Client and Server has been upgraded. I plan to upgrade the Mobility, Web-Tier, SRC, KM Search Engine....

 

allowunsupporteddbversion:1

 

My sm.ini:

shared_memory:32000000
log:../logs/sm.log
system:13080
httpPort:13080
sslConnector:0
httpsPort:13443
sqldictionary:oracle10
[oracle10]
sqldb:orcl
sqllogin:XXXXX/XXXXX
sqllibrary:sqoracle.oci10.DLL
plugin0:kmplugin.dll
allowunsupporteddbversion:1

#KM SOLR
KMSearchEngineClass:com.hp.ov.sm.server.plugins.knowledgemanagement.solr.KMSolrSearch
#log4jDebug:com.peregrine.knowledgemanagement
log4jDebug:com.hp.ov.sm.server.plugins.knowledgemanagement.solr.KMSolrSearch

 

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.