Re: SM 9.32 Windows Client not connecting to server after SSL setup (370 Views)
Reply
Advisor
Sridhar_yd
Posts: 45
Registered: ‎08-22-2012
Message 1 of 9 (522 Views)

SM 9.32 Windows Client not connecting to server after SSL setup

Hi Experts,

 

I have SM 9.32 installed.

Did SSL configuration, as per the sm help.

 

Now I am trying to login to windows client. But getting below error message

 

 

"

Error Connecting to server, server not up or wrong connection parameters:
http://localhost:13443/SM/ui

"

 

After SSL, it should point to https instead of http right.

Can you please help me to resolve this.

 

sm.ini and sm.cfg files attached.

 

Regards,
Sridhar

HP Expert
lisajo
Posts: 480
Registered: ‎02-15-2010
Message 2 of 9 (514 Views)

Re: SM 9.32 Windows Client not connecting to server after SSL setup

HI

 

Can you attach the sm log and web logs?

 

Thank you

Lisa

"HP Support
If you find that this post or any post resolves your issue, please make sure to mark it as an accepted solution."
Advisor
Sridhar_yd
Posts: 45
Registered: ‎08-22-2012
Message 3 of 9 (482 Views)

Re: SM 9.32 Windows Client not connecting to server after SSL setup

Hi,

 

Attaching the sm.log file in zip

 

Regards,

Sridhar

Trusted Contributor
hpsmsupport
Posts: 299
Registered: ‎01-25-2011
Message 4 of 9 (474 Views)

Re: SM 9.32 Windows Client not connecting to server after SSL setup

Hi Sridhar,

 

The error msg states an issue with the connection parameter or server is not up.

 

Check the Server hostname and Server port name?, before connecting just try to change the language that would give you a clear picture of connecting parameters.

 

Try to give FQDN of SM server in Server hostname and check the Server port number.

 

regards,

Madhan

Honored Contributor
Piku
Posts: 4,013
Registered: ‎06-17-2010
Message 5 of 9 (464 Views)

Re: SM 9.32 Windows Client not connecting to server after SSL setup

You are getting
http://localhost:13443/SM/ui

so sm client tries to connect to server on local machine, if you server is on different machine then you have to pass hostname/IP.

hth,
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Assign Kudo, if found post useful and mark it accepted if solves the issue.
http://h30499.www3.hp.com/t5/Tips-and-Tricks/Kudos-what-where-how-and-why/m-p/5677925#U5677925
Advisor
Sridhar_yd
Posts: 45
Registered: ‎08-22-2012
Message 6 of 9 (442 Views)

Re: SM 9.32 Windows Client not connecting to server after SSL setup

Hi,

 

I am giving the FQDN for the Server host name and 13443 as port nubmer.

But still I am not able to login.

 

Please help.

 

Regards,
Sridhar

Advisor
Sridhar_yd
Posts: 45
Registered: ‎08-22-2012
Message 7 of 9 (435 Views)

Re: SM 9.32 Windows Client not connecting to server after SSL setup

Please see the attached screenshot

Advisor
Sridhar_yd
Posts: 45
Registered: ‎08-22-2012
Message 8 of 9 (433 Views)

Re: SM 9.32 Windows Client not connecting to server after SSL setup

Hi,

 

Windows client and SM Server are in the same machine.

SM Mobility is also in the same machine.

 

I am trying to build use case on SM moblity. 

 

So, After setting up SSL, I tried to login. But failed.

 

Please help.

 

Regards,
Sridhar

HP Expert
FrankRen
Posts: 23
Registered: ‎03-18-2014
Message 9 of 9 (370 Views)

Re: SM 9.32 Windows Client not connecting to server after SSL setup

The root cause is the following line in sm.log:

3720(  1708) 12/12/2013 10:08:57 JRTE W HP Service Manager Trial license expires on: 2013/12/16Contact Customer Support for a permanent license.

 

It seems at first you don't have the license file:

 2388(   732) 10/18/2013 04:41:26 JRTE E Failed validating license. Terminating the process.
  2388(   732) 10/18/2013 04:41:26 JRTE E Add your licenses in C:\Program Files (x86)\HP\Service Manager 9.30\Server\RUN\LicFile.txt

Then later you got a trial license and the system started, but now it expired.

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.