Re: SLA fields are not populating in IM tickets. (258 Views)
Reply
Frequent Advisor
JosieJosie02
Posts: 62
Registered: ‎01-05-2012
Message 1 of 2 (264 Views)
Accepted Solution

SLA fields are not populating in IM tickets.

Has anyone seen this and do you have a fix?

 

SLA fields are not populating in SD, IM, ChM and PM tickets.

When you open a format for the perspecive phase that SLA information should show, you see the following error messages in the logs.


5604( 4100) 06/18/2014 13:30:27 RTE W A Link record needed by im.incident.subform.tasks.qbe in im.incident.categorization could not be found
5604( 4100) 06/18/2014 13:30:27 RTE W A Link record needed by activity.list.g in im.incident.categorization could not be found
5604( 4100) 06/18/2014 13:30:27 RTE W A Link record needed by sloresponse.active.vj.horz in im.incident.categorization could not be found
5604( 4100) 06/18/2014 13:30:27 RTE W A Link record needed by sloavail.vj.uptime.horz.qbe in im.incident.categorization could not be found
5604( 4100) 06/18/2014 13:30:27 RTE W A Link record needed by sloavail.vj.duration.horz.qbe in im.incident.categorization could not be found
5604( 4100) 06/18/2014 13:30:27 RTE W A Link record needed by Alert.horz.vj in im.incident.categorization could not be found
5604( 4100) 06/18/2014 13:30:27 RTE W A Link record needed by number.vj.tasks in im.incident.categorization could not be found
5604( 4100) 06/18/2014 13:30:27 RTE W A Link record needed by number.vj in im.incident.categorization could not be found
5604( 4100) 06/18/2014 13:30:27 RTE W A Link record needed by number.vj.sla in im.incident.categorization could not be found
5604( 4100) 06/18/2014 13:30:27 RTE W A Link record needed by logical.name.vj.sloavail in im.incident.categorization could not be found
5604( 4100) 06/18/2014 13:30:27 RTE W A Link record needed by logical.name.vj.duration in im.incident.categorization could not be found
5604( 4100) 06/18/2014 13:30:27 RTE W A Link record needed by number.vj.alerts in im.incident.categorization could not be found
5604( 4100) 06/18/2014 13:30:40 RTE W A Link record needed by im.incident.subform.tasks.qbe in im.incident.categorization could not be found
5604( 4100) 06/18/2014 13:30:40 RTE W A Link record needed by activity.list.g in im.incident.categorization could not be found
5604( 4100) 06/18/2014 13:30:40 RTE W A Link record needed by sloresponse.active.vj.horz in im.incident.categorization could not be found
5604( 4100) 06/18/2014 13:30:40 RTE W A Link record needed by sloavail.vj.uptime.horz.qbe in im.incident.categorization could not be found
5604( 4100) 06/18/2014 13:30:40 RTE W A Link record needed by sloavail.vj.duration.horz.qbe in im.incident.categorization could not be found
5604( 4100) 06/18/2014 13:30:40 RTE W A Link record needed by Alert.horz.vj in im.incident.categorization could not be found
5604( 4100) 06/18/2014 13:30:40 RTE W A Link record needed by number.vj.tasks in im.incident.categorization could not be found
5604( 4100) 06/18/2014 13:30:40 RTE W A Link record needed by number.vj in im.incident.categorization could not be found
5604( 4100) 06/18/2014 13:30:40 RTE W A Link record needed by number.vj.sla in im.incident.categorization could not be found
5604( 4100) 06/18/2014 13:30:40 RTE W A Link record needed by logical.name.vj.sloavail in im.incident.categorization could not be found
5604( 4100) 06/18/2014 13:30:40 RTE W A Link record needed by logical.name.vj.duration in im.incident.categorization could not be found
5604( 4100) 06/18/2014 13:30:40 RTE W A Link record needed by number.vj.alerts in im.incident.categorization could not be found

Honored Contributor
John Stagaman
Posts: 3,521
Registered: ‎07-13-2007
Message 2 of 2 (258 Views)

Re: SLA fields are not populating in IM tickets.

[ Edited ]

None of those items are the the problem.

 

After master link records were added to the application (allowing you to define a link record for "probsummary" instead of different link records for each format e.g. "im.incident.categorization ") those errors can appear in the log, but they can be ignored.

 

The code to display a virtual join (the SLA objects in the form, activity history, approval components, etc. are all virtual joins) first looks for a form-specific link (a link record with the same name as your form).

--When a link line is not found for the virtual join input in a link record with the same name as the format, the errors above are generated. 

--There is no adverse impact, however, as the master link record is then called and the corresponding link for the virtual join is used.

 

The error messages that the link line is not found in im.incident.categorization for the subform can be ignored. The out of box master link records include the necessary link line definitions. Note that if you modified or replaced the master link records with custom objects, you may have removed the necesssary link lines. 

 

When you check the source tables for SLM are records being created for the tickets?

--Have you enabled the SLM module? Service Level Management > Edit Control Record 

--Have you enabled SLM for the Appliction Module? Service Level Management > Configure Application

--After defining any changes to SLM, or adding your SLP/SLA definitions, did you restart the SLA process from system status or restart the SM server? This is required to enable the updates. 

----------------------------------------------------
Kudos - what, where, how, and why
Want Good Answers? Ask Good Questions...
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.