Re: Problem when congifure SSL (5611 Views)
Reply
HP Expert
NgocNgo
Posts: 223
Registered: ‎06-30-2013
Message 1 of 11 (5,724 Views)
Accepted Solution

Problem when congifure SSL

Hi experts,

 

My customer has an issue while trying to configure the SSL.

This is the error that he received on the log:

ERROR http-bio-8443-exec-3 com.hp.ov.sm.client.webtier.SCLogging - Oct 11, 2013 15:39:38 GMT+05:30 [ERROR] SOAP Failure - Session no longer valid

ERROR http-bio-8443-exec-3 com.hp.ov.sm.client.webtier.SCLogging - Oct 11, 2013 15:39:38 GMT+05:30 [ERROR] request:

<setPreferences>

 <name>setPreferences</name>

 <preferences>

  <preference name="viewactivenotes" value="false" />

  <preference name="viewpromptforsave" value="true" />

  <preference name="clientprinting" value="true" />

  <preference name="clientsideunload" value="true" />

  <preference name="viewrecordlist" value="true" />

  <preference name="heartbeatinterval" value="15" />

  <preference name="compress_soap" value="true" />

  <preference name="ssl" value="true" />

  <preference name="viewclassicmenu" value="false" />

  <preference name="useservertabs" value="false" />

  <preference name="recordlistcount" value="50" />

  <preference name="clientformcache" value="true" />

  <preference name="chartrefresh" value="60" />

  <preference name="essuser" value="false" />

 </preferences>

</setPreferences>

ERROR http-bio-8443-exec-3 com.hp.ov.sm.client.webtier.SCLogging - Oct 11, 2013 15:39:38 GMT+05:30 [ERROR] response:

<Fault>

 <faultcode>SOAP-ENV:Server</faultcode>

 <faultstring>Session no longer valid</faultstring>

 <faultactor>Server</faultactor>

</Fault>

Please let me know if you have any idea on the error.

Thanks in advance and Best regards,

HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Also, please assign a Kudo to the post if you find it is helpful
HP Expert
viprom
Posts: 321
Registered: ‎11-09-2011
Message 2 of 11 (5,703 Views)

Re: Problem when congifure SSL

On which stage you get this error - after configuring SSL and trying to connect with web client?

Do you get other errors?

You can advice your customer to use this guide, to doublecheck his steps to configure SSL:

http://support.openview.hp.com/selfsolve/document/KM472182

-----
If you find this or other posts helpful, please do not forget to click the Kudo Star or to mark it as a Solution if you are the owner of the thread. Thanks :)
HP Expert
NgocNgo
Posts: 223
Registered: ‎06-30-2013
Message 3 of 11 (5,692 Views)

Re: Problem when congifure SSL

Hi Viprom,

 

Thank you a lot for your help!

Actually, I provided the customer the attached documents to configure SSL. Pls note that the cust SM ver. is SM 9.32, but the provided documents I provide him is for SM 7. So is that the cause of the issue.

He got this error before:

 

 Oct 10, 2013 4:53:29 PM org.apache.catalina.core.ApplicationContext log

INFO: ContextListener: attributeAdded('org.apache.jasper.compiler.TldLocationsCache', 'org.apache.jasper.compiler.TldLocationsCache@7ad957')

Oct 10, 2013 4:53:43 PM org.apache.catalina.core.StandardWrapperValve invoke

SEVERE: Servlet.service() for servlet [HP Service Manager Web] in context with path [/webtier-9.32] threw exception [com.hp.ov.sm.client.common.communications.CommunicationException: javax.xml.soap.SOAPException: Message send failed - connection to host http://10.3.1.20:13083/SM/ui refused. Your server session may have been terminated or timed out. You may need to go to the login page and log in once again.] with root cause

java.net.ConnectException: Connection refused: connect

            at java.net.PlainSocketImpl.socketConnect(Native Method)

            at java.net.PlainSocketImpl.doConnect(Unknown Source)

            at java.net.PlainSocketImpl.connectToAddress(Unknown Source)

            at java.net.PlainSocketImpl.connect(Unknown Source)

            at java.net.SocksSocketImpl.connect(Unknown Source)

            at java.net.Socket.connect(Unknown Source)

            at java.net.Socket.connect(Unknown Source)

            at sun.net.NetworkClient.doConnect(Unknown Source)

            at sun.net.www.http.HttpClient.openServer(Unknown Source)

            at sun.net.www.http.HttpClient.openServer(Unknown Source)

            at sun.net.www.http.HttpClient.<init>(Unknown Source)

            at sun.net.www.http.HttpClient.New(Unknown Source)

            at sun.net.www.http.HttpClient.New(Unknown Source)

            at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(Unknown Source)

            at sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Source)

            at sun.net.www.protocol.http.HttpURLConnection.connect(Unknown Source)

            at sun.net.www.protocol.http.HttpURLConnection.getOutputStream(Unknown Source)

            at com.hp.ov.sm.client.common.soap.SCSOAPConnectionImpl.send(SCSOAPConnectionImpl.java:177)

            at com.hp.ov.sm.client.common.soap.SCSOAPConnectionImpl.call(SCSOAPConnectionImpl.java:109)

            at com.hp.ov.sm.client.common.soap.BaseSoapClient.internalDoSoapTransact(BaseSoapClient.java:318)

            at com.hp.ov.sm.client.common.communications.SOAPClient.internalDoSoapTransact(SOAPClient.java:1126)

            at com.hp.ov.sm.client.common.soap.SoapReq.run(SoapReq.java:263)

            at com.hp.ov.sm.client.common.soap.BaseSoapClient.syncExecInCurrentThread(BaseSoapClient.java:419)

            at com.hp.ov.sm.client.common.soap.BaseSoapClient.doSyncRequest(BaseSoapClient.java:439)

            at com.hp.ov.sm.client.common.soap.SoapReq.syncExec(SoapReq.java:113)

            at com.hp.ov.sm.client.common.communications.SOAPClient.transact(SOAPClient.java:1025)

            at com.hp.ov.sm.client.common.communications.SOAPClient.getLanguages(SOAPClient.java:987)

            at com.hp.ov.sm.client.webtier.WebController.loadLanguageList(WebController.java:3588)

            at com.hp.ov.sm.client.webtier.WebControllerServlet.initiateSession(WebControllerServlet.java:730)

            at com.hp.ov.sm.client.webtier.WebControllerServlet.process(WebControllerServlet.java:584)

            at com.hp.ov.sm.client.webtier.WebControllerServlet.processHTTPRequest(WebControllerServlet.java:463)

            at com.hp.ov.sm.client.webtier.WebControllerServlet.doGet(WebControllerServlet.java:416)

            at javax.servlet.http.HttpServlet.service(HttpServlet.java:621)

            at javax.servlet.http.HttpServlet.service(HttpServlet.java:728)

            at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:305)

            at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)

            at com.hp.ov.sm.client.webtier.util.UserLocaleFilter.doFilter(UserLocaleFilter.java:50)

            at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)

            at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)

            at com.hp.ov.web.csrf.AntiCSRFFilter.doFilter(AntiCSRFFilter.java:136)

            at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)

            at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)

            at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:265)

            at org.acegisecurity.providers.anonymous.AnonymousProcessingFilter.doFilter(AnonymousProcessingFilter.java:125)

            at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:275)

            at org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilter(HttpSessionContextIntegrationFilter.java:286)

            at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:275)

            at org.acegisecurity.util.FilterChainProxy.doFilter(FilterChainProxy.java:149)

            at org.acegisecurity.util.FilterToBeanProxy.doFilter(FilterToBeanProxy.java:98)

            at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)

            at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)

            at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:265)

            at com.hp.ov.sm.client.webtier.UserAgentFilter.doFilter(UserAgentFilter.java:48)

            at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:275)

            at com.hp.ov.sm.client.webtier.UserAgentFilter.doFilter(UserAgentFilter.java:48)

            at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:275)

            at com.hp.ov.cwc.web.CacheControlFilter.doFilter(CacheControlFilter.java:70)

            at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:275)

            at org.acegisecurity.util.FilterChainProxy.doFilter(FilterChainProxy.java:149)

            at org.acegisecurity.util.FilterToBeanProxy.doFilter(FilterToBeanProxy.java:98)

            at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)

            at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)

But then I provided him this solution:

  1. Copy servlet-api.jar and jsp-api.jar from <Tomcat>\\common\\lib to <Tomcat>\\common\\endorsed
  2. Clear tomcat cache
  3. Restart Tomcat

And now he met the error that I provided on the above post :(

 

HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Also, please assign a Kudo to the post if you find it is helpful
Occasional Advisor
jishengli
Posts: 5
Registered: ‎07-25-2011
Message 4 of 11 (5,677 Views)

Re: Problem when congifure SSL

Hi guy, could you paste the content of sm.cfg?

HP Expert
viprom
Posts: 321
Registered: ‎11-09-2011
Message 5 of 11 (5,672 Views)

Re: Problem when congifure SSL

@ NgocNgo

You def need to follow the 9.3x guide as you are configuring SSL on 9.32 machine.

-----
If you find this or other posts helpful, please do not forget to click the Kudo Star or to mark it as a Solution if you are the owner of the thread. Thanks :)
HP Expert
viprom
Posts: 321
Registered: ‎11-09-2011
Message 6 of 11 (5,668 Views)

Re: Problem when congifure SSL

[ Edited ]

Check this as well KM1417391

 

* plus if you are using ldap check this KM1416868

-----
If you find this or other posts helpful, please do not forget to click the Kudo Star or to mark it as a Solution if you are the owner of the thread. Thanks :)
Occasional Advisor
jishengli
Posts: 5
Registered: ‎07-25-2011
Message 7 of 11 (5,660 Views)

Re: Problem when congifure SSL

[ Edited ]

I doubt if the port 13083 is a http port. And also you can add debughttp:1 in sm.ini to check the SSL certificate verification.

HP Expert
NgocNgo
Posts: 223
Registered: ‎06-30-2013
Message 8 of 11 (5,645 Views)

Re: Problem when congifure SSL

Hi Shengli,

Thanks for your help

I have attached the sm.cfg and sm.ini for your reference. Could you please have a check on these files?:)

 

Thank you in advance!

HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Also, please assign a Kudo to the post if you find it is helpful
HP Expert
NgocNgo
Posts: 223
Registered: ‎06-30-2013
Message 9 of 11 (5,644 Views)

Re: Problem when congifure SSL

Hi Viprom,

 

THank you a lot!

I have provided the customer the KM, hope they can fix their error soon :)

HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Also, please assign a Kudo to the post if you find it is helpful
Occasional Advisor
jishengli
Posts: 5
Registered: ‎07-25-2011
Message 10 of 11 (5,629 Views)

Re: Problem when congifure SSL

i can't see port 13083 is in the sm.cfg.

so please check if the port 13083 is listenning.

HP Expert
NgocNgo
Posts: 223
Registered: ‎06-30-2013
Message 11 of 11 (5,611 Views)

Re: Problem when congifure SSL

Hi,

 

Thanks for your help!

He has successflully configured the SSL.

 

I do appreciate your assistance :).

HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Also, please assign a Kudo to the post if you find it is helpful
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.