Problem connect Oracle 11 in sm.ini (616 Views)
Reply
Valued Contributor
dasarro23
Posts: 124
Registered: ‎10-28-2011
Message 1 of 3 (616 Views)
Accepted Solution

Problem connect Oracle 11 in sm.ini

Hello,

We SM with Oracle DB 11 but when sm.ini include the [Oracle] or [oracle11] the system fails to connect to the database.

Currently the systematic work properly with these parameters
sqldictionary: oracle11
sqllibrary: sqoracle.oci11.so
plugin0: libkmplugin.so

But in the logfiles appears that the DB is (oracle10)

We do not understand why we are showing this, plus you do not know if this is affecting performance.

Greetings!

HP 9.30 Patch 5
Please use plain text.
HP Expert
viprom
Posts: 321
Registered: ‎11-09-2011
Message 2 of 3 (599 Views)

Re: Problem connect Oracle 11 in sm.ini

Hi,

 

This is how my OOB sm.ini looks like:

 

sqldictionary:oracle10
[oracle10]
sqldb:***
*sqllogin:***
sqllibrary:sqoracle.oci10.DLL
plugin0:kmplugin.dll

 

Note that I'm using Oracle 11gR2.

-----
If you find this or other posts helpful, please do not forget to click the Kudo Star or to mark it as a Solution if you are the owner of the thread. Thanks :)
Please use plain text.
Honored Contributor
Piku
Posts: 3,683
Registered: ‎06-17-2010
Message 3 of 3 (598 Views)

Re: Problem connect Oracle 11 in sm.ini

Hi,

What is the error you are getting after adding [Oracle] or [oracle11] ?
from one of KD :
sm.ini included the [oracle10] parameter that is created by the installer. This needs to be commented out by placing [ ] around the parameter.

-------------
Another KD,


Knowledge document information



Title:
Connecting to dbtype 'oracle10' local Oracle server
Document ID:
KM1363211
Product:
Service Manager
Version:
7.11,9.21,9.30
Updated:
2012-Apr-16
Summary:
Cannot use "oracle11" in sm.ini


Problem

If you use ORACLE 11g version for your RDBMS, the sm.ini the parameter "sqldictionary" and a group name still need to point to "[oracle10]" .

If you try to use "oracle11" with Windows you'll receive error messages like these:

6936( 1756) 04/16/2012 00:47:02 RTE E sqociExec error: sqlcode=12560 message=ORA-12560: TNS:protocol adapter error
6936( 1756) 04/16/2012 00:47:02 RTE E sqociExec error statement=Connecting to dbtype 'oracle10' local Oracle server
Cause
For Service Manager sqoracle.oci10.dll on windows is used for both oracle 10 and 11 client.

Fix

Use these sm.ini parameters:

[oracle10]
sqldictionary:oracle10
sqllibrary:sqoracle.oci10.DLL



hth,
Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation