Re: KM- Advanced Search in Knowledge Management doesn't work. (280 Views)
Reply
Occasional Advisor
sudeep2
Posts: 8
Registered: ‎09-16-2012
Message 1 of 4 (310 Views)
Accepted Solution

KM- Advanced Search in Knowledge Management doesn't work.

Hello Experts,

 

I am using the advanced search option in KM.

I am trying to search using the "creation date after" and "creation date before" fields. But no results are appearing.

Any idea what the problem could be or when I can begin to look.

 

Regards,

Sudeep

Occasional Advisor
sudeep2
Posts: 8
Registered: ‎09-16-2012
Message 2 of 4 (309 Views)

Re: KM- Advanced Search in Knowledge Management doesn't work.

The version of SM is 9.30

Honored Contributor
John Stagaman
Posts: 3,469
Registered: ‎07-13-2007
Message 3 of 4 (299 Views)

Re: KM- Advanced Search in Knowledge Management doesn't work.

For the Knowledge Library you are trying to search, in the Knowledge Library record, confirm that the creation date field is included in the fields mapped to the KM search server for indexing. If they are not listed they will not be searchable.

IF you need to modify the field mappings, after making a change you need to do a full reindex before the changes will be active.

----------------------------------------------------
Kudos - what, where, how, and why
Want Good Answers? Ask Good Questions...
Occasional Advisor
sudeep2
Posts: 8
Registered: ‎09-16-2012
Message 4 of 4 (280 Views)

Re: KM- Advanced Search in Knowledge Management doesn't work.

Thank you John. The creation date  field is there in the field mapping.

 

HP support tells me there's a known issue with this. The search by creation date range works only when the date format in the operator record and in the system record match. I did a test and they were right.

Note- The date formats should be the same both while creating and searching.

 

 

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.