Re: Change views not working after upgrading from SM 9.30 to SM 9.31 (442 Views)
Reply
Valued Contributor
Kris Jensen
Posts: 89
Registered: ‎02-06-2008
Message 1 of 5 (476 Views)
Accepted Solution

Change views not working after upgrading from SM 9.30 to SM 9.31

Hi.  We have a weird issue happening.  After we upgraded our SM 9.30 region to SM 9.31, we found some strange behaviour occurring in then Change module while testing.  For all users (except SysAdmins), the system is giving: Invalid syntax for query.  Failed parsing (scm.advanced,get.records.1) for every view.  The system appears to be adding "and ()" at the end of every query that is run by a view.  Why would the system do this, and where can we go to fix this?

 

We posted a ticket to HP and they requested a trace.  That was two weeks ago.  They do not have any updates for us yet.  Granted they are busy, but we need to get this fixed so we can meet our own upgrade target dates.

 

Kris

Esteemed Contributor
Kelalek2
Posts: 193
Registered: ‎08-05-2011
Message 2 of 5 (456 Views)

Re: Change views not working after upgrading from SM 9.30 to SM 9.31

Well, the good news is that if logging as an admin doesn't cause errors the data itself is working.

 

I've a hunch that we ran into same kind of problem while our upgrade process. I'm not sure, but try following:

 

1) Choose a Change Management profile which is used in your organization  (I use Chm Group as an example)

2) Now create a duplicate of that profile while copying values one by one to the new empty Change Management profile. (Don't use the Add to make a duplicate, you need empty fields to do this.)

3) Backup you old Change Management profile -> rename it (like Chm Group - backup)

4) Save you new "duplicate" with a same name the backupped one bad previously (like Chm Group)

5) Try to log in with any user which Change Profile includes that group (like Chm Group)

 

Anyway, that solved my problem. Somehow the upgrade spoiled the original Change Management profile. Which is odd, though, was that only one Change Management profile was affected. Didn't look further what in the upgrade caused the problem.

 

Hope this helps!

Valued Contributor
Kris Jensen
Posts: 89
Registered: ‎02-06-2008
Message 3 of 5 (447 Views)

Re: Change views not working after upgrading from SM 9.30 to SM 9.31

Thanks.  I'll give it a try.

 

Kris

Valued Contributor
Kris Jensen
Posts: 89
Registered: ‎02-06-2008
Message 4 of 5 (442 Views)

Re: Change views not working after upgrading from SM 9.30 to SM 9.31

Well, that works!  Now I have to go and rebuild the other 60-70 change profiles...  But at least it works.

 

Thanks again!

 

Kris

Esteemed Contributor
Kelalek2
Posts: 193
Registered: ‎08-05-2011
Message 5 of 5 (421 Views)

Re: Change views not working after upgrading from SM 9.30 to SM 9.31

Great! (And it's also positive that you managed to understand what I meant, looking know what I wrote...looks like I was having a Monday  :) )

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.