TRIM 7.3.4 # 5739 Locale and language setting not sticking (324 Views)
Reply
Super Advisor
JasonIMEX
Posts: 276
Registered: ‎06-17-2010
Message 1 of 8 (324 Views)

TRIM 7.3.4 # 5739 Locale and language setting not sticking

Anyone else having this issue?

 

Even when setting them as a global setting they dont seem to stick. I have also tried setting the registry key..

 

HKEY_CURRENT_USER\Software\Hewlett-Packard\HP TRIM

 

Language = 1 (international)

 

But when I oipen TRIM it reverts back to 4 (US)

 

Any help on this would be greatly appreciated.

HP Expert
Greg Fraser_1
Posts: 854
Registered: ‎01-02-2002
Message 2 of 8 (297 Views)

Re: TRIM 7.3.4 # 5739 Locale and language setting not sticking

Haven't seen the language change like that before.

 

The fact that the Global settings aren't being kept is directly related to the language setting. Global settings are stored under the language.

 

How was it installed? As 'US'?

 

What happens if you change the language settings through the Tools > options > locale and close trim and reopen?

 

 

**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Hewlett Packard**
Super Advisor
JasonIMEX
Posts: 276
Registered: ‎06-17-2010
Message 3 of 8 (290 Views)

Re: TRIM 7.3.4 # 5739 Locale and language setting not sticking

Hi Greg
Thanks for your reply. If I manually set the Locale and language settings they stay.. Though this is tough to do for the entire fleet. If I change the above registry key to 1 (international) then open TRIM it actually changes back to a 4 (US)
HP Expert
Greg Fraser_1
Posts: 854
Registered: ‎01-02-2002
Message 4 of 8 (287 Views)

Re: TRIM 7.3.4 # 5739 Locale and language setting not sticking

Yep I agree, just wanted to confirm that it would stick.

 

I wonder if there is anything else at play here, have you considered running regshot before and after you make the change in the users settings?

There might be something else that needs to change, sometimes you'll find several keys need changing. Regshot should be able to identify if there are any others.

**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Hewlett Packard**
Super Advisor
JasonIMEX
Posts: 276
Registered: ‎06-17-2010
Message 5 of 8 (281 Views)

Re: TRIM 7.3.4 # 5739 Locale and language setting not sticking

Thanks Greg will give that a go..

Will post on my results in case anyone else stumbles across this.. One thought was perhaps this setting was within the database.. Though global settings should set this.
Super Advisor
JasonIMEX
Posts: 276
Registered: ‎06-17-2010
Message 6 of 8 (264 Views)

Re: TRIM 7.3.4 # 5739 Locale and language setting not sticking

Nope does look like its just that key there.. Not sure why changing it through the registry would not stick though.. Opening TRIM just reverts it back

 

HKU\S-1-5-21-2880924088-2645547331-1629329889-1486\Software\Hewlett-Packard\HP TRIM\Language: 0x00000004
HKU\S-1-5-21-2880924088-2645547331-1629329889-1486\Software\Hewlett-Packard\HP TRIM\Language: 0x00000001

Honored Contributor
EWillsey
Posts: 1,929
Registered: ‎04-20-2010
Message 7 of 8 (260 Views)

Re: TRIM 7.3.4 # 5739 Locale and language setting not sticking

Just curious.... What's the language value in the MSISettings section of HKLM for TRIM?
Super Advisor
JasonIMEX
Posts: 276
Registered: ‎06-17-2010
Message 8 of 8 (253 Views)

Re: TRIM 7.3.4 # 5739 Locale and language setting not sticking

Yeah I thought on that one myself.. But seems MSISettings is pretty much empty. Would have to double check though.

Had cases where the HKCU gets overwritten by HKLM before as well
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.