Re: IDOL DCI not returning content search result (685 Views)
Reply
Advisor
Sarathbabuk
Posts: 34
Registered: ‎07-09-2012
Message 1 of 21 (1,356 Views)

IDOL DCI not returning content search result

Hi,

 

We are testing 7.2.1 version as per our requirement. In this version IDOL is the content indexer. We installed trim server and  IDOL on the same machine. Configured the IDOL as a content indexor. Initially it was not indexing anything but later we have done a reindex and it generated a log file saying number of files indexed.

When we do a content search through the desktop client and webclient it is not showing any result.

I have done all the configurations as understood and the information from hp self serve site

 

Still we unable to search the result.

 

Reagards,

Sarath,

Please use plain text.
Esteemed Contributor
Richard Kelly_7
Posts: 203
Registered: ‎02-15-2007
Message 2 of 21 (1,344 Views)

Re: IDOL DCI not returning content search result

Sarath,

    I am a little nervous over "Configured the IDOL" in your description.   Certainly for testing and assuming single server you should not have to configure anything - it should all be defaulted.   Steps I would suggest:

 

1. If you changed anything in the IDOL configuration, or the TRIM configuration try removing and reinstalling the IDOL component, so it is all default. (Delete any remaining files in c:\HPTRIM\IDOL after remove)  It is very easy to make errors in the IDOL config files.

2. Ensure the IDOL services are all running (after a re-install they will not be as the password will be incorrect).

3. ReIndex if required.

3. Check out the logs for BOTH content servers - there is an application log, an indexing log and a query log for each in C:\HPTRIM\IDOL\TRIM Content Service <x>\logs by default and they can all help.

4. Post the logs if still not working.

 

RIchard

Note: Any posts I make on this forum are my own personal opinion and do not constitute a formal commitment on behalf of HP.
Please use plain text.
Advisor
Sarathbabuk
Posts: 34
Registered: ‎07-09-2012
Message 3 of 21 (1,295 Views)

Re: IDOL DCI not returning content search result

Hi Richard,

 

Thanks for your reply.

configuration means in my question is creating  IDOL for a dataset. once i create the IDOL for a dataset for the first time 3 IDOL services are created, the services are running successfully.

 

I have done re-indexin also. The logs files are created successfully and shows the number of files indexed. But, when i was doing a content search by selecting "Document Content" from the search it returns nothing.

At present i have tiff , XML and html files are in the dataset.

 

Regards,

Sarath.

 

 

Please use plain text.
Esteemed Contributor
Richard Kelly_7
Posts: 203
Registered: ‎02-15-2007
Message 4 of 21 (1,278 Views)

Re: IDOL DCI not returning content search result

Ah, - just the TRIM config of IDOL then - good.

 

Did you click the "Test" button after you configured it?

Did you confirm the three IDOL services are still running when you did the search?

Did you check the IDOL logs in C:\HPTRIM\IDOL\TRIM ******\LOGS - can you post them from all three directories?

Can you check C:\HPTRIM\IDOL\TRIM Content Service *\status and see if there is anything in them? (There will be whilst indexing is pending, but they should eventually go - they will not go if the services are not running).

Depending on the TRIM build number, things have improved over when the index actually returns as completed.

Note: Any posts I make on this forum are my own personal opinion and do not constitute a formal commitment on behalf of HP.
Please use plain text.
Advisor
Sarathbabuk
Posts: 34
Registered: ‎07-09-2012
Message 5 of 21 (1,247 Views)

Re: IDOL DCI not returning content search result

All 3 Services are running.

there are no files under HPTRIM\IDOL\TRIM Content Service*\State.

Attached the log files of all three services.

Please use plain text.
Esteemed Contributor
Richard Kelly_7
Posts: 203
Registered: ‎02-15-2007
Message 6 of 21 (1,238 Views)

Re: IDOL DCI not returning content search result

The lines :

23/08/2012 02:19:47 [1] Error: Database TRIM_NS already exists.
23/08/2012 02:37:47 [1] Error: Database TRIM_72 already exists.

 

tell me you have had a couple of goes at creating indexes.  Unfortunately when you delete a content index in Enterprise Studio for TRIM, it doesn't delete it from IDOL!   This is something I have raised support issues for.

 

The only way to get round this is to delet the COntent indexes in TES, remove the IDOL feature, remove the left over files and start again.  THe following is a foolproof (or so I think) set of steps - follow EXACTLY.....

 

1.    Delete all content indexes in Enterprise Studio.
2.    Save and Deploy
3.    Stop AND DISABLE all TRIM and IDOL services
4.    Modify TRIM install and remove the IDOL feature.
5.    Reboot
6.    Delete c:\HPTRIM\IDOL directory
7.    Delete C:\Program Files\Hewlett-Packard\HP TRIM\IDOL directory
8.    Reinstall IDOL feature.
9.    Make any IDOL COnfig changes you are SURE about (none in this case).
10.    Re-Enable, but don't start, the TRIM services
11.    Change the password on the IDOL services back to what it should be (it will be incorrect but not visible….)
12.    Reboot
13.    Recreate the content indexes in Enterprise Studio and reindex.
14.    Give it a few minutes to complete.
15.    Save and Deploy the config.

Note: Any posts I make on this forum are my own personal opinion and do not constitute a formal commitment on behalf of HP.
Please use plain text.
Valued Contributor
raynebc
Posts: 507
Registered: ‎05-06-2009
Message 7 of 21 (1,227 Views)

Re: IDOL DCI not returning content search result

I'm glad we haven't tried to implement Trim 7.2 yet.  IDOL doesn't seem ready.

Please use plain text.
Honored Contributor
Sander Hoogwerf
Posts: 377
Registered: ‎11-05-2008
Message 8 of 21 (1,195 Views)

Re: IDOL DCI not returning content search result

Instead of reinstalling, you can use the following command to delete the database from IDOL.

 

http://localhost:9001/DREDELDBASE?DREdbname=TRIM_<your dataset id>

 

After that you can compact the database to release the space in the IDOL database

http://localhost:9001/DRECOMPACT

 

 

(Any opinions expressed in this forum are my own personal opinion and should not be construed as an official statement by Hewlett Packard.)

Analytics & Data Management
Application & Business Services
HP Enterprise Services
Please use plain text.
Valued Contributor
raynebc
Posts: 507
Registered: ‎05-06-2009
Message 9 of 21 (1,190 Views)

Re: IDOL DCI not returning content search result

Allowing destructive commands to be injected into a URL like that make me a bit nervous, can that be disabled?

Please use plain text.
Honored Contributor
Sander Hoogwerf
Posts: 377
Registered: ‎11-05-2008
Message 10 of 21 (1,137 Views)

Re: IDOL DCI not returning content search result

These commands indeed can be issued from any client (just checked the both commands in our test environment) in the default configuration.

 

An IDOL configuration (for TRIM) should have the QueryClients, AdminClients and IndexClients configuration options (in TRIM IDOL Service.cfg) set to the TRIM servers only.

Typical that the TRIM documentation doesn't mention this.

(Any opinions expressed in this forum are my own personal opinion and should not be construed as an official statement by Hewlett Packard.)

Analytics & Data Management
Application & Business Services
HP Enterprise Services
Please use plain text.
Valued Contributor
raynebc
Posts: 507
Registered: ‎05-06-2009
Message 11 of 21 (1,137 Views)

Re: IDOL DCI not returning content search result

Well at least they put in the ability to restrict the use of those injected commands.  Allowing them from any source by default is an extremely bad idea though.  They really need to change that.  I can't submit an enhancement request at this time, would anybody here be able to do so?

Please use plain text.
HP Expert
Neil Summers
Posts: 1,001
Registered: ‎10-08-2008
Message 12 of 21 (1,130 Views)

Re: IDOL DCI not returning content search result

Yeah I'll look into it :-)

Neil


Note: Any posts I make on this forum are my own personal opinion and do not constitute a formal commitment on behalf of HP.

(Please state the version of TRIM/HPRM you're using in all posts)

HP Software Support Online (SSO): http://support.openview.hp.com
Please use plain text.
HP Expert
Neil Summers
Posts: 1,001
Registered: ‎10-08-2008
Message 13 of 21 (1,124 Views)

Re: IDOL DCI not returning content search result

[ Edited ]

I've raised it internally for investigation.

 

(P.S. It's only possible if the firewall on the IDOL server is relaxed enough to allow such a command to be issued from another machine on the network.)

Neil


Note: Any posts I make on this forum are my own personal opinion and do not constitute a formal commitment on behalf of HP.

(Please state the version of TRIM/HPRM you're using in all posts)

HP Software Support Online (SSO): http://support.openview.hp.com
Please use plain text.
Valued Contributor
raynebc
Posts: 507
Registered: ‎05-06-2009
Message 14 of 21 (1,111 Views)

Re: IDOL DCI not returning content search result

Are you talking about the built-in OS firewall, or some firewalling component of IDOL?  Does IDOL need to allow inbound HTTP traffic from servers/clients for normal functionality, or are these URL commands just for specialized use?

Please use plain text.
HP Expert
Neil Summers
Posts: 1,001
Registered: ‎10-08-2008
Message 15 of 21 (1,102 Views)

Re: IDOL DCI not returning content search result

[ Edited ]

raynebc wrote:

Are you talking about the built-in OS firewall, or some firewalling component of IDOL?  Does IDOL need to allow inbound HTTP traffic from servers/clients for normal functionality, or are these URL commands just for specialized use?


I was referring to an OS or other firewall. Typically the Windows firewall by default won't allow this sort of command to be issued to the IDOL server from some other client on the network.

 

The TRIM clients themselves don't need to communicate with IDOL; only the TRIM server(s) for the purposes of indexing and querying and for some specialised operations such as creating an IDOL index via TES.

Neil


Note: Any posts I make on this forum are my own personal opinion and do not constitute a formal commitment on behalf of HP.

(Please state the version of TRIM/HPRM you're using in all posts)

HP Software Support Online (SSO): http://support.openview.hp.com
Please use plain text.
Valued Contributor
raynebc
Posts: 507
Registered: ‎05-06-2009
Message 16 of 21 (1,089 Views)

Re: IDOL DCI not returning content search result

That's why I'm asking, because I'm not sure if it will be fully covered by the documentation.  If I install Trim 7.2 and set up IDOL on a single server, will I need to create firewall rules to allow inbound HTTP from each workgroup server's IP address to the IDOL server, or will it only need to accept HTTP requests from itself (and any other IDOL server I eventually set up)?

Please use plain text.
Advisor
Sarathbabuk
Posts: 34
Registered: ‎07-09-2012
Message 17 of 21 (1,069 Views)

Re: IDOL DCI not returning content search result

Hi,

 

I checked with my networking guys, the port 9001 is enabled. But still i am not able to fetch the search result it is returning zero records.

 

Can somebody help me on this.

 

Regards,

Sarath.

Please use plain text.
Esteemed Contributor
Richard Kelly_7
Posts: 203
Registered: ‎02-15-2007
Message 18 of 21 (1,060 Views)

Re: IDOL DCI not returning content search result

Post the logs again, as detailed in the entry from three weeks ago.  I am asuming you did the reinstall process.

Note: Any posts I make on this forum are my own personal opinion and do not constitute a formal commitment on behalf of HP.
Please use plain text.
Advisor
Sarathbabuk
Posts: 34
Registered: ‎07-09-2012
Message 19 of 21 (1,039 Views)

Re: IDOL DCI not returning content search result

Hi All,

 

I fixed it . its a configuration change "DatabaseReadOnly=TRUE" to "FALSE" and re-indexed. Now getting the content search result.

 

Thanks for all suggessions and help.

 

Regards,

Sarath.

Please use plain text.
Regular Advisor
T0mTran
Posts: 164
Registered: ‎07-27-2011
Message 20 of 21 (697 Views)

Re: IDOL DCI not returning content search result

Sarath,

 

Could you please explain how you fixed it? We are having a similar issue and don't know how to fix it.

 

Thanks,

 

Tom

Please use plain text.
Honored Contributor
Grundy
Posts: 2,832
Registered: ‎02-16-2009
Message 21 of 21 (685 Views)

Re: IDOL DCI not returning content search result

TomTran,

 

The IDOL implementation has moved on considerably since 7.2.1 and has very different issues to what would have been the problem above.

I would suggest starting a new thread and describing your current TRIM server/build and what you are seeing with IDOL.

 

Cheers! :)



::::::::::::::::::::::
NOT A HP EMPLOYEE
::::::::::::::::::::::

Kapish.com.au
Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation