VCSU - Previous firmware update was not completed (2141 Views)
Reply
Advisor
Adam X. White
Posts: 19
Registered: ‎04-18-2010
Message 1 of 3 (2,141 Views)
Accepted Solution

VCSU - Previous firmware update was not completed

Hi

 

So I ran into this problem when attempting to update the Virtual Connect FlexFabric 10Gb/24-port modules on my new c7000 from 3.15 to 3.18. Disabling DNS on the interconnect bays resolved the error and restored functionality as described in the advisory, but now when I attempt to retry the update, VCSU returns the following result:

 

The following modules will NOT be updated:

==============================================================================
Enclosure   Bay  Module           Current Version       Status
==============================================================================
SGH120X5AJ  1    HP VC            3.15                  Previous firmware
                 FlexFabric       2010-10-09T08:13:18Z  update was not
                 10Gb/24-Port                           completed
                 Module
------------------------------------------------------------------------------
SGH120X5AJ  2    HP VC            3.15                  Previous firmware
                 FlexFabric       2010-10-09T08:13:18Z  update was not
                 10Gb/24-Port                           completed
                 Module
------------------------------------------------------------------------------

 

The log file shows the following information:

 

[Fri Aug 19 20:37:06 2011] (8668)[VcsuCore.cpp:2448] : Checking state of any incompleted firmware updates.
[Fri Aug 19 20:37:06 2011] (8668)[VcsuCore.cpp:2465] :
Previous firmware update process on the module in bay 1 did not complete
[Fri Aug 19 20:37:06 2011] (8668)[VcsuCore.cpp:2466] : The module should be reset to activate the firmware.
[Fri Aug 19 20:37:06 2011] (8668)[VcsuCore.cpp:2590] : Incomplete firmware update operation on module : enc_serial- SGH120X5AJ, bay- 1
[Fri Aug 19 20:37:06 2011] (8668)[VcsuCore.cpp:1955] : Primary VCM found in enclosure SGH120X5AJ, bay 1
[Fri Aug 19 20:37:13 2011] (8668)[OaWrap.cpp:783] : User successfully deleted

 

I already reset the Virtual Connect Manager as part of the "checkpoint error" fix, how do I reset the module? 

 

Do I need to download and reinstall 3.15 with the -f option?

 

Thanks

Adam

Advisor
Jonathan Schroeber
Posts: 18
Registered: ‎01-04-2011
Message 2 of 3 (2,135 Views)

Re: VCSU - Previous firmware update was not completed

It looks like you have a pending firmware update that still needs to be committed on those devices.  "Rebooting" the Virtual Connect Modules themselves should remove them from this state.

 

Easiest way to do it is from the Onboard Administrator of the chassis where the VC Module resides.  Go to Interconnect Bays -> VC Module you want to reboot -> Virtual Buttons Tab.  From there, you should be able to power off the VC Module, then power it back on.  Conversely, if you're nearby, you can physically pull the VC Module from the chassis and plug it back in.  That should do the trick as well...

 

Of course, since you're rebooting the modules, you will force a VC Failover, so be aware that you could potentially affect network traffic out of the chassis.  Good luck!

 

Advisor
Adam X. White
Posts: 19
Registered: ‎04-18-2010
Message 3 of 3 (2,128 Views)

Re: VCSU - Previous firmware update was not completed

Hi Jonathan

 

That fixed it. After performing the reboot both modules showed 3.18 without additional intervention required. I had already done the "Virtual Connect Manager reset" through the VCM web interface but obviously that wasn't sufficient and a full power cycle was required.

 

Thanks

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.