Virtual Connect Assigned MAC Addresses not being applied to bl620c G7 (1507 Views)
Reply
Advisor
JD-WFH
Posts: 23
Registered: ‎05-29-2009
Message 1 of 11 (1,507 Views)
Accepted Solution

Virtual Connect Assigned MAC Addresses not being applied to bl620c G7

I have my c7000's set to use VC Assigned MAC addresses for all of my NICs. On C and D of each LOM, a different, non-VC assigned address is being applied to my VMware 4.1 servers. I have seen the advisory regarding upgrading to iLO 3 FW 1.20, and am already at that level.

 

Here is what I have done.

I've reset iLO.

I've reseated the blades.

I've pulled the OA's, and the OA sleeve.

I've even called HP, with no success.

 

What I cannot figure out is if this is a Virtual Connect (v3.18) issue, or a VMWare (ESX 4.1) problem. Thankfully, this is in my test lab, so I can make changes whenever I see fit.

 

Respected Contributor
Psychonaut
Posts: 214
Registered: ‎08-31-2011
Message 2 of 11 (1,500 Views)

Re: Virtual Connect Assigned MAC Addresses not being applied to bl620c G7

What are you seeing in the server profile?  Does that MAC match what you see in ESX or is it different?

Advisor
JD-WFH
Posts: 23
Registered: ‎05-29-2009
Message 3 of 11 (1,495 Views)

Re: Virtual Connect Assigned MAC Addresses not being applied to bl620c G7

Within VCM the server profile shows them as HP Assigned ranges, but the OA and O/S see them, and only the C and D Flexnics as what I can only assume to be factory assigned MACs.

 

As I have stated, this very well may be an ESX issue or a VC issue.

Respected Contributor
Psychonaut
Posts: 214
Registered: ‎08-31-2011
Message 4 of 11 (1,493 Views)

Re: Virtual Connect Assigned MAC Addresses not being applied to bl620c G7

Doesn't the server profile show the actual MAC addresses? I'm at v3.30 and that's how I see it. Have you thought about updating the server firmware?
Trusted Contributor
Hongjun Ma
Posts: 215
Registered: ‎02-07-2011
Message 5 of 11 (1,491 Views)

Re: Virtual Connect Assigned MAC Addresses not being applied to bl620c G7

it's better to see what you descrbied.

 

Can you ssh into VC and collect

 

show version

show domain

show profile <profile name>

 

also, please collect vmnic address from ESX/ESXi.

My VC blog: http://hongjunma.wordpress.com



Advisor
JD-WFH
Posts: 23
Registered: ‎05-29-2009
Message 6 of 11 (1,487 Views)

Re: Virtual Connect Assigned MAC Addresses not being applied to bl620c G7

VCM info

 

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2012.02.06 14:58:51 =~=~=~=~=~=~=~=~=~=~=~=
login as: Administrator
Using keyboard-interactive authentication.
Password:
-------------------------------------------------------------------------------
HP Virtual Connect Management CLI v3.18
Build: 3.18-3 (r46087) Apr  1 2011 17:45:49
(C) Copyright 2006-2011 Hewlett-Packard Development Company, L.P.
All Rights Reserved
-------------------------------------------------------------------------------


GETTING STARTED:

help           : displays a list of available subcommands
exit           : quits the command shell
<subcommand> ? : displays a list of managed elements for a subcommand
<subcommand> <managed element> ? : displays detailed help for a command

->show versionHP Virtual Connect Management CLI v3.18
Build: 3.18-3 (r46087) Apr  1 2011 17:45:49
(C) Copyright 2006-2011 Hewlett-Packard Development Company, L.P.
All Rights Reserved

->show domain
Domain Name       : gle-lab-05vcm
Checkpoint Status : Valid

-------------------------------------------------------------------------------
Virtual Connect Domain IP Address Settings
-------------------------------------------------------------------------------
Domain IP Status : Enabled
IP Address       : 10.8.19.212
Subnet Mask      : 255.255.255.0
Gateway          : 10.8.19.1

-------------------------------------------------------------------------------
Ethernet MAC Address Settings
-------------------------------------------------------------------------------
MAC Address Type : VC-Defined
Pool ID          : 16
Address Start    : 00-17-A4-77-3C-00
Address End      : 00-17-A4-77-3F-FF

-------------------------------------------------------------------------------
Fibre Channel WWN Address Settings
-------------------------------------------------------------------------------
WWN Address Type : VC-Defined
Pool ID          : 16
Address Start    : 50:06:0B:00:00:C2:9E:00
Address End      : 50:06:0B:00:00:C2:A1:FF

 


->show profile VSTEST02Name          : VSTEST02
Device Bay    : enc0:8
Server        : ProLiant BL620c G7
Status        : OK
Serial Number : USE123B0AX     
UUID          : -- --

Ethernet Network Connections
=======================================================================
Port  Network Name     Status  PXE      MAC Address        Allocated  
                                                           Speed      
=======================================================================
1     10.6_IC1         OK      UseBIOS  00-17-A4-77-3C-54  500Mb      
-----------------------------------------------------------------------
2     10.6_IC2         OK      UseBIOS  00-17-A4-77-3C-56  500Mb      
-----------------------------------------------------------------------
3     Multiple         OK      UseBIOS  00-17-A4-77-3C-78  6Gb        
      Network                                                         
-----------------------------------------------------------------------
4     Multiple         OK      UseBIOS  00-17-A4-77-3C-7A  6Gb        
      Network                                                         
-----------------------------------------------------------------------
5     10.27.5_IC1      OK      UseBIOS  00-17-A4-77-3C-7C  2.5Gb      
-----------------------------------------------------------------------
6     10.27.5_IC2      OK      UseBIOS  00-17-A4-77-3C-7E  2.5Gb      
-----------------------------------------------------------------------
7     <Unassigned>     OK      UseBIOS  00-17-A4-77-3C-80  -- --      
-----------------------------------------------------------------------
8     <Unassigned>     OK      UseBIOS  00-17-A4-77-3C-82  -- --      
-----------------------------------------------------------------------

FC SAN Connections
=================================================================
Port  Bay  FC SAN Name   Status  Speed  WWPN                    
=================================================================
1     3    SAN3          OK      Auto   50:06:0B:00:00:C2:9E:58 
2     4    <Unassigned>  OK      Auto   50:06:0B:00:00:C2:9E:5A 
3     5    <Unassigned>  OK      Auto   50:06:0B:00:00:C2:9E:5C 
4     6    SAN6          OK      Auto   50:06:0B:00:00:C2:9E:5E 

 

From ESX CLI

~ #
~ # esxcfg-nics -l
Name    PCI           Driver      Link Speed     Duplex MAC Address       MTU    Description                  
vmnic0  0000:04:00.00 be2net      Up   500Mbps   Full   00:17:a4:77:3c:54 1500   ServerEngines Corporation NC553i 10Gb 2-port FlexFabric Converged Network Adapter
vmnic1  0000:04:00.01 be2net      Up   500Mbps   Full   00:17:a4:77:3c:56 1500   ServerEngines Corporation NC553i 10Gb 2-port FlexFabric Converged Network Adapter
vmnic10 0000:05:00.02 be2net      Down 0Mbps     Half   00:17:a4:77:3c:80 1500   ServerEngines Corporation NC553i 10Gb 2-port FlexFabric Converged Network Adapter
vmnic11 0000:05:00.03 be2net      Down 0Mbps     Half   00:17:a4:77:3c:82 1500   ServerEngines Corporation NC553i 10Gb 2-port FlexFabric Converged Network Adapter
vmnic12 0000:05:00.04 be2net      Down 0Mbps     Half   b4:99:ba:a8:bb:4c 1500   ServerEngines Corporation NC553i 10Gb 2-port FlexFabric Converged Network Adapter
vmnic13 0000:05:00.05 be2net      Down 0Mbps     Half   b4:99:ba:a8:bb:50 1500   ServerEngines Corporation NC553i 10Gb 2-port FlexFabric Converged Network Adapter
vmnic14 0000:05:00.06 be2net      Down 0Mbps     Half   b4:99:ba:a8:bb:4d 1500   ServerEngines Corporation NC553i 10Gb 2-port FlexFabric Converged Network Adapter
vmnic15 0000:05:00.07 be2net      Down 0Mbps     Half   b4:99:ba:a8:bb:51 1500   ServerEngines Corporation NC553i 10Gb 2-port FlexFabric Converged Network Adapter
vmnic2  0000:04:00.02 be2net      Up   2500Mbps  Full   00:17:a4:77:3c:7c 1500   ServerEngines Corporation NC553i 10Gb 2-port FlexFabric Converged Network Adapter
vmnic3  0000:04:00.03 be2net      Up   2500Mbps  Full   00:17:a4:77:3c:7e 1500   ServerEngines Corporation NC553i 10Gb 2-port FlexFabric Converged Network Adapter
vmnic4  0000:04:00.04 be2net      Down 0Mbps     Half   b4:99:ba:a8:bb:44 1500   ServerEngines Corporation NC553i 10Gb 2-port FlexFabric Converged Network Adapter
vmnic5  0000:04:00.05 be2net      Down 0Mbps     Half   b4:99:ba:a8:bb:48 1500   ServerEngines Corporation NC553i 10Gb 2-port FlexFabric Converged Network Adapter
vmnic6  0000:04:00.06 be2net      Down 0Mbps     Half   b4:99:ba:a8:bb:45 1500   ServerEngines Corporation NC553i 10Gb 2-port FlexFabric Converged Network Adapter
vmnic7  0000:04:00.07 be2net      Down 0Mbps     Half   b4:99:ba:a8:bb:49 1500   ServerEngines Corporation NC553i 10Gb 2-port FlexFabric Converged Network Adapter
vmnic8  0000:05:00.00 be2net      Up   6000Mbps  Full   00:17:a4:77:3c:78 1500   ServerEngines Corporation NC553i 10Gb 2-port FlexFabric Converged Network Adapter
vmnic9  0000:05:00.01 be2net      Up   6000Mbps  Full   00:17:a4:77:3c:7a 1500   ServerEngines Corporation NC553i 10Gb 2-port FlexFabric Converged Network Adapter
~ #

Advisor
JD-WFH
Posts: 23
Registered: ‎05-29-2009
Message 7 of 11 (1,484 Views)

Re: Virtual Connect Assigned MAC Addresses not being applied to bl620c G7

[ Edited ]

The server profile shows the MACs, and they're different from what I see on the OA and ESX. I've considered it, but will only do so if necessary. I just got all my firmware identical across 27 c7000's.

Trusted Contributor
Hongjun Ma
Posts: 215
Registered: ‎02-07-2011
Message 8 of 11 (1,478 Views)

Re: Virtual Connect Assigned MAC Addresses not being applied to bl620c G7

I can see your vmnic has the VC_Assigned MACs.

 

your profile only has 8 ports created, if you want the rest of vmnics showing VC_Assigned MACs, you can right click at profile ports section to create 8 more ports on VCM so your other vmnics can have VC_Assigned MACs.

 

vc_assigned_MAC.png

My VC blog: http://hongjunma.wordpress.com



Advisor
JD-WFH
Posts: 23
Registered: ‎05-29-2009
Message 9 of 11 (1,468 Views)

Re: Virtual Connect Assigned MAC Addresses not being applied to bl620c G7

That makes sense, but the 620's behave differently than the 490's in my environment, despite the fact that the server profiles are exactly the same.

Trusted Contributor
Hongjun Ma
Posts: 215
Registered: ‎02-07-2011
Message 10 of 11 (1,464 Views)

Re: Virtual Connect Assigned MAC Addresses not being applied to bl620c G7

Is it BL490G7? what do you mean it's different than bl490?

 

BL620G7 is full-height blade and has 4 10G CNA ports. if you assign ports in VCM, the order will look like this

 

LOM1:1a

LOM1:2a

LOM2:1a

LOM2:2a

LOM1:1b

LOM1:2b

LOM2:1b

LOM2:2b

LOM1:1c

LOM1:2c

LOM2:1c

LOM2:2c

LOM1:1d

LOM1:2d

LOM2:1d

LOM2:2d

 

BL490G7 has 2 built-in 10G CNA ports. if you assign ports in VCM, the order will look like this

LOM1:1a

LOM1:2a

LOM1:1b

LOM1:2b

LOM1:1c

LOM1:2c

LOM1:1d

LOM1:2d

 

My VC blog: http://hongjunma.wordpress.com



Advisor
JD-WFH
Posts: 23
Registered: ‎05-29-2009
Message 11 of 11 (1,461 Views)

Re: Virtual Connect Assigned MAC Addresses not being applied to bl620c G7

Okay, I see the difference now, thank you very much.

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.