Server profiles and MAC address assignment with BL460c and Windows 2012 (303 Views)
Reply
Frequent Advisor
Erick Arturo Perez
Posts: 74
Registered: ‎02-28-2008
Message 1 of 4 (303 Views)

Server profiles and MAC address assignment with BL460c and Windows 2012

[ Edited ]

Hi, I have created server profiles as shown in the attachment for the (4) BL460c blades I have on a c7000. Im using only the onboard networking module.

 

talking about the MAC address assigment I see strange things but I need clarification if this is normal.

 

Example:

If I see VC profile 1, I can see port 1 with MAC 77-10-00 port 6 with MAC 77-10-22, etc,etc and the proper LOM mappings.

 

The blades have Win2012 installed. When using windows on Bay01 blade and query the MAC address of the ports  seen by win2012, the first profile on VC matches at MAC address level except for ports 3 and 4. MAC address for port 3 is at port 4 and viceversa.

 

Things get worse at the other blades. On Bay02 blade all the ports/macs are mixed. Bay blades 03 and 04 have some ports/MACs correct.

 

My question is if this is normal behavior (it should not be) since on Bay01 all was ok except on ports 3 and 4. My concern is that we are building a cluster with hyper-v and since the OS is sensitive on some things we are implementing regarding the MAC address I just dont want to come one day to my datacenter just to find out in the last reboot the MACs changed. And It looks bad on documentation, because port assignment on the VC does not match port/mac on the blade.

 

Comments?

 

Thanks.

 

 

Frequent Advisor
Erick Arturo Perez
Posts: 74
Registered: ‎02-28-2008
Message 2 of 4 (300 Views)

Re: Server profiles and MAC address assignment with BL460c and Windows 2012

This is the blade assigment image with port mapping.

 

Respected Contributor
Psychonaut
Posts: 213
Registered: ‎08-31-2011
Message 3 of 4 (274 Views)

Re: Server profiles and MAC address assignment with BL460c and Windows 2012

I just took a look and I'm not seeing those results.  What versions of CNA, OA and VC firmware are you on?

Trusted Contributor
Casper42
Posts: 279
Registered: ‎10-07-2010
Message 4 of 4 (248 Views)

Re: Server profiles and MAC address assignment with BL460c and Windows 2012

Wheny ou say Port, are you referring to what used to be called Local Area Connection X in 2008? (Dont have experience on 2012 yet)

If so, you need to know that Windows and the PCI Device scan process often times produce very different results even on identical hardware. This happens on Linus too and we worked with Redhat to build in a new numbering method there with Gen8 using SMBIOS information to make things more consistent.



Now if the OA is not seeing that the VC Profile sees (I only saw OA screenshots), then that is really no big deal as the OA scans the information when the Blade boots and I have seen them get out of alignment before. With the OA showing the Factory MAC for some ports and VC MAC for others.
Sometimes shutting the blade down and then back up cold helps convince the OA to check again and then it gets the updated info.
But really just check the VC GUI/CLI and see what MACs it thinks are there and that should always match the OS.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.