Re: Can't upgrade to ILO2 2.12 on different servers (4343 Views)
Reply
Advisor
DGI_HP
Posts: 19
Registered: ‎06-27-2011
Message 1 of 10 (4,374 Views)

Can't upgrade to ILO2 2.12 on different servers

Hi

 

I upgraded my 5 C7000 enclosures  to OA 3.60, because I got a lot of errors on fans in the enclosures.

But I can't upgrade ILO2 to newest version.

I tried serveral servers, but one is Proliant BL465c G1 with ILO 2.07.

I have tried upgrade to 2.08, 2.09 and 2.12, but nothing is working.

It says Flash is Progress, and suddenly jumps to receiving Flash Image: 99%, and end with this screen:

 

Capture4.PNG

 

I have downgraded one enclosure to 3.56, but with the same result.

 

 

 

Advisor
DGI_HP
Posts: 19
Registered: ‎06-27-2011
Message 2 of 10 (4,343 Views)

Re: Can't upgrade to ILO2 2.12 on different servers

I didn't find any solution, but I find a way to update ILO from OA with SSH.

It was very easy, so this is the way I will update ILO from now on:)

Occasional Visitor
tim lillis
Posts: 2
Registered: ‎03-30-2007
Message 3 of 10 (4,297 Views)

Re: Can't upgrade to ILO2 2.12 on different servers

Procedure is as follow

 

SSH using your client to the OA Chassis

login

update ilo ALL ftp://user:pass@ipaddress/ilo2_212.bin

 

you can do specific bays or http and you will have to set up a source, but I love this ALL capability.

Honored Contributor
Oscar A. Perez
Posts: 644
Registered: ‎11-01-2005
Message 4 of 10 (4,288 Views)

Re: Can't upgrade to ILO2 2.12 on different servers

[ Edited ]

This is an issue with the "Content-Length" value in the HTTP header when uploading the iLO2 binary. It's started happening after MS updated Internet Explorer 8 and 9 earlier this year. It affects all the iLO2 firmware versions earlier than 2.09. 

 

There are few workarounds:  

 

Use Fixefox instead of Internet Explorer.

Use IE in "Compatibility Mode" when flashing iLO2 firmware.

Flash iLO2 firmware using an alternate method like, Online Flash from the OS or from the OA CLI.

 

In 2.09 we fixed the code to handle the content-lenght correctly so, once your iLO2s are 2.09 or later, you shouldn't have this problem anymore.

Occasional Visitor
strange
Posts: 2
Registered: ‎03-13-2013
Message 5 of 10 (3,789 Views)

Re: Can't upgrade to ILO2 2.12 on different servers

same problem!

updated 2.12 by IE

failed even do as suggestion:

   Use Fixefox instead of Internet Explorer.           

pop: there was a problem retreving the XML data

   Use IE in "Compatibility Mode" when flashing iLO2 firmware.

still ....

 

Occasional Visitor
strange
Posts: 2
Registered: ‎03-13-2013
Message 6 of 10 (3,788 Views)

Re: Can't upgrade to ILO2 2.12 on different servers

Is it caused by OA 3.6? I also just updated to 3.6 from 3.55

Neighborhood Moderator
Jeroen_Kleen
Posts: 120
Registered: ‎04-29-2003
Message 7 of 10 (3,773 Views)

Re: Can't upgrade to ILO2 2.12 on different servers

Howdy, could you give it a try via a manual SPP boot and then upgrade the iLO fw? Just to see if that is at all working?
The other option that I use a lot is via the OA CLI using the "update iLO" command. Would that maybe work?
cheers, jeroen

 

(I am an HP Employee and CI Ambassador)
http://www.hp.com/go/hpCloud
http//www.hp.com/go/CI
http://www.hp.com/go/OneView
Regular Advisor
Tom Lyczko
Posts: 196
Registered: ‎06-13-2005
Message 8 of 10 (2,512 Views)

Re: Can't upgrade to ILO2 2.12 on different servers

[ Edited ]

I have the same problem with a DL380 G5, ILO 2.23...I got it to work with FF 26.0.

Occasional Visitor
dtormin
Posts: 1
Registered: ‎05-25-2014
Message 9 of 10 (1,906 Views)

Re: Can't upgrade to ILO2 2.12 on different servers

FireFox under MAC OSX is OK!

Successfully upgrade from 1.7 to 2.25. Both IE under Windows and Safari did 99% problem.

Occasional Visitor
Adam E. Lewandowski
Posts: 2
Registered: ‎11-12-2008
Message 10 of 10 (742 Views)

Re: Can't upgrade to ILO2 2.12 on different servers

Hello,

 

HP DL 360 G5, upgrade from 2.07 to 2.25 was failing with 99% bug.  Thanks to this thread and your answer, I was able to upgrade using FF (v32.0.3 if it might matter). Please note that it didn't work at first attempt (not sure what exactly happened, but logged me out without success); 2nd attempt was fine. Also previous attempts to use various IE11 emulation (document) modes didn't succeed.

 

Thanks again and 1 up :-)

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.