Re: Standby Onboard Administrator does not respond to SNMP GET since firmware version 3.60 (516 Views)
Reply
Occasional Collector
ouzo12
Posts: 4
Registered: ‎12-05-2012
Message 1 of 7 (1,079 Views)

Standby Onboard Administrator does not respond to SNMP GET since firmware version 3.60

Hi all,

 

Since OA firmware version 3.60, the standby OA no longer responds to SNMP GET requests.

This is causing management systems to complain.

 

The standby OA would respond to SNMP GET up until version 3.56.

 

In the below, oa1 is the active and oa2 is the standby:

 

[vulture ~]$ snmpget -v 1 -c public oa1 .1.3.6.1.4.1.232.22.2.3.1.1.1.8.1
.iso.3.6.1.4.1.232.22.2.3.1.1.1.8.1 = "3.70"
[vulture ~]$ snmpget -v 1 -c public oa2 .1.3.6.1.4.1.232.22.2.3.1.1.1.8.1
Timeout: No Response from oa2.
[vulture ~]$

 

This is happening on multiple installations.

Is this on purpose? I could not find it mentioned anywhere.

 

Thanks

 

Please use plain text.
Occasional Collector
ouzo12
Posts: 4
Registered: ‎12-05-2012
Message 2 of 7 (1,060 Views)

Re: Standby Onboard Administrator does not respond to SNMP GET since firmware version 3.60

Anyone? No?

 

I guess I'll open a support case and get told "it's working as designed" ...

 

But then the change is not documented anywhere...

 

 

Please use plain text.
Occasional Visitor
blax777
Posts: 1
Registered: ‎12-12-2012
Message 3 of 7 (1,050 Views)

Re: Standby Onboard Administrator does not respond to SNMP GET since firmware version 3.60

We have got the same problem since update from 3.56 to 3.6

 

got any solution from HP?

Please use plain text.
Advisor
Francisco Mata_1
Posts: 24
Registered: ‎09-08-2005
Message 4 of 7 (965 Views)

Re: Standby Onboard Administrator does not respond to SNMP GET since firmware version 3.60

It still happens with version 3.70.

 

Do anybody solved it in any way?

Please use plain text.
Advisor
Francisco Mata_1
Posts: 24
Registered: ‎09-08-2005
Message 5 of 7 (935 Views)

Re: Standby Onboard Administrator does not respond to SNMP GET since firmware version 3.60

HP is working on the solution as it is showed on this advisory:

 

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c03659073&jumpid=em_alerts_us...

 

SUPPORT COMMUNICATION - CUSTOMER ADVISORY

Document ID: c03659073

Version: 1

Advisory: HP c-Class BladeSystem -Standby Onboard Administrator (OA) Modules May Not Respond to SNMP Data Requests
NOTICE: The information in this document, including products and software versions, is current as of the Release Date. This document is subject to change without notice.

Release Date: 2013-02-01

Last Updated: 2013-01-31


DESCRIPTION

An HP Onboard Administrator (OA) module running in standby mode and configured with OA Firmware Version 3.60 (or later) will not respond to SNMP data requests. SNMP requests that are targeted at a Standby module will not be processed and may result in a timeout on the target initiating the request, but does not result in any functional issue on the OA module itself.

SCOPE

Any HP BladeSystem c3000 or c7000 Enclosure with Onboard Administrator modules configured with OA Firmware Version 3.60 (or later).

RESOLUTION

The SNMP values returned are common across the enclosure and do not differ between the Active and Standby OA modules. SNMP data for the enclosure will continue to be returned by the Active OA module.

A Standby module that transitions to an Active state will return enclosure SNMP data once it completes the transition.

A future release of Onboard Administrator firmware will allow for SNMP data requests to be fulfilled by an Onboard Administrator running in either Active or Standby mode.

This advisory will be updated when additional information becomes available

Please use plain text.
Occasional Collector
ouzo12
Posts: 4
Registered: ‎12-05-2012
Message 6 of 7 (794 Views)

Re: Standby Onboard Administrator does not respond to SNMP GET since firmware version 3.60

Still not fixed in 3.71
Please use plain text.
Occasional Collector
ouzo12
Posts: 4
Registered: ‎12-05-2012
Message 7 of 7 (516 Views)

Re: Standby Onboard Administrator does not respond to SNMP GET since firmware version 3.60

Finally. Fixed in version 4.01 (and hopefully beyond).

 

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation