OA Enc. Firmware Mgmt. bug - can't handle different disk model FW version reporting? (256 Views)
Reply
Occasional Contributor
Posts: 3
Registered: ‎03-05-2014
Message 1 of 1 (256 Views)

OA Enc. Firmware Mgmt. bug - can't handle different disk model FW version reporting?

[ Edited ]

I believe I've found a bug with how the OA displays and reconciles hard drive firmware versions when matched against an SPP baseline.

 

I have an enclosure with OAs on the latest, very recently released FW 4.11.  I am using Enclosure Firmware Management, pointed to the latest 2014.02.0 SPP.  I have manually scanned and updated the firmware of several Gen8 servers in this enclosure.  What I am seeing is that the OA report for "Rack Firmware" is flagging the firmware of a server's hard drives as not up to date when in fact they are.

 

 

 

 

As you can see, my server has two different HD models which have two different corresponding FW versions.  SUM feels they are both current as of the latest SPP.  However, you will also see that the OA firmware report seems to be getting confused between the two as it is tagging the firmware as not current. 

 

I believe the OA logic can't distinguish between two different models with two different FW revisions and be able to look at them independently for comparison against the SPP versions.

 

PS - It's hard to make out in the picture from the OA report but the relevant line says:

 

"HP EG0300FBDSP (Bay 2)             HPD6            HPD9"

 

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.