ifalias error on HP-UX B.10.20 (145 Views)
Reply
Occasional Visitor
Posts: 2
Registered: ‎02-12-2011
Message 1 of 3 (145 Views)

ifalias error on HP-UX B.10.20

[ Edited ]

hi, i met below problem when i try to configure a virtual interface on HP-UX B.10.20. patch PHNE_12492 is installed.

when i add a IP which is from different subnet with lan0 IP, it indicates "Can't assign requested address". but when i add another IP that is from a same subnet with lan0 IP, it passed and i can ping/telnet the server with new added IP.

in this website: hthttp://h30499.www3.hp.com/t5/Networking/ifalias-error-on-HP-UX-10-20/m-p/4210601#M42792, melvyn burnard said that PHNE_12492 allowed for adding of ip addresses onto a differfent subnet. how can i successfully add a ip address that is from different subnet? thank you very much!

***@*** # ifalias lan0 add x.x.32.x
ifalias: ioctl (SIOCADDIFADDR): Can't assign requested address
ifalias: Can't add 202.x.33.x
***@*** # ifalias lan0 add x.x.33.x
***@*** # (it passed)

HP Pro
Posts: 6,068
Registered: ‎04-06-1997
Message 2 of 3 (145 Views)

Re: ifalias error on HP-UX B.10.20

If you read my response, you need to include the new subnet:
ifalias lan0 addmask 255.a.b.c 204.x.x.2
man ifalias
My house is the bank's, my money the wife's, But my opinions belong to me, not HP!
Occasional Visitor
Posts: 2
Registered: ‎02-12-2011
Message 3 of 3 (145 Views)

Re: ifalias error on HP-UX B.10.20

sorry for my careless, i didn't notice that......thank you very much.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.