Re: cstm san disks info no working after upgrade to hpux 11.31 release B.11.31.1009 (246 Views)
Reply
Honored Contributor
likid0
Posts: 981
Registered: ‎03-01-2005
Message 1 of 3 (287 Views)

cstm san disks info no working after upgrade to hpux 11.31 release B.11.31.1009

Hi,

 

After upgrading to 11.31 1009 release, cstm is not displaying info on the san disks, the HBA's are displayed, but no disks under them:

 

   4  1/0/12/1/0/4/0       Unknown ()                                        
   25  1/0/12/1/0/4/0.1     FCP Domain (Mass_Storage)                         
                  
   29  1/0/14/1/0/4/0       Unknown ()                                        
   30  1/0/14/1/0/4/0.1     FCP Domain (Mass_Storage)

 

      # swlist -l bundle | grep -i onli
  OnlineDiag            B.11.31.11.01  HPUX 11.31 Support Tools Bundle, Sept 2010

 

With the previous release it works fine:

 

23  0/0/12/1/0/4/0       Unknown ()                                        
   24  0/0/12/1/0/4/0.1     FCP Domain (Mass_Storage)                         
   25  0/0/12/***.7.0.0.0.1 SCSI Disk (IBM2810XIV)    Information Successful  
   26  0/0/12/***.255.0.0.0 SCSI Device (IBM2810XIV-L                         
   27  0/0/12/***47.0.0.0.1 SCSI Disk (IBM2810XIV)    Information Successful  
   28  0/0/12/***.255.0.0.0 SCSI Device (IBM2810XIV-L                         

 

# swlist -l bundle | grep -i oe
  HPUX11i-BOE           B.11.31.0803   HP-UX Base Operating Environment
# swlist -l bundle | grep -i online
  OnlineDiag            B.11.31.03.06  HPUX 11.31 Support Tools Bundle, March 2008

 

I have several scripts,etc. That get the disk information/serial/etc, using cstm, so I would like to be able to keep using cstm.

 

I know stm is being removed, and cprop is kind of the replacement, but cprop doesn't give info on the SAN luns, only on the normal scsi disks.

 

Any idea, how to get stm to display lun info again on the new version?.

 

Windows?, no thanks
Acclaimed Contributor
Torsten.
Posts: 23,450
Registered: ‎10-02-2001
Message 2 of 3 (282 Views)

Re: cstm san disks info no working after upgrade to hpux 11.31 release B.11.31.1009

[ Edited ]

Depending on your hardware you need to use "cprop" now.

see also

https://h20392.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=DiagProdCollection

 

will point you to

 

https://h20392.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=WBEMMgmtBundle


Hope this helps!
Regards
Torsten.

__________________________________________________

There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________

No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Honored Contributor
Robert_Jewell
Posts: 1,239
Registered: ‎06-26-2001
Message 3 of 3 (246 Views)

Re: cstm san disks info no working after upgrade to hpux 11.31 release B.11.31.1009

>>  but cprop doesn't give info on the SAN luns

 

This is what 'scsimgr' can be used for.

 

 

-Bob

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.