Re: NFS not working (651 Views)
Reply
Super Advisor
rajesh73
Posts: 448
Registered: ‎03-17-2009
Message 1 of 14 (654 Views)
Accepted Solution

NFS not working

NFS not working,i am try to run this command in source server

source server os version :hp-ux 11.23
Destination server os version :hp-ux 11.31

command :shareall -F nfs

Error:
share: Running old NFS library, requires new NFS library
share: Running old NFS library, requires new NFS library


kindly help me how to solve the problem

Acclaimed Contributor
Dennis Handly
Posts: 25,054
Registered: ‎03-06-2006
Message 2 of 14 (654 Views)

Re: NFS not working

Hmm, I thought that shareall(1m) is only available on 11.31, the destination server.

You should use: exportfs -a
Honored Contributor
P Muralidhar Kini
Posts: 897
Registered: ‎03-14-2010
Message 3 of 14 (654 Views)

Re: NFS not working

Valued Contributor
Vijaykumar_1
Posts: 118
Registered: ‎08-10-2009
Message 4 of 14 (654 Views)

Re: NFS not working

On HP-UX servers running 11i v1 and 11i v2, you need to use exportfs command. exportfs shares the filesystems that are updated in /etc/exports.

Where as on HP-UX 11i v3 you need to use shareall command to share the filesystems.The filesystems are updated in the file /etc/dfs/dfstab.

Hope this helps..
Super Advisor
rajesh73
Posts: 448
Registered: ‎03-17-2009
Message 5 of 14 (654 Views)

Re: NFS not working

still same problem in source server.

source server output
# nfsstat -m
# swlist |grep ONC
#

destination server output
#nfsstat -m
#swlist -l bundle |grep ONC
NCplus B.11.31.06.01 ONC+ 2.3
#

kindly advice their is any patch installation need for source server
Acclaimed Contributor
Dennis Handly
Posts: 25,054
Registered: ‎03-06-2006
Message 6 of 14 (654 Views)

Re: NFS not working

>still same problem in source server.

What problem? Are you using?: exportfs -a
Super Advisor
rajesh73
Posts: 448
Registered: ‎03-17-2009
Message 7 of 14 (654 Views)

Re: NFS not working

Hi kindly find the snap shot.


# shareall -F nfs
share: Running old NFS library, requires new NFS library
share: Running old NFS library, requires new NFS library
# exportfs -a
# shareall -F nfs
share: Running old NFS library, requires new NFS library
share: Running old NFS library, requires new NFS library
Super Advisor
rajesh73
Posts: 448
Registered: ‎03-17-2009
Message 8 of 14 (654 Views)

Re: NFS not working

please help .this is urgent
Outstanding Contributor
Pete Randall
Posts: 16,205
Registered: ‎11-03-1996
Message 9 of 14 (654 Views)

Re: NFS not working

What Dennis has patiently been trying to tell you is that the shareall command is not available in 11.23. Actually the command is there but the support for it is not. That is what your error message is telling you: you need the newer version of NFS which is provided with 11.31 in order to use the shareall command.

When you ran "exportfs -a" you accomplished the same thing as you would if your shareall command was enabled on 11.23: your NFS shares should be available now.


Pete

Pete
Acclaimed Contributor
Dennis Handly
Posts: 25,054
Registered: ‎03-06-2006
Message 10 of 14 (654 Views)

Re: NFS not working

>Pete: When you ran "exportfs -a" you accomplished the same thing

Right. You can check this by looking at /etc/xtab.

Trusted Contributor
singh sanjeev
Posts: 217
Registered: ‎11-07-2007
Message 11 of 14 (651 Views)

Re: NFS not working

check on the client that your NFS file system being exported or not:
on client
#showmount -e

Sanjeev Singh
Regular Advisor
Mike Miller_8
Posts: 89
Registered: ‎02-24-2003
Message 12 of 14 (651 Views)

Re: NFS not working

Dumb question but do you have NFS enabled ?
Honored Contributor
P Muralidhar Kini
Posts: 897
Registered: ‎03-14-2010
Message 13 of 14 (651 Views)

Re: NFS not working

Hi Rajesh,

Is the problem resolved ?

Can this also be a permission issue.
Looks like problem similar to
http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1436470

Regards,
Murali
Let There Be Rock - AC/DC
Regular Advisor
Deeos
Posts: 133
Registered: ‎10-15-2009
Message 14 of 14 (651 Views)

Re: NFS not working

Hi rajesh,

do following step:

#exportfs -aF nfs
#more /etc/xtab
file whether entries are availalbe for which mount points are being exported.

you can also put showmount -e command to check your exported mount point

#/sbin/init.d/nfs.server stop
#/sbin/init.d/nfs.server start



on the client side...........


check showmount -a commoand to view available nfs mount points in your client server.

#bdf
to check all mount points

if you are still facing problem, then let me know!


Regards
Deeos


Deepak
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.