Re: FTP Problem (137 Views)
Reply
Advisor
vijay alur
Posts: 20
Registered: ‎05-03-2008
Message 1 of 11 (137 Views)

FTP Problem

hii allllll, i have 2 servers. one rx2660 and one rx6600. i have installed hp-ux11iv2 on both of the server.
i am able to ftp from and to the rx2660 server. but when i try to ftp from rx6600, i get the message incorrect login.
i have checked the /etc/services, and the ftp services is enable. i also checked the thru
SAM --> network and communication --> network services and the ftp services is running.

later once i tried to ftp, i gave the username and in the password field i didnt gave any password and that allowed me to login to the ftp and allowed me to get and put files......

does anyone have any idea what may be the problem??????????
why does this happen???????????????????????

waiting for some reply.
Acclaimed Contributor
Dennis Handly
Posts: 25,054
Registered: ‎03-06-2006
Message 2 of 11 (137 Views)

Re: FTP Problem

What's different about the two machines?
What is the user? What is the user's shell?
Is the shell in /etc/shells?
Advisor
vijay alur
Posts: 20
Registered: ‎05-03-2008
Message 3 of 11 (137 Views)

Re: FTP Problem

nothing diffferent between both the servers, except that both are of different models.

the user is root and the shell is /usr/bin/sh

have'nt checked in the /etc/shell file for the entry of the shell.......
Advisor
vijay alur
Posts: 20
Registered: ‎05-03-2008
Message 4 of 11 (137 Views)

Re: FTP Problem

but later i changed the root password and gave a reboot to the server and everything was working fine later. ws able to get and put file from and to the server. so the problem got resolved, but couldnt trace what exactly the problem was......
Acclaimed Contributor
Torsten.
Posts: 23,266
Registered: ‎10-02-2001
Message 5 of 11 (137 Views)

Re: FTP Problem

"... get the message incorrect login ..."

"... later i changed the root password ..."

So I guess something was wrong with the first password.

Hope this helps!
Regards
Torsten.

__________________________________________________

There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________

No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Acclaimed Contributor
Dennis Handly
Posts: 25,054
Registered: ‎03-06-2006
Message 6 of 11 (137 Views)

Re: FTP Problem

>the user is root and the shell is /usr/bin/sh

This is NOT a valid shell for root. It must be /sbin/sh. (I doubt this is the ftp issue.)
I assume root has the same password entry for the two machines?
Respected Contributor
OFC_EDM
Posts: 740
Registered: ‎07-13-2004
Message 7 of 11 (137 Views)

Re: FTP Problem

Let me know if I summarize this correctly

On your first (failed) attempt from the rx6600 you were using root and entering a password.

On the next (successful) attempts you were using root without a password.

I'm assumping the issue is that you're logged into the rx6600 as root.

Then you run ftp and open a connection to the rx2660. Is that correct?

If it is then when you login (telnet/ssh/console) to the rx2660 as root do you enter a password? Or is it blank?

If blank then looks like you have to create a password on the rx2660 for root.

If you do have a password assigned for root on the rx2660 already then it'll be a different issue.

But from the wording of your post I'm wondering what the status of your passwords are for root...before going onto ftp setup issues.

Cheers
The Devil is in the detail.
Advisor
vijay alur
Posts: 20
Registered: ‎05-03-2008
Message 8 of 11 (137 Views)

Re: FTP Problem

little detailed description.

1)i have no probs loggin into the server rx2660 thru telnet as well as SSH with username and password.

2)
a) but when i loggin to the rx6600 i am able to login with SSH with username and password,
b) but when i try to loggin to the rx6600 with telnet using username and password, i am not able to login it gives incorrect password.

c) and if i loggin to rx6600 with telnet and username and no password i m able to login successfully.

3) i am facing the same problem (2b) and (2c) when i try ftp from rx2660 to rx6600. i.e. able to login with username and no password
and incorrect login if giving username as well as password. even if i giv the correct passowrd...


i kno it is complicated. it is clear after you read it 2-3 times...


bottom line is m facing prob with ftp and telnet only not with SSH.

also the above prob got resolved after i changed the password and a reboot. dun kno if this caused the prob to b resolved.
Respected Contributor
OFC_EDM
Posts: 740
Registered: ‎07-13-2004
Message 9 of 11 (137 Views)

Re: FTP Problem

Quick question

Do you have the option of turning off telnet and ftp altogether? We turn them off for security reasons and have moved over to SSH based methods completely.

Still trying to figure out a solution to your issue.

This is a shot in the dark....You wouldn't have 2 different versions of ftp on the server would you? Competing on the same ports....?

Cheers

The Devil is in the detail.
Advisor
vijay alur
Posts: 20
Registered: ‎05-03-2008
Message 10 of 11 (137 Views)

Re: FTP Problem

we cant turn off the ftp and telnet, we need telnet and ftp.
i checked the /etc/services file, the port used by the ftp services is not used by ny other services........

anyways kevin thanks for your effort......
Frequent Advisor
Dino_4
Posts: 49
Registered: ‎02-06-2002
Message 11 of 11 (137 Views)

Re: FTP Problem


Hi,

on both server execute this command and post the output:

grep passwd /etc/nsswitch.conf | awk '{ print $2 }'
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.