Re: DS20E KZPAC and TRU64 4.0F install and boot problem (790 Views)
Reply
Occasional Advisor
peynet
Posts: 9
Registered: ‎09-08-2009
Message 1 of 11 (793 Views)

DS20E KZPAC and TRU64 4.0F install and boot problem

Hello,

My Config is :

DS20E with last firmware update 7.3 passed
KZPAC with firmware 2.7 passed
Disk drive Compaq 18,2 G Ultra2 SCSI
Also tested with
Disk drive Compaq 36 G Ultra320 SCSI

Only one disk configure DRA0 18 Go (JBOD

On my DS20E when booting to install from CD ROM after a while I got the message :


...
Initializing xcr0, please wait…
Xcr0 at pci1 slot 9
Xcr_logger : XCR_ERROR packet
Xcr_logger : cntrl 0 unit 0
Re_getdrive
Cmd should always return good status
Hard error detected
Active XCR_COM at time of error
Xcr_logger : XRC_ERROR packet
Xcr_logger : cntrl 0 unit 0
Re_getdrive
Cmd memory lost
Possible software problem – impossible Cond detected
Active XCR_COM at time of error

The Installation continue I can select the drive re0 and install the system
but on the next reboot I have


bootdevice_parser : unknown protocol name 'RAID'
setconf : Bootdevice_parser failed to translate bootdevice RAID 1 9 0 0 0 0 0
Panic (CPU0) setconf:Bootdevice_parser failed

If someone have an idea
Thanks

Eric
Honored Contributor
Honored Contributor
cnb
Posts: 1,197
Registered: ‎09-18-2008
Message 2 of 11 (793 Views)

Re: DS20E KZPAC and TRU64 4.0F install and boot problem

[ Edited ]
Honored Contributor
Honored Contributor
cnb
Posts: 1,197
Registered: ‎09-18-2008
Message 3 of 11 (793 Views)

Re: DS20E KZPAC and TRU64 4.0F install and boot problem

Occasional Advisor
peynet
Posts: 9
Registered: ‎09-08-2009
Message 4 of 11 (793 Views)

Re: DS20E KZPAC and TRU64 4.0F install and boot problem

Thanks,

I have split my disk to 2x18 Go logical drives of course

I have also read the release notes before posting this thread

I have had configure (in the past) a KZPAC with same drives and it works !!
But I Do not remember if the server was a DS20E

Eric

Honored Contributor
Rob Leadbeater
Posts: 3,582
Registered: ‎08-14-2002
Message 5 of 11 (793 Views)

Re: DS20E KZPAC and TRU64 4.0F install and boot problem

Hi Eric,

I seem to recall a KZPAC that was also returning XCR_ERROR messages and impossible Cond detected.

This turned out to be a faulty card.

If your problems persist, replace the KZPAC.

Regards,

Rob
Occasional Advisor
peynet
Posts: 9
Registered: ‎09-08-2009
Message 6 of 11 (793 Views)

Re: DS20E KZPAC and TRU64 4.0F install and boot problem

Rob,
I already tried with 4 cards 3 chanels and 1 card sigle chanel
The problem is the same

Eric
Occasional Visitor
marlene lam
Posts: 3
Registered: ‎04-20-2010
Message 7 of 11 (793 Views)

Re: DS20E KZPAC and TRU64 4.0F install and boot problem

when you tried a new KZPAC card , was it also installed in the same slot ?
In the original post I see slot 9, and that follows the rules:
http://h18002.www1.hp.com/alphaserver/options/asds20e/asds20e_All_options_sorted.html#OptListHead

http://h18002.www1.hp.com/alphaserver/options/asds20e/asds20e___-kzpac-ca.html


Restricted to PCI slots in HOSE 1.

Tapes and CD-ROMs not supported.

Internal drives not supported in the 4 slot disk storage backplane.


Lastly, you can try split the RAID disks into 2 JBODS and try each one at a time

- regards,
Marlene
Occasional Advisor
peynet
Posts: 9
Registered: ‎09-08-2009
Message 8 of 11 (793 Views)

Re: DS20E KZPAC and TRU64 4.0F install and boot problem

I have tried this KZPAC on a DS10 the problem is the same
The only way I can make this card working (both on DS10 or DS20E) is :
Create a drive dra0
Create a drive dra1
Install OpenVMS on dra0
Install TRU64 4.0F on dra1
Then TRU64 40F boot !!!!!!
When I reinit the card recreate drive and reinstall only TRU64 4.0F it doesn't work

So strange isn't it

Eric
Honored Contributor
Rob Leadbeater
Posts: 3,582
Registered: ‎08-14-2002
Message 9 of 11 (793 Views)

Re: DS20E KZPAC and TRU64 4.0F install and boot problem

Hi,

Looking again at the original error message referring to setconf and bootdevice_parser, it would appear that the system is having difficulty setting the various boot environment variables during the installation.

Can you post the output of "show boot*" and "show config"

Cheers,
Rob
Occasional Advisor
peynet
Posts: 9
Registered: ‎09-08-2009
Message 10 of 11 (793 Views)

Re: DS20E KZPAC and TRU64 4.0F install and boot problem

Rob

here is sh boot*

boot_dev dra0.0.0.9.1
boot_file
boot_osflags A
boot_reset OFF
bootbios
bootdef_dev dra0.0.0.9.1
booted_dev dra0.0.0.9.1
booted_file genvmunix
booted_osflags A

and the sho conf

Eric

COMPAQ AlphaServer DS20E 833 MHz

SRM Console: V7.3-1
PALcode: OpenVMS PALcode V1.98-79, Tru64 UNIX PALcode V1.92-74

Processors
CPU 0 Alpha EV68A pass 2.2 833 MHz SROM Revision: V1.17.44
Bcache size: 8 MB

Core Logic
Cchip DECchip 21272-CA Rev 2.1
Dchip DECchip 21272-DA Rev 2.0
Pchip 0 DECchip 21272-EA Rev 2.2
Pchip 1 DECchip 21272-EA Rev 2.2

TIG Rev 4.22
Arbiter Rev 2.16 (0x1)

MEMORY

Array # Size Base Addr
------- ---------- ---------
0 1024 MB 000000000
2 1024 MB 040000000

Total Bad Pages = 0
Total Good Memory = 2048 MBytes


PCI Hose 00
Bus 00 Slot 05/0: Cypress 82C693
Bridge to Bus 1, ISA
Bus 00 Slot 05/1: Cypress 82C693 IDE
dqa.0.0.105.0
dqa0.0.0.105.0 CD-224E
Bus 00 Slot 05/2: Cypress 82C693 IDE
dqb.0.1.205.0
Bus 00 Slot 05/3: Cypress 82C693 USB
usba0.0.0.305.0
Bus 00 Slot 06/0: Adaptec AIC-7895
pkb0.7.0.6.0 SCSI Bus ID 7
Bus 00 Slot 06/1: Adaptec AIC-7895
pkc0.7.0.106.0 SCSI Bus ID 7

PCI Hose 01
Bus 00 Slot 08: QLogic ISP10x0
pka0.7.0.8.1 SCSI Bus ID 7
Bus 00 Slot 09: Mylex DAC960
dra.0.0.9.1 dra0.0.0.9.1 1 Member JBOD
dra1.0.0.9.1 1 Member JBOD


ISA
Slot Device Name Type Enabled BaseAddr IRQ DMA
0
0 MOUSE Embedded Yes 60 12
1 KBD Embedded Yes 60 1
2 COM1 Embedded Yes 3f8 4
3 COM2 Embedded Yes 2f8 3
4 LPT1 Embedded Yes 3bc 7
5 FLOPPY Embedded Yes 3f0 6 2
EPE
Occasional Visitor
EPE
Posts: 1
Registered: ‎06-26-2011
Message 11 of 11 (790 Views)

Re: DS20E KZPAC and TRU64 4.0F install and boot problem

Hello,

 

I can find a way to boot.

 

Configure and initialize a drive DRA0 on KZPAC

Install TRU644.0Fon DRA0

Reboot on DRA0 -fi genvmunix  Not OK

Configure a second drive DRA1 on KZPAC

Reboot on DRA0  -fi genvmunix   OK

 

Seems like loosing something between DS20E and KZPAC when installing TRU644.0F

 

More ...

 

When configuring kernel with doconfig I am unable to boot on vmunix

I can only boot on genvmunix or GENERIC

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.