Apache SSL - Internet Explorer (65 Views)
Reply
Occasional Contributor
JordiPrats
Posts: 4
Registered: ‎06-27-2006
Message 1 of 2 (65 Views)

Apache SSL - Internet Explorer

I've set up a apache 1.3 with mod_ssl that need to authenticate users with digital certificates. But it only works with Mozilla well.

With IE it's asking for target's password on each request (every image, css...)

I've configured the following global parameters:


SSLRandomSeed startup builtin
SSLRandomSeed connect builtin
SSLLog /usr/local/apache-1.3.34/logs/ssl_engine_log
SSLLogLevel info


SSLSessionCache dbm:/usr/local/apache-1.3.34/logs/scache.twiki
SSLSessionCacheTimeout 600


Ant this is the virtual host configuration is:

SSLEngine on

SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP

SSLCertificateKeyFile /usr/local/apache-1.3.34/conf/ssl.key/serv-private.w02.pem
SSLCertificateFile /usr/local/apache-1.3.34/conf/ssl.crt/CERT_w02.xe.cesca.cat_2006_07_10-084501.crt

SSLVerifyClient none
SSLVerifyDepth 10

SSLOptions +ExportCertData +CompatEnvVars +StrictRequire +StdEnvVars +FakeBasicAuth

SetEnvIf User-Agent ".*MSIE.*" \
nokeepalive ssl-unclean-shutdown \
downgrade-1.0 force-response-1.0



I suspect that is somethin related with SSLSessionCache, but I don't know what. On a Linux box is working with the same configuration.

I've followed this reference:
http://www.modssl.org/docs/2.8/ssl_faq.html#ToC49


Thanks


Regular Advisor
Yarek
Posts: 92
Registered: ‎08-16-2006
Message 2 of 2 (65 Views)

Re: Apache SSL - Internet Explorer

Hi,

I recommend you to check Secure settings on IE(client) site
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.