QTP is not able to recognize the web objects(read as winobjects instead) after LoadRunner

by Community Manager on ‎11-30-2012 10:42 AM

Question

I am working with QTP in the same desktop for past one year.

 

System configuration: Core 2 Duo Processor, 2 GB RAM, 200 GB Hard Disk

S/W Configuration: QTP 10, Windows XP, IE 8

 

Recently, we installed Load Runner 9.5 in the same machine after which, QTP expressed some odd behavior. Then after repairing, QTP was functioning well, until we installed a Load Runner patch file (LR_03019.EXE) for IE 8 issues. Later point, QTP sporadically recognize the web objects. Knowing this, we again did a QTP repair which ended in vain. So we uninstalled both Load runner & QTP and reinstalled QTP in the same machine (Note: Machine restart was done after each installation).

 

Now QTP reads web objects only as win objects. I read almost all forum threads and did possible actions.

 

  1. Application is opened only after QTP
  2. Only appropriate add-ins are selected (Web, ActiveX, .Net)
  3. Checked Task manager to ensure Iexplore.exe process is there ( and not explore.exe)
  4. Tried ‘CreateObject("InternetExplorer.Application")’
  5. Changed few registry values (mentioned in HP Forums)
  6. Installed QTP path for IE8 (QTP_00626.EXE)
  7. Accessing machine/QTP/IE as administrator

 

Answer

"it looks like your QTP lost the web recognition after installing load runner patch, in this case please be advised that QTP and LR has compatibility issues when they are installed in the same machine since they shared several registry entries and DLLs, therefore is not recommended to have both products in the same machine, however if you don’t have any other option, then there’s a workaround that you can use in order to have both in the same machine but knowing that this is not supported.

 

The workaround is to install LR and all its patches first, then install QTP; since you already have both installed and not in the correct order, then you will need to do a clean uninstall of both tools, is not enough just to uninstall the product from add or remove programs, therefore, please follow these steps:

 

  1. Clean uninstall of LR following the attached document.
  2. Clean uninstall of QTP following the instructions on the KB article at the link below.

How to perform a clean uninstall/reinstall of QuickTest Professional

http://support.openview.hp.com/selfsolve/document/KM171368

  1. If you are going to have both products, then install LR first, then QTP.

Note: If install a LR patch after both products are installed, you could start experience issues again."

 

Comments
by Atul_N on ‎04-13-2014 11:33 PM

Hi ,

I am using QTP 11.0 and then installed IE 9.0 but whenevr i try to SPY Google Browser i  am getting  pop up INTERNET EXPLORER STOP working and QTP not able to capture IE properties.

I already installed below patches:-

00733

00953

00709

Search
Follow Us


Contributors
HP Blog

HP Software Solutions Blog

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation