Re: Exchange 2010 or 2013? (275 Views)
Reply
Advisor
JaniKrippner
Posts: 24
Registered: ‎11-15-2011
Message 1 of 2 (316 Views)

Exchange 2010 or 2013?

[ Edited ]

We are looing to upgrade our Exchange server to either 2010 or 2013. We are currently on TRIM 7.1.1.1821 with Windows 7 (32bit) and Office 2010 (32 bit).

 

Because we get the very annoying trying to email a record from TRIM and the Microsoft MAPI throws a hissy fit problem a lot, which is a major headache for users, it has been suggested that we skip Exchange 2010 and head straight for Exchange 2013 which no longer uses MAPI for client communications to try and bypass the issue.

 

I can't find anything in the documentation for TRIM 7.1, 7.2 or 7.3 to indicate support for Exchange 2013 exists yet, a search not helped by the specifications document omitting any mention of what versions of Exchange are supported.

 

Is Exchange 2013 a known no go zone or is it worth a try?

HP Expert
Neil Summers
Posts: 1,036
Registered: ‎10-08-2008
Message 2 of 2 (275 Views)

Re: Exchange 2010 or 2013?

Some of you may remember the issues encountered by customers who proactively upgraded their Exchange servers to 2010 back in the days when TRIM only supported the Outlook 2007 client. Because HP's testing was only done with Outlook 2007 against Exchange 2007, these customers discovered some significant issues/errors after upgrading only the backend to Exchange 2010. Unfortunately a number of them did it in Production without first trialing it in a test environment, and in some cases it caused some data issues when trying to upgrade users' Exchange mailboxes.

 

Since then, HP Support have endeavoured to ensure that not only the supported Outlook versions but also the supported Exchange versions are listed in the documentation. This hasn't quite happened yet, and admittedly it's a bit of a minefield. There are many possible combinations of TRIM, Outlook and Exchange versions, and many configuration options available, and realistically the HP TRIM development team doesn't intend to test them all.

 

So my advice is to stick with the same Exchange version as your Outlook clients wherever possible. If the Outlook client is tested and supported with TRIM, you can expect it to have been tested with the corresponding version of Exchange.

 

A change to the TRIMSpec document along the following lines has been put forward internally by the development team for an upcoming release:

 

"Microsoft Exchange support – while TRIM does not work directly with Microsoft Exchange, testing does include Microsoft Exchange and Outlook versions supported by Microsoft. However, as there are several versions of Microsoft Exchange and Outlook, as well as many possible TRIM configurations, it is highly recommended that before upgrading your Microsoft Exchange servers, you undertake thorough testing in your software environment to ensure there are no issues."

Neil


Note: Any posts I make on this forum are my own personal opinion and do not constitute a formal commitment on behalf of HP.

(Please state the version of TRIM/HPRM you're using in all posts)

HP Software Support Online (SSO): http://support.openview.hp.com
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.