Email Notifications - No Emails Sent when activites assigned. (326 Views)
Reply
Trusted Contributor
Posts: 294
Registered: ‎10-28-2009
Message 1 of 7 (326 Views)

Email Notifications - No Emails Sent when activites assigned.

I am almost finished testing Trim 7.1.2.2017 before we roll it out.   We are also using Groupwise 8.

 

I am testing mail notifications in workflow.  I have configured the workflow and events to send an email when

an activity is assigned.

 

I have kicked off a workflow and have assigned an activity to me.  My location has the correct email address.

 

Though I can see in the TES that mail notification events exist , I have not received any emails about assigned activities.

 

I have checked the windows events log and cannot find anything that would indicate a problem.

 

I have tested the email server in the TES and it works correctly and I have received an email when testing the setup.

 

Are those activity emails getting blocked?

 

Thanks for any help in correcting the problem of no emails when activities are assigned.

 

RD

Honored Contributor
Posts: 1,990
Registered: ‎04-20-2010
Message 2 of 7 (325 Views)

Re: Email Notifications - No Emails Sent when activites assigned.

Do other workflow email notifications get sent out?

Trusted Contributor
Posts: 294
Registered: ‎10-28-2009
Message 3 of 7 (313 Views)

Re: Email Notifications - No Emails Sent when activites assigned.

That is correct.  I cannot get email notifications to be sent out from any workflow.

 

RD

Honored Contributor
Posts: 1,990
Registered: ‎04-20-2010
Message 4 of 7 (310 Views)

Re: Email Notifications - No Emails Sent when activites assigned.

Can you verify that the system setting is enabled for sending notifications for workflow?

 

1) Open TRIM

2) Click Tools->HP TRIM Administration->System Settings

3) Click the Events Tab

4) Check the box labeled "Send e-mail notifications as defined for activities"

5) Click ok

Trusted Contributor
Posts: 294
Registered: ‎10-28-2009
Message 5 of 7 (307 Views)

Re: Email Notifications - No Emails Sent when activites assigned.

Erik,

 

    Yes, I had previously enabled the settings for email notification for workflow.

 

RD

Honored Contributor
Posts: 1,990
Registered: ‎04-20-2010
Message 6 of 7 (305 Views)

Re: Email Notifications - No Emails Sent when activites assigned.

Ok... then the next thing to do is to dig into the log for the server. I would disable all other event server processing, enable logging, push through an activity, and then look at the log. It could be something with the email account on the location, maybe you're using a position/group instead of a person, etc.

There are builds of TRIM where this was a bug. But I thought it had been fixed in these latest builds.
Trusted Contributor
Posts: 294
Registered: ‎10-28-2009
Message 7 of 7 (299 Views)

Re: Email Notifications - No Emails Sent when activites assigned.

[ Edited ]

Notifications are working now.    When I suspended all other events and redeployed in order to check the logs,  Emails were being sent.

 

I then reenabled all other events to see if it would cause an error.  Instead, the emails were still getting sent.

 

Why did  I need to suspend the other events to finally get mail notifications to work?

 

Thanks Erik for your help.

 

RD

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.