Cannot send this item - in Outlook (1626 Views)
Reply
Advisor
Shammi
Posts: 25
Registered: ‎08-11-2009
Message 1 of 18 (1,626 Views)

Cannot send this item - in Outlook

Hello there

 

We are running mixed environment of XP/Windows7 and Office 2007 with TRIM6 1226.

 

Every so often when you use the  Send to, Mail receipient, email link  - the above error "cannot send this item appears".  The only option then is to cancel the process and start it again.

 

I can see from some of the other messages there are various renditions of the Outlook/TRIM issue.

 

Does anyone has any idea?  Thanks  Shammi

Please use plain text.
Regular Advisor
Chum
Posts: 185
Registered: ‎06-03-2009
Message 2 of 18 (1,625 Views)

Re: Cannot send this item - in Outlook

Try turning off simple MAPI on the Trim client.  This seems to resolve most of these issues.

Please use plain text.
Occasional Advisor
Robert_4
Posts: 6
Registered: ‎04-20-2010
Message 3 of 18 (1,625 Views)

Re: Cannot send this item - in Outlook

How do you turn off simple MAPI on the Trim client.

Please use plain text.
Honored Contributor
Grundy
Posts: 2,742
Registered: ‎02-16-2009
Message 4 of 18 (1,625 Views)

Re: Cannot send this item - in Outlook

Tools  >  user Options  >  Mail tab  >  Untick 'Use Simple MAPI'.



::::::::::::::::::::::
NOT A HP EMPLOYEE
::::::::::::::::::::::

Now working for a TRIM consultancy
Please use plain text.
Frequent Advisor
Alpine_2
Posts: 37
Registered: ‎10-12-2010
Message 5 of 18 (1,526 Views)

Re: Cannot send this item - in Outlook

We are also getting this symptom from Outlook 2010 and TRIM 7.1 1150 when using Send To Mail Recipient from TRIM.

Our "Use Simple MAPI" tickbox was already unticked.

I have tested using Send To from other applications (even non-Microsoft) and it all worked from those applications, so it only seems to be TRIM where this fails.

It seems to occur if the email is left open for a while before actually sending.

I have googled the issue but really got nowhere with any of the workarounds, such as changing between HTML and Rich Text in Outlook and so on.

Help!!!!!
Please use plain text.
Honored Contributor
Grundy
Posts: 2,742
Registered: ‎02-16-2009
Message 6 of 18 (1,524 Views)

Re: Cannot send this item - in Outlook

There was a known issue where having the email open for a certain time period (a few minutes) and then sending would cause this error.

Exactly what you're describing.

 

I was pretty sure it was fixed in 7.1.0 though, but could be wrong.

 

If you raise a support case, we can look up the defect and see exactly when we worked on this.

(Not at work right now otherwise I'd check!)



::::::::::::::::::::::
NOT A HP EMPLOYEE
::::::::::::::::::::::

Now working for a TRIM consultancy
Please use plain text.
Frequent Advisor
Alpine_2
Posts: 37
Registered: ‎10-12-2010
Message 7 of 18 (1,521 Views)

Re: Cannot send this item - in Outlook

Thanks Grundy.  We will log a support case for this issue.  In the meantime, if you happen to come across the defect previously reported while you're next at work, it would be most appreciated if you could also post the results here as well. 

Please use plain text.
Honored Contributor
Grundy
Posts: 2,742
Registered: ‎02-16-2009
Message 8 of 18 (1,517 Views)

Re: Cannot send this item - in Outlook

Found the CR:

36918

 

But the details on it reminded me:

The issue with the Microsoft MAPI library, not TRIM!

R&D replicated the issue independently of TRIM.

 

See these notes from the CR:

I can duplicate this incident on a windows Vista box, Outlook 2003 SP3 and Trim 7.1.1132.
This seems a bug in the function MAPISendMail of MAPI.Dll ( %Windir%/system32/MAPI.dll ) no matter what you use simple Mail API or extended Mail API, utilmately a mail dialog is shown up and if user leave it there for a while ( a period of inactivity roughly 3 minutes or longer than that - long enough to break the mail user session ) the incident will happen.

This odd behaviour is probably caused by a bug in MAPISendMail of Microsoft, that doesn't appear to be much we can do given our dependence on the Microsoft MAPI library. Perhaps we should even raise this with Microsoft and refer the customer to that request.



::::::::::::::::::::::
NOT A HP EMPLOYEE
::::::::::::::::::::::

Now working for a TRIM consultancy
Please use plain text.
Frequent Advisor
Alpine_2
Posts: 37
Registered: ‎10-12-2010
Message 9 of 18 (1,509 Views)

Re: Cannot send this item - in Outlook

Hmm, interesting.  Which could also explain why when I test it under TRIM 7.1.1 1828, the issue occurs as well.  Thanks for checking - we will pursue in Microsoft's direction!

Please use plain text.
Frequent Advisor
Alpine_2
Posts: 37
Registered: ‎10-12-2010
Message 10 of 18 (1,496 Views)

Re: Cannot send this item - in Outlook

Hello again...

 

I have presented the above information to the problem management incident that was raised internally in our IT dept and one of the action items is to enqurie about how TRIM calls the Outlook new mail form when the Send To is invoked.  Please allow me to elaborate...

 

Some comparisons were done when opening a new mail window directly from Outlook, and when a new mail window is called from another application using Send To.  Some key differences between the two new mail windows were:

 

1. New mail window opened directly from Outlook was in HTML editing mode, whereas the new mail window opened via a Send To was in Plain text editing mode

 

2. New mail window opened directly from Outlook automatically appended the sender's email signature (turned on by default), whereas the new mail window opened via a Send To did not append the sender's email signature despite being turned on by default in the Outlook client.  Instead, TRIM appends it own body of text detailing the TRIM link information.

 

3. New mail window opened directly from Outlook had the usual Minimise button, whereas the Send To window had the Minimise button missing entirely or was greyed out!  Interestingly, we found that this symptom also occured when invoking Send To from Adobe Acrobat when sending a PDF.  The difference here is when sending from TRIM, after about 5 minutes the mail window would not send, whereas if sending from Adobe Acrobat, the mail still sent after more than 5 minutes of being open.

 

4. Another observation is I select the file to attach, wait 5 minutes and it fails.  I then go and do the same action on the same file, wait 5 minutes and it sends fine.  All I've done in between is close the window that is failing and gone back to TRIM and tried again.  If I select a different file to send, it starts the fail process off again.  That is weird!

 

So essentially, my question is how does TRIM call a new mail window in Outlook when Send To is invoked, particularly noting the differences in points 1 and 2 above?  

 

Any extra information would be useful for our problem investigation which unfortunately needs to be done internally to cover all the bases before we can log cases with vendors, eg Microsoft and/or HP.

 

Thanks.

   

Please use plain text.
Honored Contributor
Grundy
Posts: 2,742
Registered: ‎02-16-2009
Message 11 of 18 (1,493 Views)

Re: Cannot send this item - in Outlook

No idea on the above, I would need a dev to look this over.

 

The R&D Outlook fella is stone throwing distance away, so I'll see if I can get something for you soon.



::::::::::::::::::::::
NOT A HP EMPLOYEE
::::::::::::::::::::::

Now working for a TRIM consultancy
Please use plain text.
Frequent Advisor
Alpine_2
Posts: 37
Registered: ‎10-12-2010
Message 12 of 18 (1,471 Views)

Re: Cannot send this item - in Outlook

Hi Grundy, just wondering, any update from the devs?

Please use plain text.
Honored Contributor
Grundy
Posts: 2,742
Registered: ‎02-16-2009
Message 13 of 18 (1,467 Views)

Re: Cannot send this item - in Outlook

Hi Alpine,

 

Sorry, I was in training all week.

I've shot through the questions to the dev and awaiting a reply at the moment. :)

 

Will let you know as soon as I've heard back.



::::::::::::::::::::::
NOT A HP EMPLOYEE
::::::::::::::::::::::

Now working for a TRIM consultancy
Please use plain text.
Honored Contributor
Grundy
Posts: 2,742
Registered: ‎02-16-2009
Message 14 of 18 (1,444 Views)

Re: Cannot send this item - in Outlook

Hi Alpine, I will reply in-line below:

1. New mail window opened directly from Outlook was in HTML editing mode, whereas the new mail window opened via a Send To was in Plain text editing mode
This is not just TRIM. If you right-click an object on your Windows Desktop, it will also be plain text, even though your default format may be HTML in Outlook.

 

2. New mail window opened directly from Outlook automatically appended the sender's email signature (turned on by default), whereas the new mail window opened via a Send To did not append the sender's email signature despite being turned on by default in the Outlook client.  Instead, TRIM appends it own body of text detailing the TRIM link information.
As above, we found that this behaviour is not limited to TRIM. Opening a new email directly in the full Outlook client is not the same as using a send-to function elsewhere on the system.

 

3. New mail window opened directly from Outlook had the usual Minimise button, whereas the Send To window had the Minimise button missing entirely or was greyed out!  Interestingly, we found that this symptom also occured when invoking Send To from Adobe Acrobat when sending a PDF.  The difference here is when sending from TRIM, after about 5 minutes the mail window would not send, whereas if sending from Adobe Acrobat, the mail still sent after more than 5 minutes of being open.
Same as above, send-to from elsewhere on the system will grey out the minimise button.
The only thing here we can see here is that Adobe (and Office from our testing) attached the document to a new HTML email, not plain text, but the default signature still never appeared.

 

4. Another observation is I select the file to attach, wait 5 minutes and it fails.  I then go and do the same action on the same file, wait 5 minutes and it sends fine.  All I've done in between is close the window that is failing and gone back to TRIM and tried again.  If I select a different file to send, it starts the fail process off again.  That is weird!
Yep, we found the same weirdness when we first investigated this issue!

 


   


So we've had a think about what we can do here, but we are still limited by an API issue with the MAPI dll.
At best out of all of this, we can look at being able to send HTML formatted emails, if Adobe and Office can do it, but you still dont get a signature even with those apps and we still replicated the Cannot Send error outside of TRIM too.  :S

Not ideal, but I don't think we'll be able to solve that error via our own code.

 

 



::::::::::::::::::::::
NOT A HP EMPLOYEE
::::::::::::::::::::::

Now working for a TRIM consultancy
Please use plain text.
Frequent Advisor
Alpine_2
Posts: 37
Registered: ‎10-12-2010
Message 15 of 18 (1,417 Views)

Re: Cannot send this item - in Outlook

Something we discovered a couple of weeks back is that TRIM records the fact that a file has been attached and sent to a recipient.

We thought at the time that this probably occurs at the point of sending and therefore means there is communication with the app.

Is it possible that TRIM has some sort of timeout where it no longer accepts that communication causing the email send to fail?
Please use plain text.
Honored Contributor
Grundy
Posts: 2,742
Registered: ‎02-16-2009
Message 16 of 18 (1,410 Views)

Re: Cannot send this item - in Outlook

[ Edited ]

Nope, as above, we replicated otuside of TRIM. :S

 

It will be MS MAPI code, not TRIM side.



::::::::::::::::::::::
NOT A HP EMPLOYEE
::::::::::::::::::::::

Now working for a TRIM consultancy
Please use plain text.
Advisor
Phil_The
Posts: 31
Registered: ‎09-03-2012
Message 17 of 18 (914 Views)

Re: Cannot send this item - in Outlook

I realise its been a while since this topic was touched upon however ...

 

I note that this behaviour still appears to exist with TRIM 7.31 on Windows 7 (x86) with Service Pack 1.

 

I cannot locate any update MAPI updates/fixes on the MS site.

 

Is it safe to assume that this issue with MAPI has not been addressed by MS?

 

Thanks for your time.

Please use plain text.
HP Expert
Neil Summers
Posts: 931
Registered: ‎10-08-2008
Message 18 of 18 (890 Views)

Re: Cannot send this item - in Outlook

Hi Phil,

 

I think the jury's still out on whether this problem is actually caused by a bug in MAPI (I don't think Microsoft have confirmed this). TRIM 7.32 is now shipped with an additional executable called TrimMailHelper.exe, which is essentially a workaround to avoid the issues HP were having trying to avoid this issue happening with the Outlook API.

Neil

(Please state the version of TRIM/HPRM you're using in all posts)
Note: Any posts I make on this forum are my own personal opinion and do not constitute a formal commitment on behalf of HP.

HP Software Support Online (SSO): http://support.openview.hp.com
Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation