unresolved symbol after Omniback II upgrade 3.00 to 3.10 (270 Views)
Reply
Occasional Visitor
Jerry Pinnell
Posts: 5
Registered: ‎07-15-1999
Message 1 of 3 (270 Views)

unresolved symbol after Omniback II upgrade 3.00 to 3.10

My N4000 11.0 server was recently upgraded to Omniback 3.10 after which online Oracle backups using RMAN fail while backing up the recovery catalog:

/usr/lib/dld.sl: Unresolved symbol: InitSetVerStruct (code) from /opt/omni/lbin//obkbackup
Oracle8CatalogBackup[19]: 22419 Abort
[Major] From: ob2rman.exe@pppd1 "GOLD" Time: 07/05/00 22:14:02
Backup of the recovery catalog database failed.


A previous call to HP on the problem directed me to relink the oracle executable with the new Omniback library which I have now done twice. The problem persists. Ideas?
Please use plain text.
Trusted Contributor
alberto vasquez
Posts: 119
Registered: ‎05-08-2000
Message 2 of 3 (270 Views)

Re: unresolved symbol after Omniback II upgrade 3.00 to 3.10

Hello Jerry,

I was the engineer that originally found this error and resolved it with relinking the Oracle8 library. For that situation, they were receiving the error when performing the backup of the target database. From your statement you are only receiving this error when attempting to backup the catalog database (default with full backup).

Assuming that you are not running Oracle8i and that you have not changed your Oracle environment at all during this time, I have the following suggestions:
1 - Confirm that you have applied the latest OmniBackII patches for 3.10. A current list of the patches can be obtained from:
http://ovweb.external.hp.com/cpe/patches/

2 - Confirm that the linking procedure was done correctly and that the chatr output is as it should be. By that, I mean confirming that /opt/omni/lib/libob2oracle8.sl (or 64-bit) is contained in the shared library path and that the SHLIB_PATH entry is enabled.

3 - If the problem continues, open a case with the response center so that we can obtain information and purse the issue.

4 - If you had upgraded to Oracle8i, then read the special instructions section of the OmniBackII 3.10 Oracle8 patch. The linking process is different.

Sorry that we couldn't be of more assistance.

-Mark Butler
Please use plain text.
Occasional Visitor
Jerry Pinnell
Posts: 5
Registered: ‎07-15-1999
Message 3 of 3 (270 Views)

Re: unresolved symbol after Omniback II upgrade 3.00 to 3.10

Thanks, Mark for your quick response.
While the latest 3.10 patches have not been applied, the upgrade was part of the 0300 Applications Release which should have been complete at that date. Many of the current patches don't apply (Sybase, SAP, Informix).
This is an 8.0.5 Oracle database. chatr is not showing SHLIB_PATH enabled:

shared executable
shared library dynamic path search:
SHLIB_PATH disabled second
embedded path disabled first Not Defined
shared library list:
static /opt/omni/lib/libob2oracle8.sl
dynamic /usr/lib/librt.2
dynamic /usr/lib/libnss_dns.1
dynamic /usr/lib/libdld.2

The library appears to be statically linked ok. I'll try to enable the SHLIB_PATH with the +s option.
Thanks for your help and direction.
Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation