Re: Problem with Oracle 9i > DP 6.11 integration (2285 Views)
Reply
Occasional Advisor
Ognen
Posts: 6
Registered: ‎04-05-2012
Message 1 of 9 (2,316 Views)
Accepted Solution

Problem with Oracle 9i > DP 6.11 integration

[ Edited ]

Hello , we are making migration from Legato to Data Protector and we`ve faced the following issue :

 

--Oracle Version :

Oracle9i Enterprise Edition Release 9.2.0.8.0 - 64bit Production

JServer Release 9.2.0.8.0 - Production

--Linux version :

[ora9i@fiespx0162 lib]$ uname -a

Linux fiespx0162.fortum.com 2.6.9-67.EL #1 SMP Wed Nov 7 13:43:35 EST 2007 ia64 ia64 ia64 GNU/Linux

---DP version

6.11

 

 

Library is linked (even tho it doesnt need to be for this version of DP):

ln -s /opt/omni/lib/libob2oracle8_64bit.so libobk.so

 

------------------------ERROR

 

[root@fiespx0162 ~]# /opt/omni/lbin/util_oracle8.pl -config -dbname MX5TST -orahome /oracle/9.2.0 -prmuser rman -prmpasswd ********* -prmservice MX5TST.CLIENT.COM -client fiespx0162.fortum.com OM -client fiespx0162.fortum.com
*RETVAL*8100

SBT_LIBRARY=/opt/omni/lib/libob2oracle8_64bit.so

 

CHILDERROR:1

Process exit code: 1, Signal: 0

RMAN PID=7533

 

APPERROR:

RMAN-00571: ===========================================================

RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============

RMAN-00571: ===========================================================

RMAN-03009: failure of allocate command on DP_TEST channel at 04/05/2012 14:15:00

ORA-19554: error allocating device, device type: SBT_TAPE, device name:

ORA-27000: skgfqsbi: failed to initialize storage subsystem (SBT) layer

Additional information: 7110

ORA-19511: Error received from media manager layer, error text:

   SBT error = 7110, errno = 0, sbtinit: internal error - invalid argument(s)

 

Recovery Manager complete.

 

------------

--error explanation

D:\Program Files\OmniBack\bin>omnigetmsg 12 8100

The database reported error while performing requested operation.

------------

 

---This error happens even if i try to make the integration from the cell server and even when i try to open channel manually from RMAN using :

 

RMAN> run {

allocate channel 'dev_0' type 'sbt_tape' parms 'SBT_LIBRARY=/opt/omni/lib/libob2oracle8_64bit.so,ENV=(OB2BARTYPE=Oracle8,OB2APPNAME=MX5TST)';

}2> 3>

 

 

RMAN-00571: ===========================================================

RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============

RMAN-00571: ===========================================================

RMAN-03009: failure of allocate command on dev_0 channel at 04/05/2012 14:25:37

ORA-19554: error allocating device, device type: SBT_TAPE, device name:

ORA-27000: skgfqsbi: failed to initialize storage subsystem (SBT) layer

Additional information: 7110

ORA-19511: Error received from media manager layer, error text:

   SBT error = 7110, errno = 0, sbtinit: internal error - invalid argument(s)

 

There are no errors in the sbtio.log file of the database.

 

/var/opt/omni/log/oracle8.log is empty

/var/opt/omni/log/debug.log no entries here also

 

When i try the integration from cell we have some lines here /var/opt/omni/log/inet.log :

          Thu 05 Apr 2012 10:03:30 AM EEST [ora9i.dba@fiesps0841.adinfra.net] : util_oracle8.exe

          Thu 05 Apr 2012 10:32:55 AM EEST [ora9i.dba@fiesps0841.adinfra.net] : util_oracle8.exe

          Thu 05 Apr 2012 10:34:28 AM EEST [ora9i.dba@fiesps0841.adinfra.net] : util_oracle8.exe

          Thu 05 Apr 2012 10:52:38 AM EEST [ora9i.dba@fiesps0841.adinfra.net] : util_oracle8.exe

 

[root@fiespx0162 log]# cat /proc/sys/fs/file-max

65536

 

The cell server is the correct one :

          [root@fiespx0162 log]# cat /etc/opt/omni/client/cell_server

          fiesps0841.adinfra.net

 

 

[root@fiespx0162 log]# cat /etc/sysctl.conf

# Kernel sysctl configuration file for Red Hat Linux

#

# For binary values, 0 is disabled, 1 is enabled.  See sysctl(8) and

# sysctl.conf(5) for more details.

 

# Controls IP packet forwarding

net.ipv4.ip_forward = 0

 

# Controls source route verification

net.ipv4.conf.default.rp_filter = 1

 

# Do not accept source routing

net.ipv4.conf.default.accept_source_route = 0

 

# Controls the System Request debugging functionality of the kernel

kernel.sysrq = 0

 

# Controls whether core dumps will append the PID to the core filename.

# Useful for debugging multi-threaded applications.

kernel.core_uses_pid = 1

 

# Values required by Oracle9i Server

kernel.shmall = 2097152

kernel.shmmax = 2147483648

kernel.shmmni = 4096

kernel.sem = 250 32000 100 128

fs.file-max = 65536

net.ipv4.ip_local_port_range = 1024 65000

 

 

 

At the same time current backups on Legato on tape are running successfully

 

Please share some information how to solve this issue if possible and/or what else to check.

 

Please use plain text.
Honored Contributor
Sebastian.Koehler
Posts: 1,155
Registered: ‎02-27-2007
Message 2 of 9 (2,285 Views)

Re: Problem with Oracle 9i > DP 6.11 integration

Have you added the oracle user which is used to configure the integration to the Data Protector configuration? (ora9i.dba) Have seen this kind of error message before...

 

Regards,

Sebastian

---
Assign a kudo to this post, if you find it useful.
Please use plain text.
Occasional Advisor
Ognen
Posts: 6
Registered: ‎04-05-2012
Message 3 of 9 (2,279 Views)

Re: Problem with Oracle 9i > DP 6.11 integration

Hi,

thanks for reply.

 

Yes the user exists for sure , otherwise the error would`ve been different as i recall .

Please use plain text.
Honored Contributor
Sebastian.Koehler
Posts: 1,155
Registered: ‎02-27-2007
Message 4 of 9 (2,272 Views)

Re: Problem with Oracle 9i > DP 6.11 integration

Here are some relevant issues from the SSO portal...

 

http://support.openview.hp.com/selfsolve/document/KM1127043

http://support.openview.hp.com/selfsolve/document/KM90317

 

Regards,

Sebastian

---
Assign a kudo to this post, if you find it useful.
Please use plain text.
Occasional Advisor
Ognen
Posts: 6
Registered: ‎04-05-2012
Message 5 of 9 (2,255 Views)

Re: Problem with Oracle 9i > DP 6.11 integration

the second link is totaly different problem when the user is not added in DP admin  and i dont know what is the meaning of the content in the first link..

Are those some patches ? If they are patches i cannot download them because the links are not active

Please use plain text.
Honored Contributor
Sebastian.Koehler
Posts: 1,155
Registered: ‎02-27-2007
Message 6 of 9 (2,251 Views)

Re: Problem with Oracle 9i > DP 6.11 integration

Could be possible we're talking about different things. Sorry for that. If you have a software support contract, it might be best to contact HP support to solve your issue.

Regards,
Sebastian
---
Assign a kudo to this post, if you find it useful.
Please use plain text.
Occasional Advisor
Ognen
Posts: 6
Registered: ‎04-05-2012
Message 7 of 9 (2,233 Views)

Re: Problem with Oracle 9i > DP 6.11 integration

The problem has been solved,

There was a problem with rights

We have lost rights at folder /etc/opt/omni  not at file  /etc/opt/omni/client/cell_server  itself.

We needed to give 755 rights to the folder

Please use plain text.
Honored Contributor
Sebastian.Koehler
Posts: 1,155
Registered: ‎02-27-2007
Message 8 of 9 (2,230 Views)

Re: Problem with Oracle 9i > DP 6.11 integration

Thanks for letting us know. Please mark this topic as resolved then.

 

Regards,

Sebastian

---
Assign a kudo to this post, if you find it useful.
Please use plain text.
Visitor
shyfur
Posts: 2
Registered: ‎05-01-2013
Message 9 of 9 (1,064 Views)

Re: Problem with Oracle 11G > DP 6.11 integration

Dear Ognen

 

I am getting the same error. My permission are ok . Could you please help me?

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation