Re: Hyperv 2012 R2 Support (1047 Views)
Reply
Frequent Advisor
Stefano Colombo
Posts: 126
Registered: ‎11-14-2002
Message 1 of 9 (1,118 Views)

Hyperv 2012 R2 Support

Does anyone know if Hyper V 2012 R2 is supported or at least is supposed to work as it does HyperV 2012 ?

We have a problem with DP 7.03 where when we try to create a new VE backup selecting the cluster node as client the vm list contains only the VM running on the host that is currently owning the cluster role.

 

Can anyone help on this ?

thanks

 

Please use plain text.
Advisor
Arnaud Delaloy
Posts: 11
Registered: ‎09-11-2009
Message 2 of 9 (1,103 Views)

Re: Hyperv 2012 R2 Support

[ Edited ]

Hello,

 

 Unfortunately, Hyper-v 2012 R2 doesn't work at all in Dataprotector do far (even in standalone thru the hyper-v VSS component, it fails), neither in DP 7 or DP8.0 (there is no mention of windows 2012 AT ALL in the quickspec!)

 

 I opened a case to support a month ago about it, there is an enhancement request for it, but it has no delivery date...

  maybe it will be in DP 8.1, due next month ?

 

 

the enhancement request (not mine) : https://support.openview.hp.com/selfsolve/document/LID/QCCR2A49166%20?docid=QCCR2A49166%20&isEnhance...

Please use plain text.
Frequent Advisor
Stefano Colombo
Posts: 126
Registered: ‎11-14-2002
Message 3 of 9 (1,093 Views)

Re: Hyperv 2012 R2 Support

Actually it does work .
It works either in standalone mode or clusters
I'm running it now and I can confirm that

My problem is that when the cluster role is held by a specific node I can see all the VMs in the cluster
When is held by the remaining two I see only the VM on that nodes ( but I can backup them if they don't move )
Please use plain text.
Advisor
Arnaud Delaloy
Posts: 11
Registered: ‎09-11-2009
Message 4 of 9 (1,087 Views)

Re: Hyperv 2012 R2 Support

when I asked, HP support clearly said "windows 2012 R2 is not supported in Dataprotector" , even for a basic file backup. but we all know "not supported" doesn't mean it won't work, though... the VSS integration fails on my 2012R2 servers, but my config is still in DP 7.01; that's good to know it works in 7.03 ! (i'll get the bundle, as soon as I can sort this new year's supposed support contract expiration, according to HP...)
Please use plain text.
Frequent Advisor
Stefano Colombo
Posts: 126
Registered: ‎11-14-2002
Message 5 of 9 (1,076 Views)

Re: Hyperv 2012 R2 Support

Yes is not supported officially in any documentation but it works
I only have to rectify my previous post
I still see only the VMs running on the node which is holding the cluster role
But the backup works fine
Please use plain text.
Advisor
Arnaud Delaloy
Posts: 11
Registered: ‎09-11-2009
Message 6 of 9 (1,054 Views)

Re: Hyperv 2012 R2 Support

hello,

 

I Just got the information thru a very unofficial HP channel that Windows 2012 R2 shall be supported in Dataprotector 8.11 , and that should be available around April 2014.

 

 

Please use plain text.
Frequent Advisor
Stefano Colombo
Posts: 126
Registered: ‎11-14-2002
Message 7 of 9 (1,047 Views)

Re: Hyperv 2012 R2 Support

Thanks for the info
Great to know
Please use plain text.
Advisor
rav63
Posts: 26
Registered: ‎08-15-2013
Message 8 of 9 (431 Views)

Re: Hyperv 2012 R2 Support

Hello.

Already a 8.12 patch but still no Hyper-V 2012 R2 support.

When it will be supported?

Please use plain text.
Occasional Advisor
Brendan_Reilly
Posts: 10
Registered: ‎05-16-2013
Message 9 of 9 (424 Views)

Re: Hyperv 2012 R2 Support

We had the exact issue as the OP with one of our 2012 R2 clusters, it will not get a list of VMs from the cluster, only the node you select in the VE backup job. I eventually had to create 2 separate MS VSS jobs to backup each node, so now when VMs change nodes I have to manually update my job.

 

Our 4 other Hyper-V clusters are still either 2008 R2 or 2012 but we use Veeam for them as DP was causing nothing but issues on the Cluster during backups so we had to find another solution that was stable. Granted this was 6.22/7.0 days but if you support something you should ensure it works before standing behind it.

 

I think DP should focus on fixing existing versions and adding support for existing Server OSs instead of moving all the way to DP 9 even though 8 is barely a year old.

 

Good luck.

Please use plain text.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation