Re: Drive based Encryption - Strange problem (253 Views)
Reply
Valued Contributor
nikhil_d
Posts: 122
Registered: ‎09-21-2012
Message 1 of 4 (310 Views)

Drive based Encryption - Strange problem

Hi,

 

I am facing a strange problem with DP 6.21. The drive based encryption flag on certain LTO4 drives is getting automatically "turned on". Normally all the backups run during night, and when I check in the morning the setting of the drive is changed.

 

The drives are LTO4 drives in an ESL. All are multipath drives, CM is HP-UX 11.31 IA, and the drives are visible/configured for multiple hosts ranging from Windows 2003 / 2008R2 and HP-UX 11.23/11.31 machines. MA Patches are up to date, last CM patch is pending.

 

Note: We do not use encryption for all the backups, but for certain pools only (the ones which are stored offsite). Hence in the general setting of the drive encryption is turned off, and we have enabled it on specification level for some backup specs. The backup types vary from Exchange/SAP/Oracle/Filesystems etc.

 

Has anyone observed similar issues? If yes, what was the solution?

 

I've already tried deleting the drives and re-configuring them but this does not help. Normally I would not have cared, but the IDB backup fails sometimes with the message:

 

[Critical] From: BSM@CM_HOST "XXXX"  Time: 11.06.2013 06:34:58
[61:2060]     KMS failed to automatically create a key for entity "xxxxxx".

[Critical] From: BMA@CM_HOST "DRIVE"  Time: 11.06.2013 06:34:58
[90:6111]     Error retrieving encryption key.

 

Hence this has become an issue for us. If there is no simple solution, I do plan to open a support call next week.

 

Thanks for your help.

Honored Contributor
danielbraun
Posts: 720
Registered: ‎07-07-2010
Message 2 of 4 (285 Views)

Re: Drive based Encryption - Strange problem

Hi,

 

please keep in minde that hardware encryption is not set on the pool, it is set per drive and can be turned off/on in the backup specification. You might wanna check this once more if set as expected. As you receive the error, you might run a check of the keystore.

 

 

Best regards

Daniel

-----------
Please assign Kudos - How to assign...
Valued Contributor
nikhil_d
Posts: 122
Registered: ‎09-21-2012
Message 3 of 4 (281 Views)

Re: Drive based Encryption - Strange problem

Hi Daniel,

 

Yes, I am aware of that. We use encryption only for offsite tapes, and that's why I have enabled the encryption in the specifications and not on the drives. But strangely it gets turned on for the drives making the onsite tapes also encrypted....

 

Regards,

Nikhil

Honored Contributor
danielbraun
Posts: 720
Registered: ‎07-07-2010
Message 4 of 4 (253 Views)

Re: Drive based Encryption - Strange problem

Hi Nikhil,

 

as I never heard about such a problem, it might be the best to open a case.

 

Best regards

Daniel

-----------
Please assign Kudos - How to assign...
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.