Re: Data Protector 6.2 and VMWare integration (3027 Views)
Reply
Occasional Advisor
Mark Oszczyk
Posts: 12
Registered: ‎12-17-2008
Message 1 of 11 (3,125 Views)

Data Protector 6.2 and VMWare integration

Hi

I'm part way through a DP6.2 installation and proving. I have successfully installed all of the windows components. I have installed DP clients onto ESX hosts (and the W2K8 VCC).

The Cell Manager allows me to create backup descriptions and I have successfully run a File System backup to the tape library. But when I try to execute my first test VM backup (a single VM from one of the ESX hosts) I get an error message

O2BAR_VWMARE_BAR etc (some stuff particular to our environment)

 /vm/'vmname' no target host

This is despite the fact that I can simulate the backup without error

 

The only Windows event log message I can find is on the VCC which reports failing vmware_bar_exe

 

What am I missing?

 

Honored Contributor
Sebastian.Koehler
Posts: 1,157
Registered: ‎02-27-2007
Message 2 of 11 (3,119 Views)

Re: Data Protector 6.2 and VMWare integration

Please review the VMware integration documentation for details. There is no need to install agents on ESX hosts unless you're sitll on a ESX version prior to 4.0. You need to import vCenter server and ESXi hosts and have VEPA integration installed on a Windows or Linux host. This host will perform the data movement.

 

Regards,

Sebastian

---
Assign a kudo to this post, if you find it useful.
Occasional Advisor
Mark Oszczyk
Posts: 12
Registered: ‎12-17-2008
Message 3 of 11 (3,108 Views)

Re: Data Protector 6.2 and VMWare integration

Sebastian

I have VMWare integration istalled on both the Cell Manager and the VCC.

I have imported all 3 of the ESX servers in the cluster where the VM resides

(There are 31 blades running esx but they are divided into clusters)

the VCC is a virtual running on the same cluster as the VM I am trying to back up

The Agents on the ESX hosts are from a previous attempt to install and configure v7 of DP

Should I remove them?

(The first ESX server is also an installtion server for ESX - at the time I thought the esx servers needed software)

I have opened port 5555 on all ESX servers

 

I'm still missing something

Thanks for the pointers so far

Mark

Honored Contributor
Sebastian.Koehler
Posts: 1,157
Registered: ‎02-27-2007
Message 4 of 11 (3,096 Views)

Re: Data Protector 6.2 and VMWare integration

Ok, please provide the complete session log of the non-preview session. Provide screenshots of the error message, if you have anything beside the session log and the omnicheck -patches output from the CS. If you're not using any patches, this could be a reason. Why did you throw away DP 7.0? It includes a lot of fixes, especially for VEPA backups.

You don't need to fish around in the firewall of the ESX host. Please remove the agent from the ESX host, since they are not required.

What VMware vCenter and ESX version are you using? Have you installed the VMware or the VEPA (Virtual Environment) integration on the backup host? You need VEPA!

Regards,
Sebastian
---
Assign a kudo to this post, if you find it useful.
Occasional Advisor
Mark Oszczyk
Posts: 12
Registered: ‎12-17-2008
Message 5 of 11 (3,072 Views)

Re: Data Protector 6.2 and VMWare integration

Sorry for the delay

I am unable to copy the log fro mthe affected system but here is a typed copy

[Normal] From BSM@ocisvcc001.xxx.x.x.x "OCISAVCFull" Time  etc Backup Session 2012/06/27-9 started.

[Normal] From BSM@ocisvcc001.xxx.x.x.x "OCISAVCFull" Time  etc OB2BAR application on xxxx. succesfully started

[Major] from OB2BAR_VMWARE_BAR@ocisvcc001.xxxx.xxx.x.x.x "/OCIS" time etc

Virtual Machine '/vm/OCISAVC001': no target host.

[Normal] From: BSM@ocisvcc001.xxx.x.x.x "OCISAVCFull" Time etc OB2BAR application on xxxx disconnected

[Major] From BSM@ociswdc001.xxx.x.x.x "OCISACVFull" Time etc

[61:3003]  Lost connection to OB2BAR Backup DA named "ERROR"

on host ocisvcc001.xxx.x.x.x

Ipc subsystem reports: "IPC Read error

System Error: [10053] Software caused connection abort

 

Then a [Critical] from BSM saying that none of the disk agents completed succesfully

 

vcc is the virtual centre

WDC is the DP server (with Fibre Channel connectivity to the SAN and Tape libabry

 

 

I am going to try a bcakup of a VM using one of the esx servers that does not have the v7 software installed

and will post the result (after opening port 5555 of course)

 

Regards

Honored Contributor
Eblyn Solis
Posts: 1,334
Registered: ‎10-19-2007
Message 6 of 11 (3,058 Views)

Re: Data Protector 6.2 and VMWare integration

Hi Mark,

That's a communication error,do you tried to add in the hosts file IP and long name on all servers involved?

The backup is set to be fiber?

 

 

Regards.

Occasional Advisor
Mark Oszczyk
Posts: 12
Registered: ‎12-17-2008
Message 7 of 11 (3,055 Views)

Re: Data Protector 6.2 and VMWare integration

Hi

Thanks ofr the suggestion

I have just checked and I can ping any server by shortname from any other server

ie from esx ping data protector cell manager

from esx host ping vcc

from vcc ping esx host

from vcc ping Date Centre Cell Manager

etc

I will check with long (fully qualified) names , but I think the result will be the same

regards

Occasional Advisor
Mark Oszczyk
Posts: 12
Registered: ‎12-17-2008
Message 8 of 11 (3,053 Views)

Re: Data Protector 6.2 and VMWare integration

Have tried and it works with long names as well (FQDN)
Occasional Advisor
Mark Oszczyk
Posts: 12
Registered: ‎12-17-2008
Message 9 of 11 (3,027 Views)

Re: Data Protector 6.2 and VMWare integration

Following ping results I have used telnet 5555 and obtained a result from the Cell Manager (WDC) the VCentre (VCC) and the individual esx hosts (esc00n)

 

This gives a DP response (similar to the one when installing new clients DP version etc)

 

The only slight issue is that the telnet session is not closed cleanly - but I dont think this is an issue

 

so Example telnet session

telnet ociswdc001.xxxx.x.x.x 5555

HP Data Protector A.06.20:Inet internal build 370, built on 25 February 2011, 17:41

 

Connection to host lost

 

(and telnet session has to be closed with a carraige return or escape)

 

Does it matter if the Cell clients are a newer version of the product than the Cell Manager

 

Still get same error conditions on a different set of VM and ESX host

 

 

Occasional Advisor
Mark Oszczyk
Posts: 12
Registered: ‎12-17-2008
Message 10 of 11 (3,017 Views)

Re: Data Protector 6.2 and VMWare integration

I have run OMNICHECK -DNS on all current cell members - there were some erros but I have removed some esx servers from the cell to remove these (I intend to add all cell members back once I have got a successful installtion that will backup VMWare images)

I have restarted the Cell manager (it is also the DNS server) as this was suggested in another post as a possible fix to DNS errors

Everything now looks fine (OMNICHECK -DNS -verbose lists all of the connections between Cell Manager and VCC and Cell Members) but BACKUPS STILL DO NOT WORK

Error message is still the same

From OB2BAR_VMWARE_BAR@vccservername time and date info

Virtual Machine 'vm/VMNAME' :no target host

 

Anyone have any suggestions how I can progress this

Occasional Visitor
adunkhor
Posts: 1
Registered: ‎09-07-2012
Message 11 of 11 (2,589 Views)

Re: Data Protector 6.2 and VMWare integration

Hello everybody,

I had the same error messages.

My mistake was that I imported the vCenter Server as "Data Protector Client" and not as "VMWare vCenter".

After deletion and correct reimporting everything works fine.

Hope it helps.

Cheers Axel.

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.