Re: DP8 will not scan barcode (552 Views)
Reply
Occasional Advisor
PGamblin
Posts: 11
Registered: ‎07-12-2013
Message 1 of 2 (598 Views)

DP8 will not scan barcode

[ Edited ]

When attempting a bar code scan via DataPotector 8, I receive the following, and it just sits there, BUT I can force a scan via the menu at the library

 

[Normal] From: MSM@*.*.*.com "HP:MSL6000 Series_devbackup"  Time: 7/22/2013 11:11:14 AM

Media session 2013/07/22-19 started.

[Normal] From: UMA@*.*.*.com "HP:MSL6000 Series_devbackup"  Time: 7/22/2013 11:11:14 AM

STARTING Media Agent "HP:MSL6000 Series_devbackup"

 

Prior to this I had to disable the Windows robotics drivers, because the devices were showing claimed by HP.

So I did the following;

On Windows, robotics drivers are automatically loaded for enabled tape libraries. To use the library robotics with Data Protector on a Windows system, disable the respective Windows driver.

  1. Steps
  2. In the Control Panel, double-click Administrative Tools.
  3. Double-click Computer Management and then click Device Manager.
  4. Expand Medium Changers.
  5. Right-click the medium changer, for example 4mm DDS Medium Changer, and then select Disable.
  6. Restart the system to apply the changes. The robotics is now ready to be configured with Data Protector.

Services are running, and devices are present. 

 

FYI  This same MSL6000 worked with a older machine running dp5.50, I can't go and look at that config because DP5.50 is corrupted

 

C:\Program Files\OmniBack\bin>omnisv -status

    ProcName      Status  [PID]

===============================

    crs         : Active  [1612]

    mmd         : Active  [2204]

    kms         : Active  [2460]

    hpdp-idb    : Active  [1672]

    hpdp-idb-cp : Active  [1724]

    hpdp-as     : Active  [1592]

    omniinet    : Active  [1992]

    Sending of traps disabled.

===============================

Status: All Data Protector processes/services up and running.

 

C:\Program Files\OmniBack\bin>devbra -a

[Warning] From: DEVBRA@*.*.*.com ""  Time: 7/22/2013 12:59:34 PM

[90:11]         Unrecognized option "-a" => ignored

 

Tape    HP:Ultrium 2-SCSI  Path: "scsi5:0:2:0C"  SN: "HUL4D02975"

        Description: HP LTO drive

        Revision: F6AW  Device type: lto [13]  Flags: 0x0001

Tape    HP:Ultrium 2-SCSI  Path: "scsi5:0:1:0C"  SN: "HUL4D02987"

        Description: HP LTO drive

        Revision: F6AW  Device type: lto [13]  Flags: 0x0001

Exch    HP:MSL6000 Series  Path: "scsi5:0:0:0"  SN: "3G44LRT5XMS8"

        Description: HP StorageWorks MSL 6000 Series

        Revision: 0423  Flags: 0x0006  Slots: 58  Drives: 4

        Drive(s) SN:

                "N/A"

                "N/A"

                "N/A"

                "N/A"

Tape    HP:Ultrium 2-SCSI  Path: "scsi4:0:4:0C"  SN: "HUL5K04528"

        Description: HP LTO drive

        Revision: F6AW  Device type: lto [13]  Flags: 0x0001

Tape    HP:Ultrium 2-SCSI  Path: "scsi4:0:3:0C"  SN: "HUL5K04618"

        Description: HP LTO drive

        Revision: F6AW  Device type: lto [13]  Flags: 0x0001

 

Thank you Paul

Honored Contributor
Scott McIntosh_2
Posts: 6,874
Registered: ‎08-26-2003
Message 2 of 2 (552 Views)

Re: DP8 will not scan barcode

You should have the Windows driver loaded if available for robotic devices.

Windows drivers for the MSL6000 do exist.

 

That said, try this omnirc setting on the robotic host system (where UMA runs) and see if things now work:

OB2GETSINGLEBARCODE=1

 

Thanks,

Scott

The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.