Re: DP6.2 telnet localhost no responce - any IDEA??? (1294 Views)
Reply
Frequent Advisor
Stefan Wusowski
Posts: 117
Registered: ‎04-23-2001
Message 1 of 11 (1,450 Views)
Accepted Solution

DP6.2 telnet localhost <Port> no responce - any IDEA???

[ Edited ]

Environment: DP6.2 Linux CS, Client Redhat 5.4

 

Hello,

i have succesfully installed DP Agent 6.2 (rpm tells) - via Gui and manually. But if I try to connect the INET there is no responce:

telnet localhost 9555 (yes we changed the Port !!!)
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
Connection closed by foreign host.

 

/var/log/messages tells a segfault:

Dec 20 12:50:43 lnxp-2252 xinetd[9305]: START: omni pid=11693 from=::ffff:127.0.0.1
Dec 20 12:50:43 lnxp-2252 kernel: inet[11693]: segfault at 0000000000000000 rip 000000000041cbd9 rsp 00007fff85f859b8 error 4
Dec 20 12:50:43 lnxp-2252 xinetd[9305]: EXIT: omni signal=11 pid=11693 duration=0(sec)

 

INET Debuging - says something, but no Error(sees Attachment)

 

So what happend - any IDEA?????

 

Thx

S. Wusowski

Honored Contributor
Zigoze
Posts: 549
Registered: ‎12-19-2008
Message 2 of 11 (1,442 Views)

Re: DP6.2 telnet localhost <Port> no responce - any IDEA???

are dp services online (type "omnisv -status" command)?
Frequent Advisor
Stefan Wusowski
Posts: 117
Registered: ‎04-23-2001
Message 3 of 11 (1,440 Views)

Re: DP6.2 telnet localhost <Port> no responce - any IDEA???

Hello,

omnisv is a command from CellServer it is not installed on Client Site! On Clinet the "omni" inet is running if I connect via telnet, because trace file is created!

 

;-)

Honored Contributor
Zigoze
Posts: 549
Registered: ‎12-19-2008
Message 4 of 11 (1,438 Views)

Re: DP6.2 telnet localhost <Port> no responce - any IDEA???

what happens if you telnet from your cell server to you client?

 

telnet <clientName> 9555

 

 

doing it locally on the client, what happens if you put your host name, instead of "localhost"?

 

did you change the port on both cell server and client? both have to be operating on the same port... you cannot have server on one port, and client on another...

 

hope this helps...

Frequent Advisor
Stefan Wusowski
Posts: 117
Registered: ‎04-23-2001
Message 5 of 11 (1,434 Views)

Re: DP6.2 telnet localhost <Port> no responce - any IDEA???

Hey Zigoze,

CS to Client is the same as to localhost. Local IP-Addresses or Name is the same - connection closed.

 

Telnet Client to CS are OK no problem. It seem to be a local problem.

 

Yes, we changed to DP Port on complete environment, since many year.

 

Greetings

Trusted Contributor
ranjithpk
Posts: 117
Registered: ‎07-10-2011
Message 6 of 11 (1,428 Views)

Re: DP6.2 telnet localhost <Port> no responce - any IDEA???

Are you adding a Linux client?

1.if so ,could you please check whether 5555 is used by any other service (grep 5555 /etc/servcies).then comment it out ,if you dont need that service or change DP port number.

2. check rexce/rshservice is installed and make it on (chkconfig rexec on)

3.check securetty file.

4.restart xinetd service (servcie xinetd restart) .now just try adding client.

Regards,
Ranjith
Honored Contributor
Shishir Misra
Posts: 432
Registered: ‎12-19-2004
Message 7 of 11 (1,424 Views)

Re: DP6.2 telnet localhost <Port> no responce - any IDEA???

Hi.

   Do you have openVPN running on this server? If yes, then you may need a patch from HP support.

Regards,

Shishir

Occasional Contributor
M. Bianchy
Posts: 5
Registered: ‎10-21-2009
Message 8 of 11 (1,326 Views)

Re: DP6.2 telnet localhost <Port> no responce - any IDEA???

Hi Shishir,

 

as I have the very same problem (openVPN running & segfaults in inet, rds and various other DP programs)

 

can you please be so kind an tell what patch is necessary? Downgrade to DP6.11 would not be an option (DP6.11 runned smoothly even with running openVPN tunnels...)

Honored Contributor
Shishir Misra
Posts: 432
Registered: ‎12-19-2004
Message 9 of 11 (1,314 Views)

Re: DP6.2 telnet localhost <Port> no responce - any IDEA???

Hi.

    The fix has not been released as a general patch yet. You'll need to open a case with HP Support and ask for a hot fix.

Regards,

Shishir

Occasional Contributor
M. Bianchy
Posts: 5
Registered: ‎10-21-2009
Message 10 of 11 (1,300 Views)

Re: DP6.2 telnet localhost <Port> no responce - any IDEA???

So the GR patch is to be expected soon? (Currently I have no customer with a support contract which is facing this particular problem)

Honored Contributor
Sebastian.Koehler
Posts: 1,157
Registered: ‎02-27-2007
Message 11 of 11 (1,294 Views)

Re: DP6.2 telnet localhost <Port> no responce - any IDEA???

The fix mentioned seems to be QCCR2A33419. Is this correct?

Inet results in a segfault
http://support.openview.hp.com/selfsolve/document/KM1242231

Regards,
Sebastian
---
Assign a kudo to this post, if you find it useful.
The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation.